TD-SCDMA Measurements (R&S FSW-K76/-K77)
Contents
  • Welcome to the TD-SCDMA Applications
  • Measurements and Result Display
  • Measurement Basics
  • I/Q Data Import and Export
  • Configuration
  • Analysis
  • Optimizing and Troubleshooting the Measurement
  • How to Perform Measurements in TD-SCDMA Applications
  • Remote Commands for TD-SCDMA Measurements
  • List of Commands
Top


Welcome to the TD-SCDMA Applications

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Welcome to the TD-SCDMA Applications
Welcome to the TD-SCDMA Applications

The TD-SCDMA applications add functionality to the R&S FSW to perform code domain analysis or power measurements according to the TD-SCDMA standard.

R&S FSW-K76 performs Base Transceiver Station (BTS) measurements (for downlink signals).

R&S FSW-K77 performs User Equipment (UE) measurements (for uplink signals).

In particular, the TD-SCDMA applications feature:

  • Code domain analysis, providing results like code domain power, EVM, peak code domain error etc.
  • Various power measurements
  • Spectrum Emission Mask measurements
  • Statistical (CCDF) evaluation

This user manual contains a description of the functionality that the application provides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage (http://www2.rohde-schwarz.com/product/FSW.html).

Installation

You can find detailed installation instructions in the R&S FSW Getting Started manual or in the Release Notes.

Contents
  • Starting the TD-SCDMA Application
  • Understanding the Display Information


Starting the TD-SCDMA Application

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Welcome to the TD-SCDMA Applications > Starting the TD-SCDMA Application
Starting the TD-SCDMA Application

The TD-SCDMA measurements require a special application on the R&S FSW.

To activate the TD-SCDMA applications

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "TD-SCDMA BTS" or "TD-SCDMA UE" item.

    The R&S FSW opens a new measurement channel for the TD-SCDMA application.

For details see "Applications and Operating Modes" .

A Code Domain Analysis measurement is started immediately with the default settings. It can be configured in the TD-SCDMA "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu (see "Configuration Overview").

Multiple Measurement Channels and Sequencer Function

When you activate an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application.

Only one measurement can be performed at any time, namely the one in the currently active channel. However, in order to perform the configured measurements consecutively, a Sequencer function is provided.

If activated, the measurements configured in the currently active channels are performed one after the other in the order of the tabs. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the tabs (including the "MultiView") as the measurements are performed. Sequential operation itself is independent of the currently displayed tab.

For details on the Sequencer function see "Running a Sequence of Measurements" .


Understanding the Display Information

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Welcome to the TD-SCDMA Applications > Understanding the Display Information
Understanding the Display Information

The following figure shows a measurement diagram during a TD-SCDMA BTS measurement. All different information areas are labeled. They are explained in more detail in the following sections.

(The basic screen elements are identical for TD-SCDMA UE measurements.)

1 = Channel bar for firmware and measurement settings
2+3 = Window title bar with diagram-specific (trace) information
4 = Diagram area
5 = Diagram footer with diagram-specific information
6 = Instrument status bar with error messages, progress bar and date/time display
MSRA operating mode

In MSRA operating mode, additional tabs and elements are available. A colored background of the screen behind the measurement channel tabs indicates that you are in MSRA operating mode.

For details on the MSRA operating mode see "Applications and Operating Modes" .

Channel bar information

In TD-SCDMA applications, when performing Code Domain Analysis, the R&S FSW screen display deviates from the Spectrum application. For Frequency and time domain measurements, the familiar settings are displayed (see the R&S FSW Getting Started manual).

Hardware settings displayed in the channel bar in TD-SCDMA applications for Code Domain Analysis

Ref Level

Reference level

Att

Mechanical and electronic RF attenuation

Freq

Center frequency for the RF signal

Channel

Channel number (code number and spreading factor)

Slot

Slot of the (CPICH) channel

Code Power

Power result mode:

  • Absolute
  • Relative to total power of the data parts of the signal

Symbol Rate

Symbol rate of the current channel

Window title bar information

For each diagram, the header provides the following information:

Window title bar information in TD-SCDMA applications
1 = Window number
2 = Window type
3 = Trace color
4 = Trace number
5 = Detector
Diagram footer information

For most graphical evaluations the diagram footer (beneath the diagram) contains scaling information for the x-axis, where applicable:

  • Start slot/symbol/code
  • slot/symbol/code per division
  • Stop slot/symbol/code
Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.


Measurements and Result Display

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display
Measurements and Result Display

The TD-SCDMA applications provide several different measurements for signals according to the TD-SCDMA mode. The main and default measurement is Code Domain Analysis. In addition to the code domain power measurements specified by the TD-SCDMA standard, the TD-SCDMA options offer measurements with predefined settings in the frequency and time domain, e.g. channel power or power vs time measurements.

Evaluation methods

The captured and processed data for each measurement can be evaluated with various different methods. All evaluation methods available for the selected TD-SCDMA measurement are displayed in the evaluation bar in SmartGrid mode.

Evaluation range

You can restrict evaluation to a specific channel, frame or slot, depending on the evaluation method. See "Evaluation Range".

Contents
  • Code Domain Analysis
  • Frequency and Time Domain Measurements


Code Domain Analysis

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis
Code Domain Analysis

The Code Domain Analysis measurement provides various evaluation methods and result diagrams.

A signal section containing at least two TD-SCDMA subframes is recorded for analysis and then searched through to find the start of the first subframe. If a subframe start is found in the signal, the code domain power analysis is performed for the selected slot. The different evaluations are calculated from the captured I/Q data set. Therefore it is not necessary to start a new measurement in order to change the evaluation.

The TD-SCDMA applications provide the peak code domain error measurement and composite EVM specified by the TD-SCDMA standard, as well as the code domain power measurement of assigned and unassigned codes. The power can be displayed either for all channels in one slot, or for one channel in all slots. The composite constellation diagram of the entire signal can also be displayed. In addition, the symbols demodulated in a slot, their power, and the determined bits or the symbol EVM can be displayed for an active channel.

The power of a channel is always measured in relation to its symbol rate within the code domain. It can be displayed either as absolute values or relative to the total signal (data parts only). By default, the power relative to the total signal is displayed.

The composite EVM, peak code domain error and composite constellation measurements are also always referenced to the total signal.

Remote command:

CONF:CDP[:BTS]:MEAS CDP, see CONFigure:​CDPower:​MEASurement

Contents
  • Code Domain Parameters
  • Evaluation Methods for Code Domain Analysis
  • CDA Measurements in MSRA Operating Mode


Code Domain Parameters

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Code Domain Parameters
Code Domain Parameters

Two different types of measurement results are determined and displayed in the Result Summary: global results and channel results (for the selected channel).

The number of the slot and channel (code) at which the measurement is performed is indicated globally for the measurement in the channel bar.

The spreading code of the selected channel is indicated with the channel number in the channel bar and above the channel-specific results in the Result Summary.

In the Channel Table, the analysis results for all (active) channels are displayed individually.

General and slot-specific code domain power results in the Result Summary

Parameter

Description

Chip Rate Error

The chip rate error in ppm. A large chip rate error results in symbol errors and, therefore, in possible synchronization errors for code domain measurements. This measurement result is also valid if the application could not synchronize to the TD-SCDMA signal.

Trigger to Frame

The time difference between the beginning of the recorded signal section to the start of the first slot.

For triggered measurements, this difference is identical with the time difference of frame trigger (+ trigger offset) and the start of the first slot. If synchronization of the analyzer and input signal fails, the value of "Trigger to Frame" is not significant.

For non-triggered measurements, no result is available.

P Data

Average power of the slot's data parts (total and for each data part)

P Midamble

Power of the slot's midamble

Carrier Freq Error

The frequency error relative to the center frequency of the analyzer. The absolute frequency error is the sum of the analyzer and DUT frequency error. The specified value is averaged for one slot (see also "Synchronization fails")

IQ Offset

DC offset of the signal in the selected slot in %

IQ Imbalance

I/Q imbalance of signals in the selected slot in %

Active Channels

The number of active channels detected in the signal in the selected slot. Both the detected data channels and the control channels are considered active channels.

RHO

Quality parameter RHO for each slot.

According to the TD-SCDMA standard, Rho is the normalized, correlated power between the measured and the ideally generated reference signal.

Average RCDE

Average Relative Code Domain Error over all channels. The Average RCDE is calculated according to release 8 of the standard.

Composite EVM

The error vector magnitude (EVM) over the total signal in the selected slot. The EVM is the root of the ratio of the mean error power to the power of an ideally generated reference signal.

See also "Composite EVM"

Pk CDE (15 ksps)

The Peak Code Domain Error projects the difference between the measured signal and the ideal reference signal onto the spreading factor in the selected slot (see "Peak Code Domain Error"). The symbol rate, from which the spreading factor can be determined, is indicated in brackets.

DwPTS/UpPTS parameters
Optionally, the following parameters determined for the "Downlink Pilot Time Slot" (DwPTS) or the "Uplink Pilot Time Slot" (UpPTS, see also "Frames, Subframes and Slots") can be displayed in the Result Summary.
  • "Subframe Number": Subframe the slot belongs to
  • "DwPTS/UpPTS Active": Indicates whether DwPTS/UpPTS slot is active
  • "DwPTS/UpPTS Power": Power in the DwPTS/UpPTS slot
  • "DwPTS/UpPTS Rho": RHO for the DwPTS/UpPTS slot
  • "DwPTS/UpPTS EVM(RMS)": EVM (RMS) for the DwPTS/UpPTS slot
  • "DwPTS/UpPTS EVM(Peak)": EVM (Peak) for the DwPTS/UpPTS slot

The channel-specific results are displayed in the "Result Summary", the "Channel Table", or both.

Channel-specific code domain power results

Parameter

Description

Channel Type

Detected type of channel (see table "Available channel types in TD-SCDMA signals")

Ch.SF

Channel number including the spreading factor (in the form <Channel>.<SF>).

SymRate[ksps]

Symbol rate at which the data in the channel is transmitted (in ksps)

Symbol EVM

RMS and peak EVM values per symbol (see "Symbol EVM")

Mod

Modulation type (QPSK, 8PSK, 16QAM or 64QAM)

Power [dBm]

Channel power, absolute

Power [dB]

Channel power, relative to total power of the data parts of the signal

MA.shift

Midamble shift

For channels, this is the shift of the associated midamble if a common or default midamble assignment is detected (see "Data Fields and Midambles")

ΔMid1/2

The power offset between the midamble and the sum power of its channels in data part 1 or 2, respectively.

The TD-SCDMA specifications require that the midamble and its channels must have the same power. These parameters show if a common or default midamble assignment is detected (see "Data Fields and Midambles").


Evaluation Methods for Code Domain Analysis

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis
Evaluation Methods for Code Domain Analysis

The captured I/Q data can be evaluated using various different methods without having to start a new measurement. All evaluation methods available for the selected TD-SCDMA measurement are displayed in the evaluation bar in SmartGrid mode.

To activate SmartGrid mode, do one of the following:
  • Select the "SmartGrid" icon from the toolbar.
  • Select the "Display Config" button in the configuration "Overview".
  • Select the "Display Config" softkey from the MEAS CONFIG menu.

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .

The selected evaluation also affects the results of the trace data query (see "Measurement Results for TRACe<n>[:DATA]? TRACE<n>").

└ Bitstream
└ Channel Table
└ Channel Table Configuration
└ Code Domain Power
└ Code Domain Error Power
└ Composite Constellation
└ Composite EVM
└ Mag Error vs Chip
└ Marker Table
└ Peak Code Domain Error
└ Phase Error vs Chip
└ Power vs Slot
└ Power vs Symbol
└ Result Summary
└ Symbol Constellation
└ Symbol EVM
└ Symbol Magnitude Error
└ Symbol Phase Error


Bitstream

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Bitstream
Bitstream

The Bitstream evaluation displays the demodulated bits of a selected channel for a given slot.

Depending on the spreading factor (symbol rate) of the channel, a slot may contain a minimum of 44 and a maximum of 704 symbols. Depending on the modulation type, a symbol consists of 2 to 6 bits (see table "Channel parameters and their dependencies").

TIP: Select a specific symbol using the MKR key while the display is focused. If you enter a number, the marker jumps to the selected symbol, which is highlighted by a blue circle.

Remote command:

LAY:ADD? '1',RIGH, BITS, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:​DATA]?


Channel Table

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Channel Table
Channel Table

The Channel Table evaluation displays the detected channels and the results of the code domain power measurement. The measurement evaluates the total signal over the selected slot. The Channel Table can contain a maximum of 16 entries, which corresponds to the 16 codes that can be assigned for a spreading factor of 16.

The sort order of the table is configurable (see "Channel Table Sort Order"), either by code number (starting with midambles, then control channels, then data channels), or by midamble, where all channels are listed below the midamble they belong to.

By default, only active channels are included in the display; to include inactive channels, see "Channel Table Configuration". Inactive channels are marked with dashes in the "Channel Type", "SymRate" and "Modulation" columns.

For details on the displayed results see table "Channel-specific code domain power results".

Remote command:

LAY:ADD? '1',RIGH, CTABle, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:​DATA]?

└ Channel Table Configuration


Channel Table Configuration

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Channel Table > Channel Table Configuration
Channel Table Configuration

You can configure which parameters are displayed in the Channel Table by selecting the table header. A "Table Configuration" dialog box is displayed in which you can select the columns to be displayed.

By default, only active channels are displayed. In order to display all channels, including the inactive ones, enable the "Show Inactive Channels" option.

For details on the displayed results see table "Channel-specific code domain power results".


Code Domain Power

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Code Domain Power
Code Domain Power

The Code Domain Power evaluation shows the power of all possible codes in the selected slot in the total signal. Since channel detection is based on a power threshold (see "Channels and Codes"), it is important that all codes have a similar power level (no more than 1.5 dB difference to the average power in the slot). Thus, the scaling of the code domain power is relative to the average power of the data parts in the specified slot in the total signal by default. The x-axis shows the possible codes from 0 to the highest spreading factor. Due to the circumstance that the power is regulated from slot to slot, the result power may differ between different slots.

The codes are displayed using the following colors:
  • yellow: detected channels
  • red: selected channel (if a channel is made up of more than one code, all codes that belong to the channel are red)
  • green: no channel detected
Remote command:

LAY:ADD? '1',RIGH, CDPower, see LAYout:​ADD[:​WINDow]?

CALC:MARK:FUNC:CDP:RES? CDP, see CALCulate:​MARKer:​FUNCtion:​CDPower:​RESult?

TRACe<n>[:​DATA]?


Code Domain Error Power

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Code Domain Error Power
Code Domain Error Power

The Code Domain Error Power is the difference in power between the measured and an ideally generated reference signal. The number of codes corresponds to the spreading factor. The y-axis shows the error power for each code. Since it is an error power (as opposed to the measured power), both active and inactive channels can be analyzed at a glance.

The codes are displayed using the following colors:
  • yellow: detected channels
  • red: selected channel (if a channel is made up of more than one code, all codes that belong to the channel are red)
  • green: no channel detected
Remote command:

LAY:ADD? '1',RIGH, CDEPower, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:​DATA]?


Composite Constellation

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Composite Constellation
Composite Constellation

In the Composite Constellation result display the constellation points of the 864 chips are displayed for the specified slot. This data is determined inside the DSP even before the channel search. Thus, it is not possible to assign constellation points to channels. The constellation points are displayed normalized with respect to the total power.

Note: The red circle indicates the value "1"

Remote command:

LAY:ADD? '1',RIGH, CCONst, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:​DATA]?


Composite EVM

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Composite EVM
Composite EVM

The Composite EVM evaluation determines the error vector magnitude (EVM) over the total signal. The EVM is the root of the ratio of the mean error power to the power of an ideally generated reference signal. To calculate the mean error power, the root mean square average of the real and imaginary parts of the signal is used. The EVM is shown in %. This evaluation is useful to determine the modulation accuracy.

The result display shows the composite EVM values per slot.

The slots are displayed according to the detected channels using the following colors:
  • yellow: active channel
  • red: selected channel (if a channel is made up of more than one code, all codes that belong to the channel are red)
  • none: no active channels

Only the channels detected as being active are used to generate the ideal reference signal. If a channel is not detected as being active, e.g. on account of low power, the difference between the test signal and the reference signal and therefore the composite EVM is very large.

Distortions also occur if unassigned codes are wrongly given the status of "active channel". To obtain reliable measurement results, select an adequate channel threshold.

Remote command:

LAY:ADD? '1',RIGH, CEVM, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:​DATA]?


Mag Error vs Chip

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Mag Error vs Chip
Mag Error vs Chip

Mag Error vs Chip activates the Magnitude Error versus chip display. The magnitude error is displayed for all chips of the selected slot.

The magnitude error is calculated as the difference of the magnitude of the received signal to the magnitude of the reference signal. The reference signal is estimated from the channel configuration of all active channels. The magnitude error is related to the square root of the mean power of reference signal and given in percent.

where:

MAGk | magnitude error of chip number k
sk | complex chip value of received signal
xk | complex chip value of reference signal
k | index number of the evaluated chip
N | number of chips at each CPICH slot
n | index number for mean power calculation of reference signal
Remote command:

LAY:ADD? '1',RIGH, MECHip, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Marker Table

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

This table may be displayed automatically if configured accordingly (see "Marker Table Display").

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Peak Code Domain Error

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Peak Code Domain Error
Peak Code Domain Error

The Peak Code Domain Error is defined as the maximum value for the Code Domain Error for all codes.

In line with the TD-SCDMA specifications, the error is calculated between the measurement signal and the ideal reference signal for a given slot and for each active code for any of the supported spreading codes.

For inactive slots (containing no active channels), no results are available as no reference power is available.

The result display shows the peak error values per slot.

The slots are displayed according to the detected channels using the following colors:
  • yellow: active channel
  • red: selected channel (if a channel is made up of more than one code, all codes that belong to the channel are red)
  • none: no active channels

Only the channels detected as being active are used to generate the ideal reference signal. If a channel is not detected as being active, e.g. on account of low power, the difference between the test signal and the reference signal is too large. The result display therefore shows a peak code domain error that is too high for all slots.

Distortions also occur if unassigned codes are wrongly given the status of "active channel". To obtain reliable measurement results, select an adequate channel threshold.

Remote command:

LAY:ADD? '1',RIGH, PCDerror, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:​DATA]?


Phase Error vs Chip

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Phase Error vs Chip
Phase Error vs Chip

"Phase Error vs Chip" activates the phase error versus chip display. The phase error is displayed for all chips of the slected slot.

The phase error is calculated by the difference of the phase of received signal and phase of reference signal. The reference signal is estimated from the channel configuration of all active channels. The phase error is given in degrees in a range of +180° to -180°.

Calculating the magnitude, phase and vector error per chip

where:

PHIk | phase error of chip number k
sk | complex chip value of received signal
xk | complex chip value of reference signal
k | index number of the evaluated chip
N | number of chips at each CPICH slot
φ(x) | phase calculation of a complex value
Remote command:

LAY:ADD? '1',RIGH, PECHip, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Power vs Slot

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Power vs Slot
Power vs Slot

The Power vs Slot evaluation displays the power of the selected channel for each slot. The power is displayed either absolute or relative to the total power of the data parts of the signal. The measurement evaluates a single channel over all slots.

The slots are displayed according to the detected channels using the following colors:
  • yellow: active channel
  • green: channel with alias power (power results from channels with a different code class)
  • cyan: inactive channel
  • red: selected channel (if a channel is made up of more than one code, all codes that belong to the channel are red)
Remote command:

LAY:ADD? '1',RIGH, PSLot, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:​DATA]?


Power vs Symbol

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Power vs Symbol
Power vs Symbol

The Power vs Symbol evaluation shows the power measured for each symbol in the selected channel and the selected slot. The power is not averaged here.

Depending on the spreading factor (symbol rate) of the channel, a slot may contain a minimum of 44 and a maximum of 704 symbols (see table "Channel parameters and their dependencies").

Remote command:

LAY:ADD? '1',RIGH, PSYMbol, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:​DATA]?


Result Summary

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Result Summary
Result Summary

The Result Summary evaluation displays a list of measurement results on the screen. For details see "Code Domain Parameters".

Note: DwPTS and UpPTS parameters. Optionally, the parameters determined for the "Downlink Pilot Time Slot" (DwPTS) or "Uplink Pilot Time Slot" (UpPTS, see also "Frames, Subframes and Slots") can be displayed in the Result Summary (see "Show DwPTS Results (BTS mode)").

Remote command:

LAY:ADD? '1',RIGH, RSUMmary, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:​DATA]?

CALCulate:​MARKer:​FUNCtion:​CDPower:​RESult?


Symbol Constellation

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Symbol Constellation
Symbol Constellation

The Symbol Constellation evaluation shows all modulated symbols of the selected channel and the selected slot.

Note: The red circle indicates the value "1"

Remote command:

LAY:ADD? '1',RIGH, SCONst, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:​DATA]?


Symbol EVM

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Symbol EVM
Symbol EVM

The Symbol EVM evaluation shows the error between the measured signal and the ideal reference signal in percent for the selected channel and the selected slot. A trace over all symbols of a slot is drawn. The number of symbols depends on the symbol rate (or spreading factor) of the channel (see table "Channel parameters and their dependencies").

Remote command:

LAY:ADD? '1',RIGH, SEVM, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:​DATA]?


Symbol Magnitude Error

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Symbol Magnitude Error
Symbol Magnitude Error

The "Symbol Magnitude Error" is calculated analogous to symbol EVM. The result is one symbol magnitude error value for each symbol of the slot of a special channel. Positive values of symbol magnitude error indicate a symbol magnitude that is larger than the expected ideal value; negative symbol magnitude errors indicate a symbol magnitude that is less than the ideal one.The symbol magnitude error is the difference between the magnitude of the received symbol and that of the reference symbol, related to the magnitude of the reference symbol.

Remote command:

LAY:ADD? '1',RIGH, SMERror, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Symbol Phase Error

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Symbol Phase Error
Symbol Phase Error

The "Symbol Phase Error" is calculated analogous to symbol EVM. The result is one symbol phase error value for each symbol of the slot of a special channel. Positive values of symbol phase error indicate a symbol phase that is larger than the expected ideal value; negative symbol phase errors indicate a symbol phase that is less than the ideal one.

Remote command:

LAY:ADD? '1',RIGH, SPERror, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


CDA Measurements in MSRA Operating Mode

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Code Domain Analysis > CDA Measurements in MSRA Operating Mode
CDA Measurements in MSRA Operating Mode

The TD-SCDMA BTS application can also be used to analyze data in MSRA operating mode.

In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications receive an extract of the captured data for analysis, referred to as the application data. The application data range is indicated in the MSRA Master by vertical blue lines.

However, the individual result displays of the application need not analyze the complete data range. The data range that is actually analyzed by the individual result display is referred to as the analysis interval.

In the TD-SCDMA BTS application the analysis interval is automatically determined according to the selected channel, slot or frame to analyze which is defined for the evaluation range, depending on the result display. The currently used analysis interval (in seconds, related to capture buffer start) is indicated in the window header for each result display.

For details on the MSRA operating mode see "Applications and Operating Modes" .


Frequency and Time Domain Measurements

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Frequency and Time Domain Measurements
Frequency and Time Domain Measurements

In addition to the Code Domain Analysis measurements, the TD-SCDMA applications also provide some frequency and time domain measurements as defined in the TD-SCDMA standard. Frequency and time domain measurements are identical to the corresponding measurements in the base unit, but configured according to the requirements of the TD-SCDMA standard.

For details on these measurements see "Measurements" .

MSRA operating mode

Frequency and time domain measurements are not available in MSRA operating mode.

For details on the MSRA operating mode see "Applications and Operating Modes" .

Contents
  • Measurement Types and Results in the Frequency and Time Domain
  • Evaluation Methods for Frequency and Time Measurements


Measurement Types and Results in the Frequency and Time Domain

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Frequency and Time Domain Measurements > Measurement Types and Results in the Frequency and Time Domain
Measurement Types and Results in the Frequency and Time Domain

The TD-SCDMA applications provide the following frequency and time domain measurements:

└ Power vs Time
└ Power
└ Ch Power ACLR
└ Spectrum Emission Mask
└ Occupied Bandwidth
└ CCDF


Power vs Time

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Frequency and Time Domain Measurements > Measurement Types and Results in the Frequency and Time Domain > Power vs Time
Power vs Time

The Power vs Time measurement checks the signal power in the time domain against a transmission power mask defined by the TD-SCDMA specification ("transmit ON/OFF power time mask"). This measurement is meant to ensure that each burst remains within a tight power range, i.e. rises and falls very quickly.

For downlink measurements, the power in the slots reserved for the uplink transmission must quickly fall to the low value and then quickly rise to high again in the slots for downlink transmission. Thus, the slots of interest in downlink Power vs Time measurements are slot 1 to the slot indicated by the Switching Point, in which the OFF power is checked.

In the TD-SCDMA UE application, it is assumed that only one uplink device is to be checked during one measurement, and that each uplink device may use only a single slot for transmission. Thus, for uplink measurements, only one slot is checked against the transmit mask. Since the TD-SCDMA UE application has no information which slot is being used, it assumes the first slot in which a burst is detected to be slot 1, the first slot for uplink transmission. In this slot, the power must quickly rise to the high value, and quickly fall back to low at the end. Thus, the slot of interest in uplink Power vs Time measurements is slot 1, which cannot be changed, and in which the ON power is checked.

In order to perform the power check, the TD-SCDMA application must synchronize the transmit mask to the current signal, as the mask is defined relative to a slot start.

The application measures the power in the defined number of subframes in the time domain and calculates the average power in the slots of interest. It then compares the averaged power of the signal against the mask for allowed transmission power.

The mask consists of four defined intervals:

  • before the burst
  • during fall time
  • during the low time
  • during the rise time
Note: For UE measurements, the ON power is checked, thus the mask is defined for the following intervals:
  • before the burst
  • during the rise time
  • during the high time
  • during fall time

As a result, the power vs time trace is displayed. The result of the limit check (Pass/Fail) is also indicated in the diagram.

The numeric results are provided in the List Evaluation result display (see "List Evaluation").

For details see "Power vs Time".

Remote command:

CONF:CDP[:BTS]:MEAS PVT, see CONFigure:​CDPower:​MEASurement

Querying results:

TRAC:DATA? TRACE1, see TRACe<n>[:​DATA]?

CALCulate:​LIMit<k>:​FAIL?

CONFigure:​CDPower[:​BTS]:​PVTime:​LIST:​RESult?


Power

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Frequency and Time Domain Measurements > Measurement Types and Results in the Frequency and Time Domain > Power
Power

The Power measurement determines the TD-SCDMA signal channel power. The R&S FSW measures the signal power in a single channel with a bandwidth of 1.2288 MHz. The results are based on the root mean square.

For details see "Signal Channel Power Measurements".

Remote command:

CONF:CDP[:BTS]:MEAS POW, see CONFigure:​CDPower:​MEASurement

Querying results: CALC:MARK:FUNC:POW:RES? CPOW, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?


Ch Power ACLR

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Frequency and Time Domain Measurements > Measurement Types and Results in the Frequency and Time Domain > Ch Power ACLR
Ch Power ACLR

Channel Power ACLR performs an adjacent channel power measurement in the default setting according to TD-SCDMA specifications (adjacent channel leakage ratio).

The measurement range can be adapted to a slot range of the current TD-SCDMA signal.

The R&S FSW measures the channel power and the relative power of the adjacent channels and of the alternate channels. The results are displayed below the diagram.

For details see "Channel Power (ACLR) Measurements".

Remote command:

CONF:CDP[:BTS]:MEAS ACLR, see CONFigure:​CDPower:​MEASurement

Querying results:

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?


Spectrum Emission Mask

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Frequency and Time Domain Measurements > Measurement Types and Results in the Frequency and Time Domain > Spectrum Emission Mask
Spectrum Emission Mask

The Spectrum Emission Mask measurement determines the power of the TD-SCDMA signal in defined offsets from the carrier and compares the power values with a spectral mask specified by TD-SCDMA.

For details see "Spectrum Emission Mask".

Remote command:

CONF:CDP[:BTS]:MEAS ESP, see CONFigure:​CDPower:​MEASurement

Querying results:

CALC:MARK:FUNC:POW:RES? CPOW, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALCulate:​LIMit<k>:​FAIL?


Occupied Bandwidth

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Frequency and Time Domain Measurements > Measurement Types and Results in the Frequency and Time Domain > Occupied Bandwidth
Occupied Bandwidth

The Occupied Bandwidth measurement determines the bandwidth that the signal occupies.

The occupied bandwidth is defined as the bandwidth in which – in default settings - 99 % of the total signal power is to be found. The percentage of the signal power to be included in the bandwidth measurement can be changed.

The occupied bandwidth (Occ BW) and the frequency markers are displayed in the marker table.

For details see "Occupied Bandwidth".

Remote command:

CONF:CDP[:BTS]:MEAS OBAN, see CONFigure:​CDPower:​MEASurement

Querying results:

CALC:MARK:FUNC:POW:RES? OBW, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?


CCDF

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Frequency and Time Domain Measurements > Measurement Types and Results in the Frequency and Time Domain > CCDF
CCDF

The CCDF measurement determines the distribution of the signal amplitudes (complementary cumulative distribution function). The CCDF and the Crest factor are displayed. For the purposes of this measurement, a signal section of user-definable length is recorded continuously in the zero span, and the distribution of the signal amplitudes is evaluated.

For details see "CCDF".

Remote command:

CONF:CDP[:BTS]:MEAS CCDF, see CONFigure:​CDPower:​MEASurement

Querying results:

CALCulate:​STATistics:​RESult<t>?


Evaluation Methods for Frequency and Time Measurements

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Frequency and Time Domain Measurements > Evaluation Methods for Frequency and Time Measurements
Evaluation Methods for Frequency and Time Measurements

The evaluation methods for frequency and time domain measurements are identical to those in the Spectrum application.

└ Diagram
└ List Evaluation
└ Result Summary
└ Marker Table
└ Marker Peak List


Diagram

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Frequency and Time Domain Measurements > Evaluation Methods for Frequency and Time Measurements > Diagram
Diagram

Displays a basic level vs. frequency or level vs. time diagram of the measured data to evaluate the results graphically. This is the default evaluation method. Which data is displayed in the diagram depends on the "Trace" settings. Scaling for the y-axis can be configured.

Remote command:

LAY:ADD? '1',RIGH, DIAG, see LAYout:​ADD[:​WINDow]?


List Evaluation

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Frequency and Time Domain Measurements > Evaluation Methods for Frequency and Time Measurements > List Evaluation
List Evaluation

The list evaluation provides the numerical results for the Power vs Time measurement.

The List Evaluation displays the following information:

Column | Description
Start / Stop | Start and stop time of the individual time intervals of the Emission Envelope Mask (in ns)
Avg | Average power measured in mask interval
Max | Maximum power measured in mask interval
Time @ MaxPower | The exact point in time when the maximum power occured

For details see "Power vs Time".

Remote command:

LAY:ADD? '1',RIGH, LEV, see LAYout:​ADD[:​WINDow]?


Result Summary

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Frequency and Time Domain Measurements > Evaluation Methods for Frequency and Time Measurements > Result Summary
Result Summary

Result summaries provide the results of specific measurement functions in a table for numerical evaluation. The contents of the result summary vary depending on the selected measurement function. See the description of the individual measurement functions for details.

Remote command:

LAY:ADD? '1',RIGH, RSUM, see LAYout:​ADD[:​WINDow]?


Marker Table

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Frequency and Time Domain Measurements > Evaluation Methods for Frequency and Time Measurements > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

This table may be displayed automatically if configured accordingly (see "Marker Table Display").

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Marker Peak List

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurements and Result Display > Frequency and Time Domain Measurements > Evaluation Methods for Frequency and Time Measurements > Marker Peak List
Marker Peak List

The marker peak list determines the frequencies and levels of peaks in the spectrum or time domain. How many peaks are displayed can be defined, as well as the sort order. In addition, the detected peaks can be indicated in the diagram. The peak list can also be exported to a file for analysis in an external application.

Remote command:

LAY:ADD? '1',RIGH, PEAK, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Measurement Basics

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurement Basics
Measurement Basics

Some background knowledge on basic terms and principles used in TD-SCDMA measurements is provided here for a better understanding of the required configuration settings.

Contents
  • Short Introduction to TD-SCDMA
  • Frames, Subframes and Slots
  • Channels and Codes
  • Data Fields and Midambles
  • CDA Measurements in MSRA Operating Mode


Short Introduction to TD-SCDMA

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurement Basics > Short Introduction to TD-SCDMA
Short Introduction to TD-SCDMA

While many communication standards, such as WCDMA or cdma2000, distribute the data from different users to different frequencies within a specific band (FDD mode), TD-SCDMA distributes the data in time (TDD mode). Furthermore, the mentioned FDD-based standards require two distinct frequency bands for uplink (to the base station) and downlink (from the base station) communication. TD-SCDMA, on the other hand, can adjust the number of time slots (and thus the data rate) used for downlink or uplink dynamically, according to the current traffic requirements. The available time slots can be distributed flexibly either to several users, or to a single user requiring a higher data rate. This is a benefit especially when transmitting Internet data, as usually more data is downloaded than uploaded.

Distributing the data in time also means the TD-SCDMA standard can use the same carrier frequency for both uplink and downlink.


Frames, Subframes and Slots

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurement Basics > Frames, Subframes and Slots
Frames, Subframes and Slots

The structure of a typical TD-SCDMA signal is shown in figure "TD-SCDMA signal structure".

A TD-SCDMA signal is divided into frames with a length of 10 ms each. The frames are further divided into 2 subframes, with a length of 5 ms each. For the physical communication layer, mostly the subframes are of interest.

Each subframe consists of 7 slots, named TS0 to TS6, plus a "Downlink Pilot Time Slot" (DwPTS) and an "Uplink Pilot Time Slot" (UpPTS), which are required to transmit synchronization codes. Between the two synchronization areas, a guard period of 75 µs is inserted. Each slot has a length of 0.675 ms.

The first slot (TS0) of a subframe is always reserved for downlink, the second slot (TS1) is always reserved for uplink. The switching point indicates the time after which subsequent slots are available for downlink again. The system is informed about the current location of the switching point by higher layers.

TD-SCDMA signal structure
Synchronization

The individual channels in the input signal need to be synchronized to detect timing offsets in the slot spacings. To do so, either slot 0 (BTS mode) or slot 1 (UE mode), or the "Downlink Pilot Time Slot" (DwPTS) or "Uplink Pilot Time Slot" (UpPTS) can be used.

In UE mode, if the UpPTS is used for synchronization, you must define the SYNC-UL code to be used. This code depends on the used scrambling code as indicated in the following table.

Possible SYNC-UL codes depending on scrambling code
Code Group | Scrambling Code | Sync -UL Code
Group 1 | 0 to 3 | 0 to 7
Group 2 | 4 to 7 | 8 to 15
... | ... | ...
Group 32 | 124 to 127 | 248 to 255


Channels and Codes

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurement Basics > Channels and Codes
Channels and Codes

Within each time slot, up to 16 code channels may be transmitted. Each channel is spread over one to 16 codes (also referred to as channelization codes), depending on the code class of the channel. The code class specifies the spreading factor of the channel and thus the number of possible channels per slot.

Relationship between code class, channels and spreading factor
Code class | Spreading factor = No. channels per slot
0 | 1
1 | 2
2 | 4
3 | 8
4 | 16
Chips

The user data is spread to code channels across the available bandwidth using the spreading factor before transmission. The spreaded bits are referred to as chips. Each slot consists of 864 chips. The chips are transferred at a rate of 1.28 Megachips per second (Mcps).

Active and inactive codes/slots

During code domain analysis, the power in the selected slot in the captured subframes is measured in order to detect active channels. If the total power in the slot does not exceed a threshold, the slot is considered to be inactive. Otherwise, the slot is analyzed to detect channels.

To do so, the data in the slot is unscrambled according to the defined scrambling code and carrier (= center) frequency. Then, all possible spreading sequences are applied to the unscrambled data, defining the individual channels. Each despread channel whose power exceeds the channel threshold is considered to be active. The reference signal is then generated according to the active channels only.

If the power threshold for inactive channels is not set correctly, power from supposedly inactive channels contributes to the peak code domain error, leading to false results.

In order to determine the correct threshold, the Code Domain Power evaluation is a useful instrument (see "Code Domain Power").

Contents
  • Special Channels
  • Channel Characteristics


Special Channels

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurement Basics > Channels and Codes > Special Channels
Special Channels

In order to control the data transmission between the sender and the receiver, specific symbols must be included in the transmitted data. This data is included in special data channels defined by the 3GPP standard which use fixed codes in the code domain. Thus, they can be detected easily by the receiver.

Special channels in TD-SCDMA signals
Name | Description | Slot No. | Spreading factor (SF) | Code No. (1...SF)
P-CCPCH1 | Primary common control physical channel 1 | 0 | 16 | 1
P-CCPCH2 | Primary common control physical channel 2 | 0 | 16 | 2

Other special control channels do not have a fixed code, but are identified by higher layers.

The user data is contained in the Dedicated Physical Channel (DPCH).

The detected type of the channel is indicated in the Channel Table evaluation according to the following assignment:

Available channel types in TD-SCDMA signals
No. | Channel type
0 | inactive
1 | midamble
2 | DPCH (user data)


Channel Characteristics

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurement Basics > Channels and Codes > Channel Characteristics
Channel Characteristics

The spreading factor used by a channel determines the data rate. Based on a subframe length of 5 ms, the bits per slot can be calculated.

The modulation used to transmit the user data determines how many bits are required for each symbol, and thus the maximum number of symbols per slot. Thus, the symbol rate depends on the used modulation and the data rate. The following tables show the relationships:

Number of symbols per slot depending on spreading factor
Spreading factor | Number of symbols
16 | 44
8 | 88
4 | 176
2 | 352
1 | 704
Number of bits per symbol depending on modulation
Modulation | Number of bits per symbol
QPSK | 2
8PSK | 3
16QAM | 4
64QAM | 6
Number of bits per slot depending on modulation and spreading factor
SF | Modulation
 | QPSK | 8PSK | 16QAM | 64QAM
 | Number of bits
16 | 88 | 132 | 176 | 264
8 | 176 | 264 | 352 | 528
4 | 352 | 528 | 704 | 1056
2 | 704 | 1056 | 1408 | 2112
1 | 1408 | 2112 | 2816 | 4224
Channel parameters and their dependencies
Spreading Factor | Symbols / Slot | QPSK |  | 8PSK |  | 16QAM |  | 64QAM
 |  | Bits per Slot | ksps | Bits per slot | ksps | Bits per slot | ksps | Bits per slot | ksps
1 | 704 | 1408 | 281.6 | 2112 | 422.4 | 2816 | 563.2 | 4224 | 844.8
2 | 352 | 704 | 140.8 | 1056 | 211.2 | 1408 | 281.6 | 2112 | 422.4
4 | 176 | 352 | 70.4 | 528 | 105.6 | 704 | 140.8 | 1056 | 211.2
8 | 88 | 176 | 35.2 | 264 | 52.8 | 352 | 70.4 | 528 | 105.6
16 | 44 | 88 | 17.6 | 132 | 26.4 | 176 | 35.2 | 264 | 52.8
Channel notation

Channels are generally indicated by their channel number and spreading factor (in the form <Channel>.<SF>).

Selected codes and channels

In the result displays that refer to channels, the currently selected channel is highlighted in the diagram. You select a channel by entering a channel number and spreading factor in the "Evaluation Range" settings.

The specified channel is selected and marked in red in the corresponding result displays, if active. If no spreading factor is specified, the spreading factor 16 is assumed. For inactive (unused) channels, the code on the basis of the spreading factor 16 is highlighted.

Example: Enter 4.8

Channel 4 is marked at spreading factor 8 (35.2 ksps) if the channel is active, otherwise code 7 at spreading factor 16.


Data Fields and Midambles

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurement Basics > Data Fields and Midambles
Data Fields and Midambles

Each slot consists of 864 chips, of which 704 are used to transmit data. The data is divided into two data fields with 352 chips each. The midamble (consisting of the remaining 144 chips) is located between the two data fields. A guard period of 16 chips completes the slot.

TD-SCDMA slot structure
Midamble shifts

The midamble is a known symbol sequence which can be used to synchronize the signal in the slot, and to distinguish the data from individual users in a single slot. Different users can be separated by their different time shifts of the same basic midamble sequence. For each midamble shift, the known symbol sequence is rotated cyclically by a defined number of chips. The maximum number of possible midamble shifts defines the maximum number of possible users in a single slot.

Each user is thus identified by a particular time slot and a particular code on a particular carrier frequency.

Midamble assignment

A midamble is assigned to each code channel by the transmission side. Different methods of assigning midambles to code channels are available.

  • default midamble assignment
    Specific midambles are assigned to each channelization code according to a standard-specific rule
  • user specific midamble assignment
    Each code channel is assigned an individual midamble code; higher communication layers must determine which midamble belongs to which channelization code
  • common midamble assignment
    All code channels share a common midamble

The midamble to be inserted between the data fields in a slot is generated by superimposing the individual midambles of the codes.

The TD-SCDMA specifications require that the power of the midamble and the power of the data fields for a single slot must be identical. When using the default midamble assignment, this means that each individual midamble is transmitted with the same power as its assigned channelization code. For common midamble assignment, this means the (single) midamble is transmitted with the same power as the data fields. For user-specific assignment, the individual midambles are not known at this stage.

The parameters ΔMid1/2 in the Channel Table results show the power offset of the midamble to the data fields 1 or 2 for each channel (see table "Channel-specific code domain power results").


CDA Measurements in MSRA Operating Mode

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Measurement Basics > CDA Measurements in MSRA Operating Mode
CDA Measurements in MSRA Operating Mode

The TD-SCDMA BTS application can also be used to analyze data in MSRA operating mode.

In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications receive an extract of the captured data for analysis, referred to as the application data. For the TD-SCDMA BTS application in MSRA operating mode, the application data range is defined by the same settings used to define the signal capture in Signal and Spectrum Analyzer mode. In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for the TD-SCDMA BTS measurement.

Data coverage for each active application

Generally, if a signal contains multiple data channels for multiple standards, separate applications are used to analyze each data channel. Thus, it is of interest to know which application is analyzing which data channel. The MSRA Master display indicates the data covered by each application, restricted to the channel bandwidth used by the corresponding standard (for TD-SCDMA: 1.6 MHz), by vertical blue lines labeled with the application name.

Analysis interval

However, the individual result displays of the application need not analyze the complete data range. The data range that is actually analyzed by the individual result display is referred to as the analysis interval.

In the TD-SCDMA BTS application the analysis interval is automatically determined according to the selected channel, slot or set to analyze which is defined for the evaluation range, depending on the result display. The analysis interval can not be edited directly in the TD-SCDMA BTS application, but is changed automatically when you change the evaluation range.

Analysis line

A frequent question when analyzing multi-standard signals is how each data channel is correlated (in time) to others. Thus, an analysis line has been introduced. The analysis line is a common time marker for all MSRA applications. It can be positioned in any MSRA application or the MSRA Master and is then adjusted in all other applications. Thus, you can easily analyze the results at a specific time in the measurement in all applications and determine correlations.

If the marked point in time is contained in the analysis interval of the application, the line is indicated in all time-based result displays, such as time, symbol, slot or bit diagrams. By default, the analysis line is displayed, however, it can be hidden from view manually. In all result displays, the "AL" label in the window title bar indicates whether or not the analysis line lies within the analysis interval or not:

  • orange "AL": the line lies within the interval
  • white "AL": the line lies within the interval, but is not displayed (hidden)
  • no "AL": the line lies outside the interval

For details on the MSRA operating mode see "Applications and Operating Modes" .


I/Q Data Import and Export

TD-SCDMA Measurements (R&S FSW-K76/-K77) > I/Q Data Import and Export
I/Q Data Import and Export

Baseband signals mostly occur as so-called complex baseband signals, i.e. a signal representation that consists of two channels; the in phase (I) and the quadrature (Q) channel. Such signals are referred to as I/Q signals. I/Q signals are useful because the specific RF or IF frequencies are not needed. The complete modulation information and even distortion that originates from the RF, IF or baseband domains can be analyzed in the I/Q baseband.

Importing and exporting I/Q signals is useful for various applications:
  • Generating and saving I/Q signals in an RF or baseband signal generator or in external software tools to analyze them with the R&S FSW later
  • Capturing and saving I/Q signals with an RF or baseband signal analyzer to analyze them with the R&S FSW or an external software tool later

As opposed to storing trace data, which may be averaged or restricted to peak values, I/Q data is stored as it was captured, without further processing. The data is stored as complex values in 32-bit floating-point format. Multi-channel data is not supported. The I/Q data is stored in a format with the file extension .iq.tar.

For a detailed description see "I/Q Data File Format (iq-tar)" .

Export only in MSRA mode

In MSRA mode, I/Q data can only be exported to other applications; I/Q data cannot be imported to the MSRA Master or any MSRA applications.

For details on import and export functions see "Import/Export Functions" .


Configuration

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration
Configuration

The TD-SCDMA applications provide several different measurements for signals according to the TD-SCDMA application. The main and default measurement is Code Domain Analysis. In addition to the code domain power measurements specified by the TD-SCDMA standard, the TD-SCDMA options offer measurements with predefined settings in the frequency and time domain, e.g. channel power or power vs time measurements.

Only one measurement type can be configured per channel; however, several channels with TD-SCDMA applications can be configured in parallel on the R&S FSW. Thus, you can configure one channel for a Code Domain Analysis, for example, and another for a Time Alignment Error or Power measurement for the same input signal. Then you can use the Sequencer to perform all measurements consecutively and switch through the results easily, or monitor all results at the same time in the "MultiView" tab.

For details on the Sequencer function see "Running a Sequence of Measurements" .

Selecting the measurement type

When you activate an TD-SCDMA application, Code Domain Analysis of the input signal is started automatically. However, the TD-SCDMA applications also provide other measurement types.

►

To select a different measurement type, do one of the following:

  • Select the "Overview" softkey. In the "Overview", select the "Select Measurement" button. Select the required measurement.
  • Press the MEAS key on the front panel. In the "Select Measurement" dialog box, select the required measurement.
Contents
  • Result Display Configuration
  • Code Domain Analysis
  • Frequency and Time Domain Measurements


Result Display Configuration

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Result Display Configuration
Result Display Configuration

The captured signal can be displayed using various evaluation methods. All evaluation methods available for TD-SCDMA applications are displayed in the evaluation bar in SmartGrid mode when you do one of the following:

  • Select the [image] "SmartGrid" icon from the toolbar.
  • Select the "Display" button in the "Overview".
  • Press the MEAS key.
  • Select the "Display Config" softkey in any TD-SCDMA menu.

Up to 16 evaluation methods can be displayed simultaneously in separate windows. The TD-SCDMA evaluation methods are described in "Evaluation Methods for Code Domain Analysis".

To close the SmartGrid mode and restore the previous softkey menu select the [image] "Close" icon in the righthand corner of the toolbar, or press any key on the front panel.

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .


Code Domain Analysis

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis
Code Domain Analysis

TD-SCDMA measurements require special applications on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you activate a TD-SCDMA application the first time, a set of parameters is passed on from the currently active application:
  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

When you activate a TD-SCDMA application, Code Domain Analysis of the input signal is started automatically with the default configuration (see "Default Settings for Code Domain Analysis"). The "Code Domain Analyzer" menu is displayed and provides access to the most important configuration functions.

For a description see
  • "Signal Capture (Data Acquisition)"
  • "Synchronization"
  • "Channel Detection"
  • "Code Domain Analysis Settings"
  • "Evaluation Range"
  • "Result Display Configuration"

The "Span", "Bandwidth", "Lines", and "Marker Functions" menus are not available for Code Domain Analysis in TD-SCDMA applications.

Code Domain Analysis can be configured easily in the "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu.

Importing and Exporting I/Q Data

The I/Q data to be evaluated for TD-SCDMA measurements can not only be measured by the TD-SCDMA applications themselves, it can also be imported to the applications, provided it has the correct format. Furthermore, the evaluated I/Q data from the TD-SCDMA applications can be exported for further analysis in external applications.

The import and export functions are available in the "Save/Recall" menu which is displayed when you select the [image] "Save" or [image] "Open" icon in the toolbar.

For details on importing and exporting I/Q data see "I/Q Data Import and Export".

Contents
  • Default Settings for Code Domain Analysis
  • Configuration Overview
  • Data Input and Output Settings
  • Frontend Settings
  • Trigger Settings
  • Signal Capture (Data Acquisition)
  • Application Data (MSRA)
  • Synchronization
  • Channel Detection
  • Sweep Settings
  • Automatic Settings
  • BW, Span, Lines and Marker Function Menus
  • Zoom Functions


Default Settings for Code Domain Analysis

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Default Settings for Code Domain Analysis
Default Settings for Code Domain Analysis

When you activate a TD-SCDMA application the first time, a set of parameters is passed on from the currently active application:

  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation
  • signal source and digital I/Q input settings
  • input coupling
  • YIG filter state

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Apart from these settings, the following default settings are activated directly after a TD-SCDMA application is activated, or after a "Preset Channel":

The following default settings of the Code Domain Analysis are activated:

Default settings for TD-SCDMA channels
Parameter | Value
Sweep | CONTINUOUS
Channel detection mode | AUTOSEARCH
Trigger settings | FREE RUN
Trigger offset | 0
Symbol rate | 17.6 ksps
Number of sets to capture | 1
Set to analyze | 0
Scrambling code | 0
MA shift cell | 16
Synchronization | P-CCPCH
Max. modulation | 64QAM
Predefined tables | Auto search
Selected channel | 1.16
Selected slot number | 0
I/Q offset compensation | Off
Evaluations | Window 1: Code Domain Power Relative Window 2: Result Summary


Configuration Overview

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. Thus, you can easily configure an entire measurement channel from input over processing to evaluation by stepping through the dialog boxes as indicated in the "Overview".

The available settings and functions in the "Overview" vary depending on the currently selected measurement. For frequency and time domain measurements see "Frequency and Time Domain Measurements".

For Code Domain Analysis measurements, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

The "Signal Description" button indicated in the "Overview" is not required for TD-SCDMA measurements.

  1. "Select Measurement"

    See "Measurements and Result Display"

  2. "Input/ Frontend"

    See "Data Input and Output Settings"

  3. (Optionally:) "Trigger"

    See "Trigger Settings"

  4. "Signal Capture"

    See "Signal Capture (Data Acquisition)"

  5. "Synchronization"

    See "Synchronization"

  6. "Channel Detection"

    See "Channel Detection"

  7. "Analysis"

    See "Analysis"

  8. "Display Configuration"

    See "Result Display Configuration"

To configure settings
►

Select any button in the "Overview" to open the corresponding dialog box.

Select a setting in the channel bar (at the top of the measurement channel tab) to change a specific setting.

└ Preset Channel
└ Select Measurement
└ Specifics for


Preset Channel

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

See "Default Settings for Code Domain Analysis" for details.

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Select Measurement

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Configuration Overview > Select Measurement
Select Measurement

Selects a different measurement to be performed.

See "Measurements and Result Display".


Specifics for

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.


Data Input and Output Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings
Data Input and Output Settings

The R&S FSW can analyze signals from different input sources and provide various types of output (such as noise or trigger signals).

Frontend settings are described in "Frontend Settings".

Contents
  • Input Source Settings
  • Output Settings
  • Digital I/Q Output Settings
  • Analog Baseband Input Settings


Input Source Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings
Input Source Settings

The input source determines which data the R&S FSW will analyze.

Input settings can be configured in the "Input" dialog box.

Some settings are also available in the "Amplitude" tab of the "Amplitude" dialog box.

Output settings are described in "Output Settings".

Since the Digital I/Q input and the Analog Baseband input use the same digital signal path, both cannot be used simultaneously. When one is activated, established connections for the other are disconnected. When the second input is deactivated, connections to the first are re-established. This may cause a short delay in data transfer after switching the input source.

Contents
  • Radio Frequency Input
  • Digital I/Q Input Settings
  • Analog Baseband Input Settings
  • Probe Settings


Radio Frequency Input

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is "Radio Frequency", i.e. the signal at the RF INPUT connector on the front panel of the R&S FSW. If no additional options are installed, this is the only available input source.

└ Radio Frequency State
└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector
└ Input Connector


Radio Frequency State

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Radio Frequency State
Radio Frequency State

Activates input from the RF INPUT connector.

Remote command:

INPut:​SELect


Input Coupling

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

This value also affects the unit conversion (see "Reference Level").

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71). For analog baseband input, an impedance of 50 Ω is always used.

Remote command:

INPut:​IMPedance


High-Pass Filter 1...3 GHz

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

An internal YIG-preselector at the input of the R&S FSW ensures that image frequencies are rejected. However, this is only possible for a restricted bandwidth. In order to use the maximum bandwidth for signal analysis you can deactivate the YIG-preselector at the input of the R&S FSW, which may lead to image-frequency display.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Remote command:

INPut:​FILTer:​YIG[:​STATe]


Input Connector

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Input Connector
Input Connector

Determines whether the RF input data is taken from the RF INPUT connector (default) or the optional BASEBAND INPUT I connector. This setting is only available if the Analog Baseband Interface (R&S FSW-B71) is installed and active for input. It is not available for the R&S FSW67.

For more information see "Processing Data From the Analog Baseband Interface" .

Remote command:

INPut:​CONNector


Digital I/Q Input Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings
Digital I/Q Input Settings

The following settings and functions are available to provide input via the Digital Baseband Interface (R&S FSW-B17) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see " Processing Data from the Digital Baseband Interface (-B17)" .

└ Digital I/Q Input State
└ Input Sample Rate
└ Full Scale Level
└ Adjust Reference Level to Full Scale Level
└ Connected Instrument
└ DigIConf


Digital I/Q Input State

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Digital I/Q Input State
Digital I/Q Input State

Enables or disable the use of the "Digital IQ" input source for measurements. "Digital IQ" is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

Remote command:

INPut:​SELect


Input Sample Rate

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Input Sample Rate
Input Sample Rate

Defines the sample rate of the digital I/Q signal source. This sample rate must correspond with the sample rate provided by the connected device, e.g. a generator.

If "Auto" is selected, the sample rate is adjusted automatically by the connected device.

The allowed range is from 100 Hz to 10 GHz.

Remote command:

INPut:​DIQ:​SRATe

INPut:​DIQ:​SRATe:​AUTO


Full Scale Level

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Full Scale Level
Full Scale Level

The "Full Scale Level" defines the level and unit that should correspond to an I/Q sample with the magnitude "1".

If "Auto" is selected, the level is automatically set to the value provided by the connected device.

Remote command:

INPut:​DIQ:​RANGe[:​UPPer]

INPut:​DIQ:​RANGe[:​UPPer]:​UNIT

INPut:​DIQ:​RANGe[:​UPPer]:​AUTO


Adjust Reference Level to Full Scale Level

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Adjust Reference Level to Full Scale Level
Adjust Reference Level to Full Scale Level

If enabled, the reference level is adjusted to the full scale level automatically if any change occurs.

Remote command:

INPut:​DIQ:​RANGe:​COUPling


Connected Instrument

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Connected Instrument
Connected Instrument

Displays the status of the Digital Baseband Interface connection.

This function is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
  • Sample rate of the data currently being transferred via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level"), if provided by connected instrument
Remote command:

INPut:​DIQ:​CDEVice


DigIConf

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > DigIConf
DigIConf

Starts the optional R&S DigIConf application. This softkey is available in the In-/Output menu, but only if the optional software is installed.

Note that R&S DigIConf requires a USB connection (not LAN!) from the R&S FSW to the R&S EX-IQ-BOX in addition to the Digital Baseband Interface (R&S FSW-B17) connection. R&S DigIConf version 2.20.360.86 Build 170 or higher is required.

To return to the R&S FSW application, press any key on the front panel. The R&S FSW application is displayed with the "Input/Output" menu, regardless of which key was pressed.

For details on the R&S DigIConf application, see the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Note: If you close the R&S DigIConf window using the "Close" icon, the window is minimized, not closed.
If you select the "File > Exit" menu item in the R&S DigIConf window, the application is closed. Note that in this case the settings are lost and the EX-IQ-BOX functionality is no longer available until you restart the application using the "DigIConf" softkey in the R&S FSW once again.


Analog Baseband Input Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings
Analog Baseband Input Settings

The following settings and functions are available to provide input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see "Processing Data From the Analog Baseband Interface" .

If Analog Baseband input is used, measurements in the frequency and time domain are not available.

└ Analog Baseband Input State
└ I/Q Mode
└ Input configuration
└ Center Frequency


Analog Baseband Input State

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Analog Baseband Input State
Analog Baseband Input State

Enables or disable the use of the "Analog Baseband" input source for measurements. "Analog Baseband" is only available if the Analog Baseband Interface (R&S FSW-B71) is installed.

Remote command:

INPut:​SELect


I/Q Mode

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > I/Q Mode
I/Q Mode

Defines the format of the input signal.

For more information see "I/Q Processing Modes" .

"I + jQ"

The input signal is filtered and resampled to the sample rate of the application.

Two inputs are required for a complex signal, one for the in-phase component, and one for the quadrature component.

"I Only / Low IF I"

The input signal at the BASEBAND INPUT I connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband I).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF I).

"Q Only / Low IF Q"

The input signal at the BASEBAND INPUT Q connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband Q).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF Q).

Remote command:

INPut:​IQ:​TYPE


Input configuration

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Input configuration
Input configuration

Defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Note: Both single-ended and differential probes are supported as input; however, since only one connector is occupied by a probe, the "Single-ended" setting must be used for all probes.
For details on probes see "Using Probes" .

"Differential" | I, Q and inverse I,Q data
"Single Ended" | I, Q data only
Remote command:

INPut:​IQ:​BALanced[:​STATe]


Center Frequency

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Center Frequency
Center Frequency

Defines the center frequency for analog baseband input.

For real-type baseband input (I or Q only), the center frequency is always 0 Hz.

Note: If the analysis bandwidth to either side of the defined center frequency exceeds the minimum frequency (0 Hz) or the maximum frequency (40 MHz/80 MHz), an error is displayed. In this case, adjust the center frequency or the analysis bandwidth.

Remote command:

[SENSe:​]FREQuency:​CENTer


Probe Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Probe Settings
Probe Settings

Probes are configured in a separate tab on the "Input" dialog box which is displayed when you select the INPUT/OUTPUT key and then "Input Source Config".

For each possible probe connector (Baseband Input I, Baseband Input Q), the detected type of probe, if any, is displayed. The following information is provided for each connected probe:

  • Probe name
  • Serial number
  • R&S part number
  • Type of probe ("Differential", "Single Ended")

For more information on using probes with an R&S FSW, see "Using Probes" .

For general information on the R&S®RTO probes, see the device manuals.

└ Microbutton Action


Microbutton Action

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Probe Settings > Microbutton Action
Microbutton Action

Active R&S probes (except for RT-ZS10E) have a configurable microbutton on the probe head. By pressing this button, you can perform an action on the instrument directly from the probe.

Select the action that you want to start from the probe:

"Run single" | Starts one data acquisition.
"No action" | Prevents unwanted actions due to unintended usage of the microbutton.
Remote command:

[SENSe:​]PROBe<p>:​SETup:​MODE


Output Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Output Settings
Output Settings

The R&S FSW can provide output to special connectors for other devices.

For details on connectors refer to "Instrument Tour" .

Providing trigger signals as output is described in "How to Output a Trigger Signal" .

Output settings can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

└ Noise Source
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Noise Source

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Output Settings > Noise Source
Noise Source

Switches the supply voltage for an external noise source on or off.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of a DUT.

Remote command:

DIAGnostic:​SERVice:​NSOurce


Trigger 2/3

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Output Settings > Trigger 2/3
Trigger 2/3

Defines the usage of the variable TRIGGER INPUT/OUTPUT connectors, where:

"Trigger 2": TRIGGER INPUT/OUTPUT connector on the front panel

"Trigger 3": TRIGGER 3 INPUT/ OUTPUT connector on the rear panel

(Trigger 1 is INPUT only.)

Note: Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .

"Input" | The signal at the connector is used as an external trigger source by the R&S FSW. No further trigger parameters are available for the connector.
"Output" | The R&S FSW sends a trigger signal to the output connector to be used by connected devices. Further trigger parameters are available for the connector.
Remote command:

OUTPut:​TRIGger<port>:​LEVel

OUTPut:​TRIGger<port>:​DIRection

└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Output Type

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type
Output Type

Type of signal to be sent to the output

"Device Triggered" | (Default) Sends a trigger when the R&S FSW triggers.
"Trigger Armed" | Sends a (high level) trigger when the R&S FSW is in "Ready for trigger" state. This state is indicated by a status bit in the STATus:OPERation register (bit 5), as well as by a low level signal at the AUX port (pin 9).
"User Defined" | Sends a trigger when user selects "Send Trigger" button. In this case, further parameters are available for the output signal.
Remote command:

OUTPut:​TRIGger<port>:​OTYPe

└ Level
└ Pulse Length
└ Send Trigger


Level

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Level
Level

Defines whether a constant high (1) or low (0) signal is sent to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​LEVel


Pulse Length

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Pulse Length
Pulse Length

Defines the length of the pulse sent as a trigger to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​LENGth


Send Trigger

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Send Trigger
Send Trigger

Sends a user-defined trigger to the output connector immediately. Note that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is sent.

Which pulse level will be sent is indicated by a graphic on the button.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​IMMediate


Digital I/Q Output Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Digital I/Q Output Settings
Digital I/Q Output Settings

The optional Digital Baseband Interface (R&S FSW-B17) allows you to output I/Q data from any R&S FSW application that processes I/Q data to an external device. The configuration settings for digital I/Q output can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

Digital output is not available if the bandwidth extension option R&S FSW-B500 is active.

For details on digital I/Q output see "Digital Output" .

└ Digital Baseband Output
└ Output Settings Information
└ Connected Instrument


Digital Baseband Output

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Digital I/Q Output Settings > Digital Baseband Output
Digital Baseband Output

Enables or disables a digital output stream to the optional Digital Baseband Interface (R&S FSW-B17), if available.

Note: If digital baseband output is active, the sample rate is restricted to 200 MHz (max. 160 MHz bandwidth).
The only data source that can be used for digital baseband output is RF input.

For details on digital I/Q output see "Digital Output" .

Remote command:

OUTPut:​DIQ


Output Settings Information

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Digital I/Q Output Settings > Output Settings Information
Output Settings Information

Displays information on the settings for output via the Digital Baseband Interface (R&S FSW-B17).

The following information is displayed:

  • Maximum sample rate that can be used to transfer data via the Digital Baseband Interface (i.e. the maximum input sample rate that can be processed by the connected instrument)
  • Sample rate currently used to transfer data via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level")
Remote command:

OUTPut:​DIQ:​CDEVice


Connected Instrument

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Digital I/Q Output Settings > Connected Instrument
Connected Instrument

Displays information on the instrument connected to the Digital Baseband Interface (R&S FSW-B17), if available.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
Remote command:

OUTPut:​DIQ:​CDEVice


Analog Baseband Input State

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Analog Baseband Input Settings > Analog Baseband Input State
Analog Baseband Input State

Enables or disable the use of the "Analog Baseband" input source for measurements. "Analog Baseband" is only available if the Analog Baseband Interface (R&S FSW-B71) is installed.

Remote command:

INPut:​SELect


I/Q Mode

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Analog Baseband Input Settings > I/Q Mode
I/Q Mode

Defines the format of the input signal.

For more information see "I/Q Processing Modes" .

"I + jQ"

The input signal is filtered and resampled to the sample rate of the application.

Two inputs are required for a complex signal, one for the in-phase component, and one for the quadrature component.

"I Only / Low IF I"

The input signal at the BASEBAND INPUT I connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband I).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF I).

"Q Only / Low IF Q"

The input signal at the BASEBAND INPUT Q connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband Q).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF Q).

Remote command:

INPut:​IQ:​TYPE


Input configuration

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Analog Baseband Input Settings > Input configuration
Input configuration

Defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Note: Both single-ended and differential probes are supported as input; however, since only one connector is occupied by a probe, the "Single-ended" setting must be used for all probes.
For details on probes see "Using Probes" .

"Differential" | I, Q and inverse I,Q data
"Single Ended" | I, Q data only
Remote command:

INPut:​IQ:​BALanced[:​STATe]


Center Frequency

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Data Input and Output Settings > Analog Baseband Input Settings > Center Frequency
Center Frequency

Defines the center frequency for analog baseband input.

For real-type baseband input (I or Q only), the center frequency is always 0 Hz.

Note: If the analysis bandwidth to either side of the defined center frequency exceeds the minimum frequency (0 Hz) or the maximum frequency (40 MHz/80 MHz), an error is displayed. In this case, adjust the center frequency or the analysis bandwidth.

Remote command:

[SENSe:​]FREQuency:​CENTer


Frontend Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings
Frontend Settings

Frequency, amplitude and y-axis scaling settings represent the "frontend" of the measurement setup.

Contents
  • Amplitude Settings
  • Amplitude Settings for Analog Baseband Input
  • Y-Axis Scaling
  • Frequency Settings


Amplitude Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings
Amplitude Settings

Amplitude settings determine how the R&S FSW must process or display the expected input power levels.

The scaling settings are described in "Y-Axis Scaling".

Amplitude settings for input from the Analog Baseband interface (R&S FSW-B71) are described in "Amplitude Settings for Analog Baseband Input".

To configure the amplitude settings

Amplitude settings can be configured via the AMPT key or in the "Amplitude" dialog box.

►

To display the "Amplitude" dialog box, do one of the following:

  • Select "Input/Frontend" from the "Overview" and then switch to the "Amplitude" tab.
  • Select the AMPT key and then the "Amplitude Config" softkey.
└ Reference Level
└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)
└ RF Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Reference Level

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > Reference Level
Reference Level

Defines the expected maximum reference level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display ("OVLD" for analog baseband or digitial baseband input).

The reference level is also used to scale power diagrams; the reference level is then used as the maximum on the y-axis.

Since the R&S FSW hardware is adapted according to this value, it is recommended that you set the reference level close above the expected maximum signal level to ensure an optimum measurement (no compression, good signal-to-noise ratio).

Note that the "Reference Level" value ignores the "Shifting the Display (Offset)". It is important to know the actual power level the R&S FSW must handle.

For details see "Reference Level" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)


Shifting the Display (Offset)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > Reference Level > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the y-axis is changed accordingly.

Define an offset if the signal is attenuated or amplified before it is fed into the R&S FSW so the application shows correct power results. All displayed power level results will be shifted by this value.

Note, however, that the "Reference Level" value ignores the "Reference Level Offset". It is important to know the actual power level the R&S FSW must handle.

To determine the required offset, consider the external attenuation or gain applied to the input signal. A positive value indicates that an attenuation took place (R&S FSW increases the displayed power values) , a negative value indicates an external gain (R&S FSW decreases the displayed power values).

The setting range is ±200 dB in 0.01 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


Unit

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > Reference Level > Unit
Unit

For CDA measurements the unit should not be changed, as this would lead to useless results.


Setting the Reference Level Automatically (Auto Level)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > Reference Level > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier (for analog baseband input: the full scale level) are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

This function is only available for the MSRA/MSRT Master, not for the applications.

You can change the measurement time for the level measurement if necessary (see "Changing the Automatic Measurement Time (Meastime Manual)").

Remote command:

[SENSe:​]ADJust:​LEVel


RF Attenuation

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > RF Attenuation
RF Attenuation

Defines the attenuation applied to the RF input.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

└ Attenuation Mode / Value


Attenuation Mode / Value

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > RF Attenuation > Attenuation Mode / Value
Attenuation Mode / Value

The RF attenuation can be set automatically as a function of the selected reference level (Auto mode). This ensures that the optimum RF attenuation is always used. It is the default setting. By default and when "Using Electronic Attenuation (Option B25)" is not available, mechanical attenuation is applied.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

In "Manual" mode, you can set the RF attenuation in 1 dB steps (down to 0 dB, also using the rotary knob). Other entries are rounded to the next integer value. The range is specified in the data sheet. If the defined reference level cannot be set for the defined RF attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed.

NOTICE! Risk of hardware damage due to high power levels. When decreasing the attenuation manually, ensure that the power level does not exceed the maximum level allowed at the RF input, as an overload may lead to hardware damage.

Note: In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible (if option B25 is installed and active) to reduce the amount of mechanical switching required.

For details see "RF Attenuation" .

Remote command:

INPut:​ATTenuation

INPut:​ATTenuation:​AUTO


Using Electronic Attenuation (Option B25)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > Using Electronic Attenuation (Option B25)
Using Electronic Attenuation (Option B25)

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator.

In "Auto" mode, the settings are defined automatically; in "Manual" mode, you can define the mechanical and electronic attenuation separately.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

Note: Electronic attenuation is not available for stop frequencies (or center frequencies in zero span) >13.6 GHz.
In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible to reduce the amount of mechanical switching required. Mechanical attenuation may provide a better signal-to-noise ratio, however.
When you switch off electronic attenuation, the RF attenuation is automatically set to the same mode (auto/manual) as the electronic attenuation was set to. Thus, the RF attenuation may be set to automatic mode, and the full attenuation is provided by the mechanical attenuator, if possible.

Both the electronic and the mechanical attenuation can be varied in 1 dB steps. Other entries are rounded to the next lower integer value.

If the defined reference level cannot be set for the given attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed in the status bar.

Remote command:

INPut:​EATT:​STATe

INPut:​EATT:​AUTO

INPut:​EATT


Input Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Preamplifier (option B24)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > Input Settings > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


Amplitude Settings for Analog Baseband Input

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings for Analog Baseband Input
Amplitude Settings for Analog Baseband Input

The following settings and functions are available to define amplitude settings for input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the AMPT key or in the "Amplitude" tab of the "Input" dialog box.

The input settings provided here are identical to those in the "Input Source" > "Analog Baseband" tab, see "Analog Baseband Input Settings".

For more information see "Processing Data From the Analog Baseband Interface" .

└ Reference Level
└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)
└ Full Scale Level Mode / Value


Full Scale Level Mode / Value

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings for Analog Baseband Input > Full Scale Level Mode / Value
Full Scale Level Mode / Value

The full scale level defines the maximum power you can input at the Baseband Input connector without clipping the signal.

The full scale level can be defined automatically according to the reference level, or manually.

For manual input, the following values can be selected:

  • 0.25 V
  • 0.5 V
  • 1 V
  • 2 V

If probes are connected, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

For details on probes see "Processing Data From the Analog Baseband Interface" .

Remote command:

INPut:​IQ:​FULLscale:​AUTO

INPut:​IQ:​FULLscale[:​LEVel]


Y-Axis Scaling

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Y-Axis Scaling
Y-Axis Scaling

The vertical axis scaling is configurable. In Code Domain Analysis, the y-axis usually displays the measured power levels.

└ Y-Maximum, Y-Minimum
└ Auto Scale Once
└ Restore Scale (Window)


Y-Maximum, Y-Minimum

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Y-Axis Scaling > Y-Maximum, Y-Minimum
Y-Maximum, Y-Minimum

Defines the amplitude range to be displayed on the y-axis of the evaluation diagrams.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MAXimum

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MINimum


Auto Scale Once

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Y-Axis Scaling > Auto Scale Once
Auto Scale Once

Automatically determines the optimal range and reference level position to be displayed for the current measurement settings.

The display is only set once; it is not adapted further if the measurement settings are changed again.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO ONCE


Restore Scale (Window)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Y-Axis Scaling > Restore Scale (Window)
Restore Scale (Window)

Restores the default scale settings in the currently selected window.


Frequency Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Frequency Settings
Frequency Settings

Frequency settings for the input signal can be configured via the "Frequency" dialog box, which is displayed when you do one of the following:

  • Select the FREQ key and then the "Frequency Config" softkey.
  • Select "Input/Frontend" from the "Overview" and then switch to the "Frequency" tab.
└ Center frequency
└ Center Frequency Stepsize
└ Frequency Offset


Center frequency

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Frequency Settings > Center frequency
Center frequency

Defines the normal center frequency of the signal. The allowed range of values for the center frequency depends on the frequency span.

span > 0: spanmin/2 ≤ fcenter ≤ fmax – spanmin/2

fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​CENTer


Center Frequency Stepsize

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Frequency Settings > Center Frequency Stepsize
Center Frequency Stepsize

Defines the step size by which the center frequency is increased or decreased when the arrow keys are pressed. When you use the rotary knob the center frequency changes in steps of only 1/10 of the "Center Frequency Stepsize".

The step size can be coupled to another value or it can be manually set to a fixed value.

This setting is available for frequency and time domain measurements.

For more details see "Stepping Through the Frequency Range - Center Frequency Stepsize" .

"= Center" | Sets the step size to the value of the center frequency. The used value is indicated in the "Value" field.
"Manual" | Defines a fixed step size for the center frequency. Enter the step size in the "Value" field.
Remote command:

[SENSe:​]FREQuency:​CENTer:​STEP


Frequency Offset

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Frontend Settings > Frequency Settings > Frequency Offset
Frequency Offset

Shifts the displayed frequency range along the x-axis by the defined offset.

This parameter has no effect on the R&S FSW hardware, or on the captured data or on data processing. It is simply a manipulation of the final results in which absolute frequency values are displayed. Thus, the x-axis of a spectrum display is shifted by a constant offset if it shows absolute frequencies, but not if it shows frequencies relative to the signal's center frequency.

A frequency offset can be used to correct the display of a signal that is slightly distorted by the measurement setup, for example.

The allowed values range from -100 GHz to 100 GHz. The default setting is 0 Hz.

Remote command:

[SENSe:​]FREQuency:​OFFSet


Trigger Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Trigger Settings
Trigger Settings

Trigger settings determine when the input signal is measured.

External triggers from one of the TRIGGER INPUT/OUTPUT connectors on the R&S FSW are configured in a separate tab of the dialog box.

For step-by-step instructions on configuring triggered measurements, see "How to Configure a Triggered and Gated Measurement" .

For step-by-step instructions on configuring triggered measurements, see the main R&S FSW User Manual.

└ Trigger Source
└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ Baseband Power
└ Digital I/Q
└ IF Power
└ Trigger Level
└ Trigger Offset
└ Slope
└ Hysteresis
└ Trigger Holdoff
└ Capture Offset
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Trigger Source

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source
Trigger Source

The trigger settings define the beginning of a measurement.

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ Baseband Power
└ Digital I/Q
└ IF Power
└ Trigger Level
└ Trigger Offset
└ Slope
└ Hysteresis
└ Trigger Holdoff
└ Capture Offset


Trigger Source

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Source
Trigger Source

Defines the trigger source. If a trigger source other than "Free Run" is set, "TRG" is displayed in the channel bar and the trigger source is indicated.

Remote command:

TRIGger[:​SEQuence]:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ Baseband Power
└ Digital I/Q
└ IF Power


Free Run

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Source > Free Run
Free Run

No trigger source is considered. Data acquisition is started manually or automatically and continues until stopped explicitely.

Remote command:

TRIG:SOUR IMM, see TRIGger[:​SEQuence]:​SOURce


External Trigger 1/2/3

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Source > External Trigger 1/2/3
External Trigger 1/2/3

Data acquisition starts when the TTL signal fed into the specified input connector (on the front or rear panel) meets or exceeds the specified trigger level.

(See "Trigger Level (Repetition interval)" ).

Note: The "External Trigger 1" softkey automatically selects the trigger signal from the TRIGGER INPUT connector on the front panel.

For details see "TRIGGER INPUT / OUTPUT" and "TRIGGER 3 INPUT/ OUTPUT" .

"External Trigger 1" | Trigger signal from the TRIGGER 1 INPUT connector on the front panel.
"External Trigger 2" | Trigger signal from the TRIGGER 2 INPUT/OUTPUT connector on the front panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
"External Trigger 3" | Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector on the rear panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
Remote command:

TRIG:SOUR EXT, TRIG:SOUR EXT2

TRIG:SOUR EXT3

See TRIGger[:​SEQuence]:​SOURce


Baseband Power

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Source > Baseband Power
Baseband Power

Defines triggering on the baseband power (for baseband input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)).

For more information on the Digital Baseband Interface see "Digital I/Q Data Processing" .

For more information on the Analog Baseband Interface see "Processing Data From the Analog Baseband Interface" .

Remote command:

TRIG:SOUR BBP, see TRIGger[:​SEQuence]:​SOURce


Digital I/Q

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Source > Digital I/Q
Digital I/Q

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available:

Defines triggering of the measurement directly via the LVDS connector. In the selection list you must specify which general purpose bit (GP0 to GP5) will provide the trigger data.

Note: If the Digital I/Q enhanced mode is used, i.e. the connected device supports transfer rates up to 200 Msps, only the general purpose bits GP0 and GP1 are available as a Digital I/Q trigger source.

The following table describes the assignment of the general purpose bits to the LVDS connector pins.

(For details on the LVDS connector see "Description of the LVDS Connector" )

Assignment of general purpose bits to LVDS connector pins
Bit | LVDS pin
GP0 | SDATA4_P - Trigger1
GP1 | SDATA4_P - Trigger2
GP2 *) | SDATA0_P - Reserve1
GP3 *) | SDATA4_P - Reserve2
GP4 *) | SDATA0_P - Marker1
GP5 *) | SDATA4_P - Marker2
*): not available for Digital I/Q enhanced mode
Remote command:

TRIG:SOUR GP0, see TRIGger[:​SEQuence]:​SOURce


IF Power

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Source > IF Power
IF Power

The R&S FSW starts capturing data as soon as the trigger level is exceeded around the third intermediate frequency.

This trigger source is only available for RF input.

This trigger source is available for frequency and time domain measurements only.

It is not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

For frequency sweeps, the third IF represents the start frequency. The trigger bandwidth at the third IF depends on the RBW and sweep type.

For measurements on a fixed frequency (e.g. zero span or I/Q measurements), the third IF represents the center frequency.

The available trigger levels depend on the RF attenuation and preamplification. A reference level offset, if defined, is also considered.

For details on available trigger levels and trigger bandwidths see the data sheet.

Remote command:

TRIG:SOUR IFP, see TRIGger[:​SEQuence]:​SOURce


Trigger Level

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Level
Trigger Level

Defines the trigger level for the specified trigger source.

For details on supported trigger levels, see the data sheet.

Remote command:

TRIGger[:​SEQuence]:​LEVel[:​EXTernal<port>]

For analog baseband (B71) or digital baseband (B17) input only:


Trigger Offset

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Offset
Trigger Offset

Defines the time offset between the trigger event and the start of the sweep.

Note: In MSRA/MSRT mode, the trigger offset defines the start of the sweep only for the MSRA/MSRT Master. For MSRA/MSRT applications, use the "Capture Offset" instead.

offset > 0: | Start of the sweep is delayed
offset < 0: | Sweep starts earlier (pre-trigger)
Remote command:

TRIGger[:​SEQuence]:​HOLDoff[:​TIME]


Slope

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Slope
Slope

For all trigger sources except time and frequency mask (Realtime only) you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

TRIGger[:​SEQuence]:​SLOPe


Hysteresis

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Settting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

This setting is only available for "IF Power" trigger sources. The range of the value is between 3 dB and 50 dB with a step width of 1 dB.

This setting is available for frequency and time domain measurements only.

For more information see "Trigger Hysteresis" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HYSTeresis


Trigger Holdoff

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff" .

This softkey is available for frequency and time domain measurements only.

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HOLDoff


Capture Offset

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Capture Offset
Capture Offset

This setting is only available for applications in MSRA operating mode. It has a similar effect as the trigger offset in other measurements: it defines the time offset between the capture buffer start and the start of the extracted application data.

In MSRA mode, the offset must be a positive value, as the capture buffer starts at the trigger time = 0.

For details on the MSRA operating mode see "Applications and Operating Modes" .

Remote command:

[SENSe:​]MSRA:​CAPTure:​OFFSet


Signal Capture (Data Acquisition)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Signal Capture (Data Acquisition)
Signal Capture (Data Acquisition)

How much and how data is captured from the input signal are defined in the "Signal Capture" settings.

Not available for Power vs Time measurements.

MSRA operating mode

In MSRA operating mode, only the MSRA Master channel actually captures data from the input signal. The data acquisition settings for the TD-SCDMA BTS application in MSRA mode define the application data extract. See "Application Data (MSRA) ".

For details on the MSRA operating mode see "Applications and Operating Modes" .

└ Sample Rate
└ Invert Q
└ RRC Filter State
└ Set Count
└ Set to Analyze
└ Number of Slots to Capture


Sample Rate

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Signal Capture (Data Acquisition) > Sample Rate
Sample Rate

The sample rate is always 2 MHz (indicated for reference only).


Invert Q

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Signal Capture (Data Acquisition) > Invert Q
Invert Q

Inverts the sign of the signal's Q-branch. The default setting is OFF.

Remote command:

[SENSe:​]CDPower:​QINVert


RRC Filter State

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Signal Capture (Data Acquisition) > RRC Filter State
RRC Filter State

Selects if a root raised cosine (RRC) receiver filter is used or not. This feature is useful if the RRC filter is implemented in the device under test (DUT).

"ON" | If an unfiltered signal is received (normal case), the RRC filter should be used to get a correct signal demodulation. (Default settings)
"OFF" | If a filtered signal is received, the RRC filter should not be used to get a correct signal demodulation. This is the case if the DUT filters the signal.
Remote command:

[SENSe:​]CDPower:​FILTer[:​STATe]


Set Count

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Signal Capture (Data Acquisition) > Set Count
Set Count

Defines the number of consecutive sets to be captured and stored in the instrument's I/Q memory. One set consists of 63 slots. The R&S FSW can capture from 1 to 4500 sets.

Remote command:

[SENSe:​]CDPower:​SET:​COUNt


Set to Analyze

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Signal Capture (Data Acquisition) > Set to Analyze
Set to Analyze

Selects a specific set for further analysis. The value range depends on the "Set Count" and is between 0 and [Set Count-1].

Remote command:

[SENSe:​]CDPower:​SET


Number of Slots to Capture

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Signal Capture (Data Acquisition) > Number of Slots to Capture
Number of Slots to Capture

Defines the number of slots to capture.

Note: if the "Set Count" is larger than 1, the number of slots to capture is automatically set to the maximum of 64.

Remote command:

[SENSe:​]CDPower:​IQLength


Application Data (MSRA)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Application Data (MSRA)
Application Data (MSRA)

For the TD-SCDMA BTS application in MSRA operating mode, the application data range is defined by the same settings used to define the signal capturing in Signal and Spectrum Analyzer mode (see "Signal Capture (Data Acquisition)".

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for the TD-SCDMA BTS measurement (see "Capture Offset").

The analysis interval cannot be edited manually, but is determined automatically according to the selected channel, slot or set to analyze which is defined for the evaluation range, depending on the result display. Note that the set/slot/channel is analyzed within the application data.

For details see "CDA Measurements in MSRA Operating Mode".


Synchronization

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Synchronization
Synchronization

The individual channels in the input signal need to be synchronized to detect timing offsets in the slot spacings. These settings are described here.

└ Scrambling Code
└ SYNC-UL Code (UE only)
└ MA Shift Cell / Number of Users
└ Time Reference (BTS mode)
└ Time Reference (UE mode)
└ Sync To
└ Rotate code channel to associated midamble


Scrambling Code

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Synchronization > Scrambling Code
Scrambling Code

Sets the Scrambling Code of the base station. Possible values are between 0 and 127 and have to be entered as decimals.

Remote command:

[SENSe:​]CDPower:​SCODe


SYNC-UL Code (UE only)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Synchronization > SYNC-UL Code (UE only)
SYNC-UL Code (UE only)

Defines the code used for synchronization on the UpPTS (see "Time Reference (UE mode)").

Remote command:

[SENSe:​]CDPower:​SULC


MA Shift Cell / Number of Users

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Synchronization > MA Shift Cell / Number of Users
MA Shift Cell / Number of Users

Sets the maximum number of usable midamble shifts (= number of users) on the base station. Possible values are in the range from 2 to 16 in steps of 2 midamble shifts.

If you use a predefined channel table, this value is replaced by that of the channel table.

For details see "Data Fields and Midambles".

Remote command:

[SENSe:​]CDPower:​MSHift


Time Reference (BTS mode)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Synchronization > Time Reference (BTS mode)
Time Reference (BTS mode)

Defines which slot is used as a time reference for synchronization.

"DwPTS" | Uses the Downlink Pilot Time Slot (DwPTS) as a time reference (see also "Frames, Subframes and Slots")
"Slot 0" | Uses slot 0 as a time reference.
Remote command:

[SENSe:​]CDPower:​TREF


Time Reference (UE mode)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Synchronization > Time Reference (UE mode)
Time Reference (UE mode)

Defines which slot is used as a time reference for synchronization.

"UpPTS" | Uses the Uplink Pilot Time Slot (UpPTS) as a time reference (see also "Frames, Subframes and Slots")
"Slot 1" | Uses slot 1 as a time reference.
Remote command:

[SENSe:​]CDPower:​TREF


Sync To

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Synchronization > Sync To
Sync To

Defines the phase reference. For a successful synchronization, the selected slot must contain at least one data channel with sufficient power.

(Not available for Power vs Time measurements.)

"P-CCPCH" | (BTS application only) By default, the R&S FSW TD-SCDMA BTS application determines the phase reference for all downlink data slots from the downlink pilot channel (P-CCPCH) in slot 0. For some measurements like beamforming or repeater measurements, it might be necessary to apply different phase offsets to each time slot. In these timeslots, using the P-CCPCH as phase reference leads to rotated constellation diagrams and poor EVM results.
"Code Channel" | (UE application only) The R&S FSW TD-SCDMA UE determines the phase reference from the channel of the selected slot. This is useful when synchronization fails in poor SNR environments. For channel synchronization, at least one of the channels must be QPSK or 8PSK modulated.
"Midamble" | The R&S FSW TD-SCDMA application determines the phase reference from the midamble of the selected slot. With this method, the data slots can be phase rotated to each other and a degradation of the EVM results can be avoided.
Remote command:

[SENSe:​]CDPower:​STSLot

UE application: [SENSe:​]CDPower:​STSLot:​MODE


Rotate code channel to associated midamble

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Synchronization > Rotate code channel to associated midamble
Rotate code channel to associated midamble

(Not available for Power vs Time measurements.)

By default, the R&S FSWTD-SCDMA application determines one phase reference for all midambles and channels of a data slot. If this option is enabled, phase rotations between the channels are allowed. Each channel gets its own phase reference from the associated midamble according to section AA.2 of the standard document 3GPP TS 25.221. If the associated midamble is missing, the common phase reference is used for this channel.

Remote command:

[SENSe:​]CDPower:​STSLot:​ROTate


Channel Detection

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection
Channel Detection

The channel detection settings determine which channels are found in the input signal.

Not available for Power vs Time measurements.

Contents
  • General Channel Detection Settings
  • Channel Table Management
  • Channel Table Settings and Functions
  • Channel Details


General Channel Detection Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > General Channel Detection Settings
General Channel Detection Settings

Channel detection settings are configured in the "Channel Detection" dialog box which is displayed when you select the "Channel Detection" button in the configuration "Overview".

└ Inactive Channel Threshold
└ Max Modulation
└ Using Predefined Channel Tables


Inactive Channel Threshold

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > General Channel Detection Settings > Inactive Channel Threshold
Inactive Channel Threshold

Defines the minimum power that a single channel must have compared to the total signal in order to be recognized as an active channel.

Remote command:

[SENSe:​]CDPower:​ICTReshold


Max Modulation

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > General Channel Detection Settings > Max Modulation
Max Modulation

Defines the highest modulation to be considered in the automatic channel search. In low SNR environments it may be necessary to limit the channel search to lower modulations than 64QAM. The following types are available:

  • QPSK
  • 8PSK
  • 16QAM
  • 64QAM
Remote command:

[SENSe:​]CDPower:​MMAX


Using Predefined Channel Tables

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > General Channel Detection Settings > Using Predefined Channel Tables
Using Predefined Channel Tables

Defines the channel search mode.

"Predefined" | Compares the input signal to the predefined channel table selected in the "Predefined Tables" list.
"Autosearch" | Detects channels automatically on the basis of the active predefined channel table.
Remote command:

CONFigure:​CDPower:​CTABle[:​STATe]


Channel Table Management

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management
Channel Table Management

Channel tables are managed in the "Channel Detection" dialog box which is displayed when you select the "Channel Detection" button in the configuration "Overview".

└ Predefined Tables
└ Selecting a Table
└ Creating a New Table
└ Editing a Table
└ Copying a Table
└ Deleting a Table


Predefined Tables

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management > Predefined Tables
Predefined Tables

The list shows all available channel tables and marks the currently used table with a checkmark. The currently focused table is highlighted blue.

Remote command:

BTS measurements:

CONFigure:​CDPower:​CTABle:​CATalog?


Selecting a Table

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management > Selecting a Table
Selecting a Table

Selects the channel table currently focused in the "Predefined Tables" list and compares it to the measured signal to detect channels.

Remote command:

CONFigure:​CDPower:​CTABle:​SELect


Creating a New Table

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management > Creating a New Table
Creating a New Table

Creates a new channel table. See "Channel Details".

For step-by-step instructions on creating a new channel table, see "To define or edit a channel table".


Editing a Table

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management > Editing a Table
Editing a Table

You can edit existing channel table definitions. The details of the selected channel are displayed in the "Channel Table" dialog box. See "Channel Details".


Copying a Table

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management > Copying a Table
Copying a Table

Copies an existing channel table definition. The details of the selected channel are displayed in the "Channel Table" dialog box. See "Channel Details".

Remote command:

CONFigure:​CDPower:​CTABle:​COPY


Deleting a Table

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management > Deleting a Table
Deleting a Table

Deletes the currently selected channel table after a message is confirmed.

Remote command:

CONFigure:​CDPower:​CTABle:​DELete


Channel Table Settings and Functions

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions
Channel Table Settings and Functions

Some general settings and functions are available when configuring a predefined channel table.

Channel tables are configured in the "Channel Table" dialog box which is displayed when you select the "New", "Copy" or "Edit" buttons for a predefined channel table in the "Channel Detection" dialog box.

└ Name
└ Comment
└ MA Shifts Cell
└ Adding a Channel
└ Deleting a Channel
└ Creating a New Channel Table from the Measured Signal (Measure Table)
└ Sorting the Table by Midamble
└ Sorting the Table by Code
└ Selecting the Slot to Evaluate
└ Cancelling Configuration
└ Saving the Table


Name

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Name
Name

Name of the channel table that will be displayed in the "Predefined Channel Tables" list.

Remote command:

CONFigure:​CDPower:​CTABle:​NAME


Comment

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Comment
Comment

Optional description of the channel table.

Remote command:

CONFigure:​CDPower:​CTABle:​COMMent


MA Shifts Cell

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > MA Shifts Cell
MA Shifts Cell

Defines the maximum number of midamble shifts (i.e. the maximum number of users) in a single cell for channel detection using the predefined table.

This value replaces the global value defined by "MA Shift Cell / Number of Users".

For details see "Data Fields and Midambles".

Remote command:

CONFigure:​CDPower:​CTABle:​MSHift


Adding a Channel

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Adding a Channel
Adding a Channel

Inserts a new row in the channel table to define another channel.


Deleting a Channel

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Deleting a Channel
Deleting a Channel

Deletes the currently selected channel from the table.


Creating a New Channel Table from the Measured Signal (Measure Table)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Creating a New Channel Table from the Measured Signal (Measure Table)
Creating a New Channel Table from the Measured Signal (Measure Table)

Creates a completely new channel table according to the current measurement data.

Remote command:

CONFigure:​CDPower:​MEASurement


Sorting the Table by Midamble

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Sorting the Table by Midamble
Sorting the Table by Midamble

(BTS application only):

Sorting by midamble means that after each midamble, the corresponding code is listed. The R&S FSW automatically distinguishes between common and default midamble assignment. The assignment of code to midamble is specified in the TD-SCDMA standard.

If neither a common nor a default midamble assignment is found, sorting is in code order.

For details see "Data Fields and Midambles".


Sorting the Table by Code

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Sorting the Table by Code
Sorting the Table by Code

The midambles are sorted according to their midamble shifts. Active and inactive channels are projected to a spreading factor of 16 and sorted according to their code numbers.


Selecting the Slot to Evaluate

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Selecting the Slot to Evaluate
Selecting the Slot to Evaluate

The application analyzes a single slot over the total signal to detect channels. Which slot to analyze is defined here.

The values in the "Channel Detection" settings and in the "Evaluation Range" settings are identical.


Cancelling Configuration

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Cancelling Configuration
Cancelling Configuration

Closes the "Channel Table" dialog box without saving the changes.


Saving the Table

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Saving the Table
Saving the Table

Saves the changes to the table and closes the "Channel Table" dialog box.


Channel Details

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Details
Channel Details

Channel details are configured in the "Channel Table" dialog box which is displayed when you select the "New", "Copy" or "Edit" buttons for a predefined channel table in the "Channel Detection" dialog box.

To edit channel settings, select the corresponding cell in the table and enter the new value. Gray cells are read-only and cannot be edited.

└ Channel Type
└ Channel Number (Ch. SF)
└ Symbol Rate
└ Modulation
└ Midamble Shift
└ State
└ Domain Conflict


Channel Type

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Details > Channel Type
Channel Type

Type of channel. For a list of possible channel types see "Special Channels".

Remote command:

CONFigure:​CDPower:​CTABle:​DATA


Channel Number (Ch. SF)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Details > Channel Number (Ch. SF)
Channel Number (Ch. SF)

Channel number, defined by code and spreading factor

Remote command:

CONFigure:​CDPower:​CTABle:​DATA


Symbol Rate

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Details > Symbol Rate
Symbol Rate

Symbol rate at which the channel is transmitted.

(Read-only; for reference purposes)

For an overview of possible symbol rates depending on the modulation type and other parameters, see table "Channel parameters and their dependencies".


Modulation

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Details > Modulation
Modulation

The modulation type.

For an overview of possible modulation types and other parameters, see table "Channel parameters and their dependencies".


Midamble Shift

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Details > Midamble Shift
Midamble Shift

For channels, this is the shift of the associated midamble if a common or default midamble assignment is detected.

For details see "Data Fields and Midambles".

Remote command:

CONFigure:​CDPower:​CTABle:​MSHift


State

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Details > State
State

Indicates the channel state. Codes that are not assigned are marked as inactive channels (OFF).

Remote command:

CONFigure:​CDPower:​CTABle:​DATA


Domain Conflict

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Channel Detection > Channel Details > Domain Conflict
Domain Conflict

Indicates a code domain conflict between channel definitions (e.g. overlapping channels or conflicting channel codes).


Sweep Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Sweep Settings
Sweep Settings

The sweep settings define how the data is measured.

└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Continue Single Sweep
└ Refresh
└ Sweep/Average Count


Continuous Sweep/RUN CONT

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Sweep Settings > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. If the Sequencer is active, the "Continuous Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in continuous sweep mode is swept repeatedly.
Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Sweep Settings > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. If the Sequencer is active, the "Single Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in single sweep mode is swept only once by the Sequencer.
Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]


Continue Single Sweep

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Sweep Settings > Continue Single Sweep
Continue Single Sweep

While the measurement is running, the "Continue Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Remote command:

INITiate:​CONMeas


Refresh

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Sweep Settings > Refresh
Refresh

This function is only available if the Sequencer is deactivated and only for MSRA applications.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

This is useful, for example, after evaluation changes have been made or if a new sweep was performed from another application; in this case, only that application is updated automatically after data acquisition.

Note: To update all active applications at once, use the "Refresh all" function in the "Sequencer" menu.
(See "Refresh All" ).

Remote command:

INITiate:​REFResh


Sweep/Average Count

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Sweep Settings > Sweep/Average Count
Sweep/Average Count

Defines the number of sweeps to be performed in the single sweep mode. Values from 0 to 200000 are allowed. If the values 0 or 1 are set, one sweep is performed.

The sweep count is applied to all the traces in all diagrams.

For more information see "How Much Data is Measured: Sweep Points and Sweep Count" .

Remote command:

[SENSe:​]SWEep:​COUNt


Automatic Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Automatic Settings
Automatic Settings

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings. In order to do so, a measurement is performed. The duration of this measurement can be defined automatically or manually.

To activate the automatic adjustment of a setting, select the corresponding function in the AUTO SET menu or in the configuration dialog box for the setting, where available.

MSRA operating mode

In MSRA operating mode, the following automatic settings are not available, as they require a new data acquisition. However, TD-SCDMA applications cannot perform data acquisition in MSRA operating mode.

└ Adjusting all Determinable Settings Automatically (Auto All)
└ Setting the Reference Level Automatically (Auto Level)
└ Auto Scale Window
└ Auto Scale All
└ Restore Scale (Window)
└ Resetting the Automatic Measurement Time (Meastime Auto)
└ Changing the Automatic Measurement Time (Meastime Manual)
└ Upper Level Hysteresis
└ Lower Level Hysteresis


Adjusting all Determinable Settings Automatically (Auto All)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Automatic Settings > Adjusting all Determinable Settings Automatically (Auto All)
Adjusting all Determinable Settings Automatically (Auto All)

Activates all automatic adjustment functions for the current measurement settings.

This includes:

  • Auto Level
  • "Auto Scale All"

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​ALL


Auto Scale Window

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Automatic Settings > Auto Scale Window
Auto Scale Window

Automatically determines the optimal range and reference level position to be displayed for the current measurement settings in the currently selected window. No new measurement is performed.


Auto Scale All

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Automatic Settings > Auto Scale All
Auto Scale All

Automatically determines the optimal range and reference level position to be displayed for the current measurement settings in all displayed diagrams. No new measurement is performed.


Resetting the Automatic Measurement Time (Meastime Auto)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Automatic Settings > Resetting the Automatic Measurement Time (Meastime Auto)
Resetting the Automatic Measurement Time (Meastime Auto)

Resets the measurement duration for automatic settings to the default value.

For details see "Adjusting Settings Automatically" .

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE


Changing the Automatic Measurement Time (Meastime Manual)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Automatic Settings > Changing the Automatic Measurement Time (Meastime Manual)
Changing the Automatic Measurement Time (Meastime Manual)

This function allows you to change the measurement duration for automatic setting adjustments. Enter the value in seconds.

For details see "Adjusting Settings Automatically" .

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE

[SENSe:​]ADJust:​CONFigure:​DURation


Upper Level Hysteresis

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Automatic Settings > Upper Level Hysteresis
Upper Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​UPPer


Lower Level Hysteresis

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Automatic Settings > Lower Level Hysteresis
Lower Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​LOWer


BW, Span, Lines and Marker Function Menus

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > BW, Span, Lines and Marker Function Menus
BW, Span, Lines and Marker Function Menus

The "Span", "Bandwidth", "Lines", and "Marker Functions" menus are not available for Code Domain Analysis in TD-SCDMA applications.


Zoom Functions

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Zoom Functions
Zoom Functions

The zoom functions are only available from the toolbar.

For details on the zoom functions see "Single Zoom Versus Multiple Zoom" .

└ Single Zoom
└ Multiple Zoom
└ Restore Original Display
└ Deactivating Zoom (Selection mode)


Single Zoom

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Zoom Functions > Single Zoom
Single Zoom

A single zoom replaces the current diagram by a new diagram which displays an enlarged extract of the trace. This function can be used repetitively until the required details are visible.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​AREA


Multiple Zoom

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Zoom Functions > Multiple Zoom
Multiple Zoom

In multiple zoom mode, you can enlarge several different areas of the trace simultaneously. An overview window indicates the zoom areas in the original trace, while the zoomed trace areas are displayed in individual windows. The zoom area that corresponds to the individual zoom display is indicated in the lower right corner, between the scrollbars.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​AREA


Restore Original Display

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Zoom Functions > Restore Original Display
Restore Original Display

Restores the original display and closes all zoom windows.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Deactivating Zoom (Selection mode)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Code Domain Analysis > Zoom Functions > Deactivating Zoom (Selection mode)
Deactivating Zoom (Selection mode)

Deactivates zoom mode.

Tapping the screen no longer invokes a zoom, but selects an object.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Frequency and Time Domain Measurements

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements
Frequency and Time Domain Measurements

TD-SCDMA measurements require a special application on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you activate a TD-SCDMA application, Code Domain Analysis of the input signal is started automatically. However, the TD-SCDMA applications also provide various frequency and time domain measurement types.

Selecting the measurement type
►

To select a frequency and time domain measurement type, do one of the following:

  • Select the "Overview" softkey. In the "Overview", select the "Select Measurement" button. Select the required measurement.
  • Press the MEAS key on the front panel. In the "Select Measurement" dialog box, select the required measurement.

Some parameters are set automatically according to the TD-SCDMA standard the first time a measurement is selected (since the last PRESET operation). A list of these parameters is given with each measurement type. The parameters can be changed, but are not reset automatically the next time you re-enter the measurement.

The main measurement configuration menus for the RF measurements are identical to the Spectrum application.

For details refer to "Common Measurement Settings" .

The measurement-specific settings for the following measurements are available in the "Analysis" dialog box (via the "Overview").

Contents
  • Power vs Time
  • Signal Channel Power Measurements
  • Channel Power (ACLR) Measurements
  • Spectrum Emission Mask
  • Occupied Bandwidth
  • CCDF


Power vs Time

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Power vs Time
Power vs Time

The Power vs Time measurement checks the signal power against a transmission power mask defined by the TD-SCDMA specification.

Contents
  • Default Settings for PvT Measurements
  • PvT Configuration Overview
  • PvT Measurement Settings


Default Settings for PvT Measurements

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Power vs Time > Default Settings for PvT Measurements
Default Settings for PvT Measurements

By default, the following settings are used for a Power vs Time measurement in the TD-SCDMA BTS application:

Parameter | Default Value
Span | Zero Span
Sweep Time | 2.4 ms
RBW | 1.28 MHz
VBW | 10 MHz
Trace Mode | Average
Switching point (BTS application only): | 3
Number of subframes | 100


PvT Configuration Overview

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Power vs Time > PvT Configuration Overview
PvT Configuration Overview

For Power vs Time measurements, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

The "Signal Description", "Signal Capture" and "Channel Detection" buttons indicated in the "Overview" are not available for TD-SCDMA Power vs Time measurements.

  1. "Select Measurement"

    See "Measurements and Result Display"

  2. "Input/ Frontend"

    See "Data Input and Output Settings"

  3. (Optionally:) "Trigger"

    See "Trigger Settings"

  4. "Synchronization"

    See "Synchronization"

  5. "Analysis"

    See "Analysis"

  6. "Display Configuration"

    See "Result Display Configuration"

The "Span", "Lines", and "Marker Functions" menus are not available for Power vs Time measurements in TD-SCDMA applications.

To configure settings
►

Select any button in the "Overview" to open the corresponding dialog box.

Select a setting in the channel bar (at the top of the measurement channel tab) to change a specific setting.

└ Preset Channel
└ Select Measurement
└ Specifics for


Select Measurement

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Power vs Time > PvT Configuration Overview > Select Measurement
Select Measurement

Selects a different measurement to be performed.

See "Measurements and Result Display".


PvT Measurement Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Power vs Time > PvT Measurement Settings
PvT Measurement Settings

The following settings and functions are specific to the Power vs Time measurement in the TD-SCDMA applications. They are available from the "Power vs Time" menu, which is displayed when you press the MEAS CONFIG key.

└ Switching Point
└ Start Meas
└ No of Subframes
└ Adapting the Measurement to the Current Signal
└ Start Slot / Stop Slot
└ Auto Level & Time


Switching Point

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Power vs Time > PvT Measurement Settings > Switching Point
Switching Point

(BTS application only):

The switching point defines the border between uplink slots and downlink slots and is between 1 and 6.

In downlink Power vs Time measurements, the slots of interest are defined as the range from slot 1 to the slot indicated by the "Switching Point".

In the TD-SCDMA UE application, the slot of interest is slot 1, which cannot be changed. Thus, the switching point is irrelevant.

Remote command:

CONFigure:​CDPower[:​BTS]:​PVTime:​SPOint


Start Meas

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Power vs Time > PvT Measurement Settings > Start Meas
Start Meas

Starts measuring the power for the defined number of subframes (same effect as pressing the RUN SINGLE key).

Remote command:

INIT:CONT OFF, see INITiate:​CONTinuous

INITiate[:​IMMediate]


No of Subframes

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Power vs Time > PvT Measurement Settings > No of Subframes
No of Subframes

Defines the number of subframes that the R&S FSW includes in the measurement. The results of the Power vs Time measurement are based on the average of the number of the subframes. This setting is identical to the "Sweep/Average Count".

Remote command:

CONFigure:​CDPower[:​BTS]:​PVTime:​SFRames


Adapting the Measurement to the Current Signal

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Power vs Time > PvT Measurement Settings > Adapting the Measurement to the Current Signal
Adapting the Measurement to the Current Signal

You can adapt the measurement range to the current TD-SCDMA signal.

└ Start Slot / Stop Slot
└ Auto Level & Time


Start Slot / Stop Slot

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Power vs Time > PvT Measurement Settings > Adapting the Measurement to the Current Signal > Start Slot / Stop Slot
Start Slot / Stop Slot

(BTS application only):

Defines the measurement range for Channel Power measurements as a range of slots in the current TD-SCDMA signal, e.g. the downlink slots 4 to 6, for a "Switching Point" = 3.

Remote command:

[SENSe:​]POWer:​ACHannel:​SLOT:​STARt

[SENSe:​]POWer:​ACHannel:​SLOT:​STOP


Auto Level & Time

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Power vs Time > PvT Measurement Settings > Adapting the Measurement to the Current Signal > Auto Level & Time
Auto Level & Time

Automatically adjusts the reference level and the trigger offset to subframe start to their optimum levels for the current signal. This prevents overloading the R&S FSW.

When this function is activated, current measurements are aborted and resumed after the automatic level detection is finished.

Remote command:

[SENSe:​]POWer:​ACHannel:​AUTO:​LTIMe


Signal Channel Power Measurements

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Signal Channel Power Measurements
Signal Channel Power Measurements

The Power measurement determines the TD-SCDMA signal channel power in a single channel with a bandwidth of 1.2288 MHz.

In order to determine the signal power, the TD-SCDMA application performs a Channel Power measurement as in the Spectrum application with the following settings:

Predefined settings for TD-SCDMA Signal Channel Power measurements
Standard | TD SCDMA FWD (UE: TD SCDMA REV)
Number of adjacent channels | 0
Frequency span | 3 MHz
Measurement bandwidth | 1.6 MHz

The main measurement menus and the configuration "Overview" for the RF measurements are identical to the Spectrum application. However, an additional function is provided to adapt the Power measurement to the current TD-SCDMA signal.

└ Adapting the Measurement to the Current Signal
└ Start Slot / Stop Slot
└ Auto Level & Time


Auto Level & Time

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Signal Channel Power Measurements > Adapting the Measurement to the Current Signal > Auto Level & Time
Auto Level & Time

Automatically adjusts the reference level and the trigger offset to subframe start to their optimum levels for the current signal. This prevents overloading the R&S FSW.

When this function is activated, current measurements are aborted and resumed after the automatic level detection is finished.

Remote command:

[SENSe:​]POWer:​ACHannel:​AUTO:​LTIMe


Channel Power (ACLR) Measurements

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Channel Power (ACLR) Measurements
Channel Power (ACLR) Measurements

Channel Power ACLR measurements are performed as in the Spectrum application with the following predefined settings according to TD-SCDMA specifications (adjacent channel leakage ratio).

Predefined settings for TD-SCDMA ACLR Channel Power measurements
Standard | TD SCDMA FWD (UE: TD SCDMA REV)
Number of adjacent channels | 2

For further details about the ACLR measurements refer to "Channel Power and Adjacent-Channel Power (ACLR) Measurement" .

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • RBW, VBW
  • Sweep time
  • Span
  • Number of adjacent channels
  • Fast ACLR mode

The main measurement menus and the configuration "Overview" for the RF measurements are identical to the Spectrum application. However, an additional function is provided to adapt the ACLR measurement to the current TD-SCDMA signal.

└ Adapting the Measurement to the Current Signal
└ Start Slot / Stop Slot
└ Auto Level & Time


Auto Level & Time

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Channel Power (ACLR) Measurements > Adapting the Measurement to the Current Signal > Auto Level & Time
Auto Level & Time

Automatically adjusts the reference level and the trigger offset to subframe start to their optimum levels for the current signal. This prevents overloading the R&S FSW.

When this function is activated, current measurements are aborted and resumed after the automatic level detection is finished.

Remote command:

[SENSe:​]POWer:​ACHannel:​AUTO:​LTIMe


Spectrum Emission Mask

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Spectrum Emission Mask
Spectrum Emission Mask

The Spectrum Emission Mask measurement determines the power of the TD-SCDMA signal in defined offsets from the carrier and compares the power values with a spectral mask specified by TD-SCDMA.

For further details about the Spectrum Emission Mask measurements refer to "Spectrum Emission Mask (SEM) Measurement" .

The TD-SCDMA applications perform the SEM measurement as in the Spectrum application with the following settings:

Predefined settings for TD-SCDMA SEM measurements
Span | +/- 4 MHz
Number of ranges | 9
Fast SEM | ON
Number of power classes | 1
Channel bandwidth | 1.28 MHz
Power reference type | Channel power
Detector | RMS

Changing the RBW and the VBW is restricted due to the definition of the limits by the standard.

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • Sweep time
  • Span

The main measurement menus and the configuration "Overview" for the RF measurements are identical to the Spectrum application. However, an additional function is provided to adapt the SEM measurement to the current TD-SCDMA signal.

└ Adapting the Measurement to the Current Signal
└ Start Slot / Stop Slot
└ Auto Level & Time


Auto Level & Time

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Spectrum Emission Mask > Adapting the Measurement to the Current Signal > Auto Level & Time
Auto Level & Time

Automatically adjusts the reference level and the trigger offset to subframe start to their optimum levels for the current signal. This prevents overloading the R&S FSW.

When this function is activated, current measurements are aborted and resumed after the automatic level detection is finished.

Remote command:

[SENSe:​]POWer:​ACHannel:​AUTO:​LTIMe


Occupied Bandwidth

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Occupied Bandwidth
Occupied Bandwidth

The Occupied Bandwidth measurement determines the bandwidth that the signal occupies. The occupied bandwidth is defined as the bandwidth in which – in default settings - 99 % of the total signal power is to be found. The percentage of the signal power to be included in the bandwidth measurement can be changed.

The Occupied Bandwidth measurement is performed as in the Spectrum application with the following predefined settings according to TD-SCDMA specifications:

Predefined settings for TD-SCDMA OBW measurements
Setting | Default value
% Power Bandwidth | 99 %
Channel bandwidth | 1.28 MHz
Sweep Time | 676 ms
RBW | 30 kHz
VBW | 300 kHz
Detector | RMS
Trigger | Gated, IF power

For further details about the Occupied Bandwidth measurements refer to "Occupied Bandwidth Measurement (OBW)" .

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • RBW, VBW
  • Sweep time
  • Span

The main measurement menus and the configuration "Overview" for the RF measurements are identical to the Spectrum application. However, an additional function is provided to adapt the OBW measurement to the current TD-SCDMA signal.

└ Adapting the Measurement to the Current Signal
└ Start Slot / Stop Slot
└ Auto Level & Time


Auto Level & Time

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > Occupied Bandwidth > Adapting the Measurement to the Current Signal > Auto Level & Time
Auto Level & Time

Automatically adjusts the reference level and the trigger offset to subframe start to their optimum levels for the current signal. This prevents overloading the R&S FSW.

When this function is activated, current measurements are aborted and resumed after the automatic level detection is finished.

Remote command:

[SENSe:​]POWer:​ACHannel:​AUTO:​LTIMe


CCDF

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > CCDF
CCDF

The CCDF measurement determines the distribution of the signal amplitudes (complementary cumulative distribution function).

The CCDF measurement is performed as in the Spectrum application with the following settings:

Predefined settings for TD-SCDMA CCDF measurements
CCDF | Active on trace 1
Analysis bandwidth | 10 MHz
Number of samples | 500000
Detector | Sample

For further details about the CCDF measurements refer to "Statistical Measurements (APD, CCDF)" .

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • Analysis bandwidth
  • Number of samples

The main measurement menus and the configuration "Overview" for the RF measurements are identical to the Spectrum application. However, an additional function is provided to adapt the CCDF measurement to the current TD-SCDMA signal.

└ Adapting the Measurement to the Current Signal
└ Start Slot / Stop Slot
└ Auto Level & Time


Auto Level & Time

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Configuration > Frequency and Time Domain Measurements > CCDF > Adapting the Measurement to the Current Signal > Auto Level & Time
Auto Level & Time

Automatically adjusts the reference level and the trigger offset to subframe start to their optimum levels for the current signal. This prevents overloading the R&S FSW.

When this function is activated, current measurements are aborted and resumed after the automatic level detection is finished.

Remote command:

[SENSe:​]POWer:​ACHannel:​AUTO:​LTIMe


Analysis

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis
Analysis

General result analysis settings concerning the evaluation range, trace, markers, etc. can be configured via the "Analysis" button in the "Overview".

Analysis of RF Measurements

General result analysis settings concerning the trace, markers, lines etc. for RF measurements are identical to the analysis functions in the Spectrum application except for some special marker functions and spectrograms, which are not available in TD-SCDMA applications.

See
  • "Common Analysis and Display Functions"
  • "Analyzing Measurements (Basics)"

The remote commands required to perform these tasks are described in "Analysis".

Contents
  • Evaluation Range
  • Code Domain Analysis Settings
  • Traces
  • Markers


Evaluation Range

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Evaluation Range
Evaluation Range

The evaluation range defines which channel, slot or set is evaluated in the result display.

The set to analyze can also be defined in the "Signal Capture" settings, see "Set to Analyze".

└ Channel (Code) Number
└ Slot Number
└ Set to Analyze


Channel (Code) Number

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Evaluation Range > Channel (Code) Number
Channel (Code) Number

Selects a channel for the following evaluations:

  • Bitstream
  • Power vs Slot
  • Power vs Symbol
  • Result Summary
  • Symbol Constellation
  • Symbol EVM

Enter a code number and spreading factor, separated by a decimal point.

The specified channel is selected and marked in red in the corresponding result displays, if active. If no spreading factor is specified, the code on the basis of the spreading factor 16 is marked. For unused channels, the code resulting from the conversion is marked.

Example: Enter 4.8

Channel 4 is marked at spreading factor 8 (35.2 ksps) if the channel is active, otherwise code 7 at spreading factor 16.

Remote command:

[SENSe:​]CDPower:​CODE


Slot Number

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Evaluation Range > Slot Number
Slot Number

Selects the slot for evaluation. This affects channel detection as well as the following evaluations (see also "Evaluation Methods for Code Domain Analysis"):

  • Bitstream
  • Channel Table
  • Code Domain Power
  • Code Domain Error Power
  • Result Summary
  • Composite Constellation
  • Power vs Symbol
  • Result Summary
  • Symbol Constellation
  • Symbol EVM
Remote command:

[SENSe:​]CDPower:​SLOT


Set to Analyze

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Evaluation Range > Set to Analyze
Set to Analyze

Selects a specific set for further analysis. The value range depends on the "Set Count" and is between 0 and [Set Count-1].

Remote command:

[SENSe:​]CDPower:​SET


Code Domain Analysis Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Code Domain Analysis Settings
Code Domain Analysis Settings

Some evaluations provide further settings for the results.

└ Compensate IQ Offset
└ Code Power Display
└ Channel Table Sort Order
└ Show DwPTS Results (BTS mode)
└ Show UpPTS Results (UE mode)


Compensate IQ Offset

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Code Domain Analysis Settings > Compensate IQ Offset
Compensate IQ Offset

If enabled, the I/Q offset is eliminated from the measured signal. This is useful to deduct a DC offset to the baseband caused by the DUT, thus improving the EVM. Note, however, that for EVM measurements according to standard, compensation must be disabled.

Remote command:

[SENSe:​]CDPower:​NORMalize


Code Power Display

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Code Domain Analysis Settings > Code Power Display
Code Power Display

For "Code Domain Power" evaluation:

Defines whether the absolute power or the power relative to the total power of the data parts of the signal is displayed.

Remote command:

[SENSe:​]CDPower:​PDISplay


Channel Table Sort Order

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Code Domain Analysis Settings > Channel Table Sort Order
Channel Table Sort Order

You can sort channels in the Channel Table result display in two ways:

"Code Order"

First, all midambles are listed, then all control channels and last all data channels

The midambles are sorted according to their midamble shifts. Active and inactive channels are projected to a spreading factor of 16 and sorted according to their code numbers.

"Midamble Order"

All control and data channels are assigned to the midambles they belong to; the midambles are in ascending order

The TD-SCDMA application automatically distinguishes between common and default midamble allocation. If neither a common nor a default midamble allocation is found, sorting is in code order.

The allocation of code to midamble is specified in the TD-SCDMA standard. (See also "Data Fields and Midambles").

Remote command:

CONFigure:​CDPower:​CTABle:​ORDer


Show DwPTS Results (BTS mode)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Code Domain Analysis Settings > Show DwPTS Results (BTS mode)
Show DwPTS Results (BTS mode)

Displays additional information on the "Downlink Pilot Time Slot" (DwPTS, see also "Frames, Subframes and Slots") in the Result Summary.

Remote command:

[SENSe:​]CDPower:​PTS


Show UpPTS Results (UE mode)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Code Domain Analysis Settings > Show UpPTS Results (UE mode)
Show UpPTS Results (UE mode)

Displays additional information on the "Uplink Pilot Time Slot" (UpPTS, see also "Frames, Subframes and Slots") in the Result Summary.

Remote command:

[SENSe:​]CDPower:​PTS


Traces

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Traces
Traces

The trace settings determine how the measured data is analyzed and displayed on the screen.

In CDA evaluations, only one trace can be active in each diagram at any time.

Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

└ Trace Mode


Trace Mode

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Traces > Trace Mode
Trace Mode

Defines the update mode for subsequent traces.

For details see "Analyzing Several Traces - Trace Mode" .

"Clear Write" | Overwrite mode: the trace is overwritten by each sweep. This is the default setting.
"Max Hold" | The maximum value is determined over several sweeps and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is greater than the previous one.
"Min Hold" | The minimum value is determined from several measurements and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is lower than the previous one.
"Average" | The average is formed over several sweeps.
"View" | The current contents of the trace memory are frozen and displayed.
"Blank" | Removes the selected trace from the display.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE


Markers

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers
Markers

Markers help you analyze your measurement results by determining particular values in the diagram. Thus you can extract numeric values from a graphical display.

Markers are configured in the "Marker" dialog box which is displayed when you do one of the following:

  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab.
  • Press the MKR key, then select the "Marker Config" softkey.
Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

Markers in Code Domain Analysis measurements

In Code Domain Analysis measurements, the markers are set to individual symbols, codes, slots or channels, depending on the result display. Thus you can use the markers to identify individual codes, for example.

Contents
  • Individual Marker Settings
  • General Marker Settings
  • Marker Search Settings
  • Marker Positioning Functions


Individual Marker Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Individual Marker Settings
Individual Marker Settings

In CDA evaluations, up to 4 markers can be activated in each diagram at any time.

└ Marker 1 / Marker 2 / Marker 3 / Marker 4
└ Selected Marker
└ Marker State
└ X-value
└ Marker Type
└ All Markers Off


Marker 1 / Marker 2 / Marker 3 / Marker 4

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Individual Marker Settings > Marker 1 / Marker 2 / Marker 3 / Marker 4
Marker 1 / Marker 2 / Marker 3 / Marker 4

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.

Marker 1 is always the default reference marker for relative measurements. If activated, markers 2 to 4 are delta markers that refer to marker 1. These markers can be converted into markers with absolute value display using the "Marker Type" function.

If normal marker 1 is the active marker, pressing the "Mkr Type" softkey switches on an additional delta marker 1.

Several markers can be configured very easily using the "Marker" dialog box, see "Marker Settings" .

Note: For Code Domain Analysis the marker position moves from one slot (PCG) / channel / code / symbol to the next, depending on the current evaluation.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?

CALCulate<n>:​DELTamarker<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​DELTamarker<m>:​X:​RELative?

CALCulate<n>:​DELTamarker<m>:​Y?


Selected Marker

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Individual Marker Settings > Selected Marker
Selected Marker

Marker name. The marker which is currently selected for editing is highlighted orange.

Remote command:

Marker selected via suffix <m> in remote commands.


Marker State

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Individual Marker Settings > Marker State
Marker State

Activates or deactivates the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


X-value

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Individual Marker Settings > X-value
X-value

Defines the position of the marker on the x-axis (channel, slot, symbol, depending on evaluation).

Remote command:

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​MARKer<m>:​X


Marker Type

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Individual Marker Settings > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


All Markers Off

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Individual Marker Settings > All Markers Off
All Markers Off

Deactivates all markers in one step.

Remote command:

CALCulate<n>:​MARKer<m>:​AOFF


General Marker Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > General Marker Settings
General Marker Settings

General marker settings are defined in the "Marker Config" tab of the "Marker" dialog box.

└ Marker Table Display


Marker Table Display

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > General Marker Settings > Marker Table Display
Marker Table Display

Defines how the marker information is displayed.

For more details see "Marker Results" .

"On" | Displays the marker information in a table in a separate area beneath the diagram.
"Off" | Displays the marker information within the diagram area.
"Auto" | (Default) Up to two markers are displayed in the diagram area. If more markers are active, the marker table is displayed automatically.
Remote command:

DISPlay:​MTABle


Marker Search Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Marker Search Settings
Marker Search Settings

Several functions are available to set the marker to a specific position very quickly and easily. In order to determine the required marker position, searches may be performed. The search results can be influenced by special settings.

These settings are available as softkeys in the "Marker To" menu, or in the "Search" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey. Then select the horizontal "Search" tab.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Config" tab. Then select the horizontal "Search" tab.
└ Search Mode for Next Peak


Search Mode for Next Peak

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Marker Search Settings > Search Mode for Next Peak
Search Mode for Next Peak

Selects the search mode for the next peak search.

"Left" | Determines the next maximum/minimum to the left of the current peak.
"Absolute" | Determines the next maximum/minimum to either side of the current peak.
"Right" | Determines the next maximum/minimum to the right of the current peak.
Remote command:

CALCulate<n>:​DELTamarker<m>:​MAXimum:​LEFT

CALCulate<n>:​MARKer<m>:​MAXimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MAXimum:​RIGHt

CALCulate<n>:​DELTamarker<m>:​MINimum:​LEFT

CALCulate<n>:​MARKer<m>:​MINimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MINimum:​RIGHt


Marker Positioning Functions

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Marker Positioning Functions
Marker Positioning Functions

The following functions set the currently selected marker to the result of a peak search. These functions are available as softkeys in the "Marker To" menu, which is displayed when you press the MKR -> key.

Markers in Code Domain Analysis measurements

In Code Domain Analysis measurements, the markers are set to individual symbols, codes, slots or channels, depending on the result display. Thus you can use the markers to identify individual codes, for example.

└ Select Marker
└ Search Next Peak
└ Search Next Minimum
└ Peak Search
└ Search Minimum


Select Marker

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Marker Positioning Functions > Select Marker
Select Marker

Selects the subsequent marker (marker 1/2/3/4 or delta marker) to be edited or to be used for a marker function. The currently selected marker number is highlighted.

Remote command:

Marker selected via suffix <m> in remote commands.


Search Next Peak

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Marker Positioning Functions > Search Next Peak
Search Next Peak

Sets the selected marker/delta marker to the next (lower) maximum of the assigned trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT


Search Next Minimum

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Marker Positioning Functions > Search Next Minimum
Search Next Minimum

Sets the selected marker/delta marker to the next (higher) minimum of the selected trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT


Peak Search

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Marker Positioning Functions > Peak Search
Peak Search

Sets the selected marker/delta marker to the maximum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]


Search Minimum

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Analysis > Markers > Marker Positioning Functions > Search Minimum
Search Minimum

Sets the selected marker/delta marker to the minimum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Optimizing and Troubleshooting the Measurement

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Optimizing and Troubleshooting the Measurement
Optimizing and Troubleshooting the Measurement

If the results do not meet your expectations, try the following methods to optimize the measurement:

Synchronization fails
  • Check the frequency.
  • Check the reference level.
  • When using an external trigger, check whether an external trigger is being sent to the R&S FSW.
  • Check the carrier frequency error (see "Code Domain Parameters")
    Frequency differences between the transmitter and receiver of more than 1.0 kHz impair synchronization of the Code Domain Power measurement. If at all possible, the transmitter and the receiver should be synchronized.
  • Check the chip rate error. A large chip rate error results in symbol errors and, therefore, in possible synchronization errors for code domain measurements.
EVM and Error results are too high

Only the channels detected as being active are used to generate the ideal reference signal. If a channel is not detected as being active, e.g. on account of low power, the difference between the test signal and the reference signal and therefore the (composite) EVM and code domain errors are very large.

Distortions also occur if unassigned codes are wrongly given the status of "active channel". To obtain reliable measurement results, select an adequate channel threshold.

Contents
  • Error Messages


Error Messages

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Optimizing and Troubleshooting the Measurement > Error Messages
Error Messages

Error messages are entered in the error/event queue of the status reporting system in the remote control mode and can be queried with the command SYSTem:ERRor?.

A short explanation of the device-specific error messages for the TD-SCDMA applications is given below.

Status bar message | Description
Sync not found | This message is displayed if synchronization is not possible. Possible causes are that frequency, level, scrambling code, Invert Q values are set incorrectly, or the input signal is invalid.


How to Perform Measurements in TD-SCDMA Applications

TD-SCDMA Measurements (R&S FSW-K76/-K77) > How to Perform Measurements in TD-SCDMA Applications
How to Perform Measurements in TD-SCDMA Applications

The following step-by-step instructions demonstrate how to perform measurements with the TD-SCDMA applications.

The following tasks are described:
  • "To perform Code Domain Analysis"
  • "To define or edit a channel table"
  • "To perform a Power vs Time check"
  • "To perform an RF measurement"
  • "To select the application data for MSRA measurements"
To perform Code Domain Analysis

  1. Press the MODE key on the front panel and select the "TD-SCDMA BTS" applications for base station tests, or "TD-SCDMA UE" for user equipment tests.

    Code Domain Analysis of the input signal is performed by default.

  2. Select the "Overview" softkey to display the "Overview" for Code Domain Analysis.

  3. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's center frequency.

  4. Select the "Amplitude" tab to define the reference level and other settings concerning the expected power levels.

  5. Optionally, in the "Overview", select the "Trigger" button and define a trigger for data acquisition, for example an external trigger to start capturing data only when a useful signal is transmitted.

  6. Select the "Signal Capture" button and define the acquisition parameters for the input signal, i.e. how many sets and slots are to be captured.

    In MSRA mode, define the application data instead, see "To select the application data for MSRA measurements".

  7. Select the "Synchronization" button and define the channel synchronization settings, i.e. the maximum number of users and the scrambling code to be expected in the input signal.

  8. Select the "Channel Detection" button and define how the individual channels are to be detected within the input signal. If necessary, define a channel table as described in "To define or edit a channel table".

  9. Select the "Display Config" button and select the evaluation methods that are of interest to you.

    Arrange them on the display to suit your preferences.

  10. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  11. Select the "Analysis" button in the "Overview" to configure how the data is evaluated in the individual result displays.

    • Select the channel, slot and set to be evaluated.
    • Configure specific settings for the selected evaluation method(s).
    • Optionally, configure the trace to display the average over a series of measurements. If necessary, increase the "Sweep/Average Count" in the "Sweep Config" dialog box.
    • Configure markers and delta markers to determine deviations and offsets within the results, e.g. when comparing errors or peaks.

  12. Start a new measurement with the defined settings.

    In MSRA mode you may want to stop the continuous measurement mode by the Sequencer and perform a single data acquisition:

    1. Select the Sequencer icon ( [image]) from the toolbar.

    2. Set the Sequencer state to "OFF".

    3. Press the RUN SINGLE key.

To define or edit a channel table

Channel tables contain a list of channels to be detected and their specific parameters. You can create user-defined and edit pre-defined channel tables.

  1. Select the "Channel Detection" softkey from the main "Code Domain Analyzer" menu to open the "Channel Detection" dialog box.

  2. To define a new channel table, select the "New" button next to the "Predefined Tables" list.

    To edit an existing channel table:

    1. Select the existing channel table in the "Predefined Tables" list.

    2. Select the "Edit" button next to the "Predefined Tables" list.

  3. In the "Channel Table" dialog box, define a name and, optionally, a comment that describes the channel table. The comment is displayed when you set the focus on the table in the "Predefined Tables" list.

  4. Define the maximum number of users ("MA Shifts Cell") to be used for the channel table.

  5. Define the channels to be detected using one of the following methods:

    Select the "Measure Table" button to create a table that consists of the channels detected in the currently measured signal.

    Or:

    1. Select the "Add Channel" button to insert a row for a new channel below the currently selected row in the channel table.

    2. Define the channel specifications required for detection.

  6. Select the "Save Table" button to store the channel table.

    The table is stored and the dialog box is closed. The new channel table is included in the "Predefined Tables" list in the "Channel Detection" dialog box.

  7. To activate the use of the new channel table:

    1. Select the table in the "Predefined Tables" list.

    2. Select the "Select" button.

      A checkmark is displayed next to the selected table.

    3. Toggle the "Use Predefined Channel Table" setting to "Predefined".

    4. Close the dialog box.

    5. Start a new measurement.

To perform a Power vs Time check

The Power vs Time measurement checks the signal power in the time domain against a transmission power mask defined by the TD-SCDMA specification (for details see "Power vs Time").

  1. Press the MODE key on the front panel and select the "TD-SCDMA BTS" applications for base station tests, or "TD-SCDMA UE" for user equipment tests.

    Code Domain Analysis of the input signal is performed by default.

  2. Switch to the Power vs Time measurement:

    1. Press the MEAS key on the front panel.

    2. In the "Select Measurement" dialog box, select the "Power vs Time" button.

  3. For downlink measurements (BTS application) only:

    Select the "Switching Point" softkey to define the slot which separates the uplink from the downlink data. Only the slots for downlink data are measured and checked against the transmission power mask.

    (For uplink measurements, the application always measures slot 1, thus the switching point is irrelevant.)

  4. For downlink measurements (BTS application):

    Select the "Auto Level & Time" softkey to adjust the reference level and the trigger offset to subframe start to their optimum levels for the current signal.

    For uplink measurements, select the "Adapt to Signal" softkey and then the "Auto Level & Time" button to adjust the reference level and the trigger offset to subframe start automatically.

  5. Select the "No. of Subframes" softkey to define how many slots are taken into consideration for the Power vs Time results.

  6. Optionally, press the TRIGGER key and define a trigger for the measurement, for example an external trigger to start measuring only when a useful signal is transmitted.

  7. Select the "Start Meas" softkey or press the RUN SINGLE key to start a new measurement.

    The Power vs Time diagram is displayed, averaged over the defined number of subframes. The result of the limit check against the transmission power mask is also indicated.

  8. To display the numerical results, select the "Display Config" softkey and drag the "Evaluation List" result to the display.

To perform an RF measurement

  1. Press the MODE key on the front panel and select the "TD-SCDMA BTS" applications for base station tests, or "TD-SCDMA UE" for user equipment tests.

    Code Domain Analysis of the input signal is performed by default.

  2. Select the RF measurement:

    1. Press the MEAS key on the front panel.

    2. In the "Select Measurement" dialog box, select the required measurement.

    The selected measurement is activated with the default settings for TD-SCDMA mode immediately.

  3. If necessary, adapt the settings as described for the individual measurements in "Measurements" .

  4. Select the "Display Config" button and select the evaluation methods that are of interest to you.

    Arrange them on the display to suit your preferences.

  5. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  6. Select the "Analysis" button in the "Overview" to make use of the advanced analysis functions in the result displays.

    • Configure a trace to display the average over a series of sweeps; if necessary, increase the "Sweep Count" in the "Sweep" settings.
    • Configure markers and delta markers to determine deviations and offsets within the evaluated signal.
    • Use special marker functions to calculate noise or a peak list.
    • Configure a limit check to detect excessive deviations.

  7. Optionally, export the trace data of the graphical evaluation results to a file.

    1. In the "Traces" tab of the "Analysis" dialog box, switch to the "Trace Export" tab.

    2. Select "Export Trace to ASCII File".

    3. Define a file name and storage location and select "OK".

To select the application data for MSRA measurements

In multi-standard radio analysis you can analyze the data captured by the MSRA Master in the TD-SCDMA BTS application. Assuming you have detected a suspect area of the captured data in another application, you would now like to analyze the same data in the TD-SCDMA BTS application.

  1. Select the "Overview" softkey to display the "Overview" for Code Domain Analysis.

  2. Select the "Signal Capture" button.

  3. Define the application data range as the "Capture Length (Slots)".

  4. Define the starting point of the application data as the "Capture offset". The offset is calculated according to the following formula:

    <capture offset> = <starting point for application> - <starting point in capture buffer>

  5. The analysis interval is automatically determined according to the selected channel, slot or set to analyze (defined for the evaluation range), depending on the result display. Note that the set/slot/channel is analyzed within the application data. If the analysis interval does not yet show the required area of the capture buffer, move through the sets/slots/channels in the evaluation range or correct the application data range.

  6. If the Sequencer is off, select the "Refresh" softkey in the "Sweep" menu to update the result displays for the changed application data.


Remote Commands for TD-SCDMA Measurements

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements
Remote Commands for TD-SCDMA Measurements

The following commands are required to perform measurements in TD-SCDMA applications in a remote environment. It assumes that the R&S FSW has already been set up for remote operation in a network as described in the base unit manual.

(See "How to Set Up a Network and Remote Control" .)

Note that basic tasks that are also performed in the base unit in the same way are not described here.

In particular, this includes:

  • Managing Settings and Results, i.e. storing and loading settings and result data, see "Managing Settings and Results"
  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation, see "Configuring the "
  • Using the common status registers, see "Using the Status Register"

The following topics specific to TD-SCDMA applications are described here:

Contents
  • Introduction
  • Common Suffixes
  • Activating the TD-SCDMA Applications
  • Selecting a Measurement
  • Configuring Code Domain Analysis
  • Configuring Frequency and Time Domain Measurements
  • Configuring the Result Display
  • Starting a Measurement
  • Retrieving Results
  • Analysis
  • Configuring the Application Data Range (MSRA mode only)
  • Status Registers
  • Commands for Compatibility
  • Programming Examples (TD-SCDMA BTS)


Introduction

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Common Suffixes

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Common Suffixes
Common Suffixes

In TD-SCDMA applications, the following common suffixes are used in remote commands:

Suffix | Value range | Description
<n> | 1..16 | Window
<t> | 1 (CDA) 6 (Frequency and time domain) | Trace
<m> | 1..4 (CDA) 1..16 (Frequency and time domain) | Marker


Activating the TD-SCDMA Applications

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Activating the TD-SCDMA Applications
Activating the TD-SCDMA Applications

TD-SCDMA measurements require a special application on the R&S FSW. The measurement is started immediately with the default settings.

List of Commands
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:CHANnel[:EXECute]


INSTrument:CREate:DUPLicate

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Activating the TD-SCDMA Applications > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect] ).

This command is not available if the MSRA Master channel is selected.

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Activating the TD-SCDMA Applications > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .


INSTrument:CREate:REPLace

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Activating the TD-SCDMA Applications > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.


INSTrument:DELete

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Activating the TD-SCDMA Applications > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Activating the TD-SCDMA Applications > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Activating the TD-SCDMA Applications > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Activating the TD-SCDMA Applications > INSTrument[:SELect]
INSTrument[:SELect] <Mode>

This command activates a new measurement channel with the defined channel type, or selects an existing measurement channel with the specified name.

Also see

  • INSTrument:​CREate[:​NEW]
  • "Programming Example: Performing a Sequence of Measurements"
Parameters:
<Mode>
BTDS

TD-SCDMA BTS mode (R&S FSW-K76 option)

MTDS

TD-SCDMA UE mode (R&S FSW-K77 option)


SYSTem:PRESet:CHANnel[:EXECute]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Activating the TD-SCDMA Applications > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Selecting a Measurement

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Selecting a Measurement
Selecting a Measurement

The following commands are required to define the measurement type in a remote environment. For details on available measurements see "Measurements and Result Display".

List of Commands
CONFigure:CDPower:MEASurement


CONFigure:CDPower:MEASurement

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Selecting a Measurement > CONFigure:CDPower:MEASurement
CONFigure:CDPower:MEASurement <Measurement>

This command selects the measurement type for the TD-SCDMA BTS application.

For details on these measurements see "Frequency and Time Domain Measurements".

Parameters:
<Measurement>
ACLR

Adjacent Channel Power

CCDF

Complementary Cumulative Distribution Function

CDPower

Code Domain Power

ESPectrum

Spectrum Emission Mask

OBWidth

Occupied Bandwidth

POWer

Channel Power

PVTime

Power vs Time

*RST: CDPower
Example: CONF:CDP:MEAS POW

Selects Signal Channel Power measurement.

Example:

See "Programming Examples (TD-SCDMA BTS)"

Manual operation: See "Power vs Time"
See "Power"
See "Ch Power ACLR"
See "Spectrum Emission Mask"
See "Occupied Bandwidth"
See "CCDF"
See "Creating a New Channel Table from the Measured Signal (Measure Table)"


Configuring Code Domain Analysis

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis
Configuring Code Domain Analysis

The following commands are required to configure Code Domain Analysis.

Contents
  • Configuring the Data Input and Output
  • Frontend Configuration
  • Configuring Triggered Measurements
  • Signal Capturing
  • Synchronization
  • Channel Detection
  • Sweep Settings
  • Automatic Settings
  • Evaluation Range
  • Code Domain Analysis Settings


Configuring the Data Input and Output

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output
Configuring the Data Input and Output
Contents
  • RF Input
  • Configuring Digital I/Q Input and Output
  • Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
  • Setting up Probes
  • Configuring the Outputs


RF Input

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input
RF Input
List of Commands
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:IMPedance
INPut:SELect


INPut:ATTenuation:PROTection:RESet

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input > INPut:ATTenuation:PROTection:RESet
INPut:ATTenuation:PROTection:RESet

This command resets the attenuator and reconnects the RF input with the input mixer after an overload condition occured and the protection mechanism intervened.The error status bit (bit 3 in the STAT:QUES:POW status register) and the INPUT OVLD message in the status bar are cleared.

The command works only if the overload condition has been eliminated first.

Usage: Event


INPut:CONNector

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input > INPut:CONNector
INPut:CONNector <ConnType>

Determines whether the RF input data is taken from the RF input connector or the optional Analog Baseband I connector. This command is only available if the Analog Baseband interface (R&S FSW-B71) is installed and active for input.

For more information see "Processing Data From the Analog Baseband Interface" .

Parameters:
<ConnType>
RF

RF input connector

AIQI

Analog Baseband I connector

*RST: RF
Example: INP:CONN:AIQI

Selects the analog baseband input.

Usage: SCPI confirmed
Manual operation: See "Input Connector"


INPut:COUPling

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

The command is not available for measurements with the Digital Baseband Interface (R&S FSW-B17).

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:FILTer:HPASs[:STATe]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


INPut:IMPedance

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

The command is not available for measurements with the Digital Baseband Interface (R&S FSW-B17).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"


INPut:SELect

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

DIQ

Digital IQ data (only available with optional Digital Baseband Interface R&S FSW-B17)

For details on I/Q input see "Digital Input" .

AIQ

Analog Baseband signal (only available with optional Analog Baseband Interface R&S FSW-B71)

For details on Analog Baseband input see "Processing Data From the Analog Baseband Interface" .

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Radio Frequency State"
See "Digital I/Q Input State"
See "Analog Baseband Input State"


Configuring Digital I/Q Input and Output

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output
Configuring Digital I/Q Input and Output
Remote commands for the R&S DigIConf software

Remote commands for the R&S DigIConf software always begin with SOURce:EBOX. Such commands are passed on from the R&S FSW to the R&S DigIConf automatically which then configures the R&S EX-IQ-BOX via the USB connection.

Be sure to connect the R&S EX-IQ-BOX to the R&S FSW via USB, not via LAN!

All remote commands available for configuration via the R&S DigIConf software are described in the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Example 1:

SOURce:EBOX:*RST

SOURce:EBOX:*IDN?

Result:

"Rohde&Schwarz,DigIConf,02.05.436 Build 47"

Example 2:

SOURce:EBOX:USER:CLOCk:REFerence:FREQuency 5MHZ

Defines the frequency value of the reference clock.

Remote commands exclusive to digital I/Q data input and output
List of Commands
INPut:DIQ:CDEVice
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
OUTPut:DIQ
OUTPut:DIQ:CDEVice


INPut:DIQ:CDEVice

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:CDEVice
INPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q input from the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<SampleRate>

Maximum or currently used sample rate of the connected device in Hz (depends on the used connection protocol version; indicated by <SampleRateType> parameter)

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<SampleRateType>
0

Maximum sample rate is displayed

1

Current sample rate is displayed

<FullScaleLevel>

The level (in dBm) that should correspond to an I/Q sample with the magnitude "1" (if transferred from connected device);

If not available, 9.97e37 is returned

Example: INP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Connected Instrument"


INPut:DIQ:RANGe[:UPPer]:AUTO

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:AUTO <State>

If enabled, the digital input full scale level is automatically set to the value provided by the connected device (if available).

This command is only available if the optional Digital Baseband interface (option R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe:COUPling

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe:COUPling <State>

If enabled, the reference level for digital input is adjusted to the full scale level automatically if the full scale level changes.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Adjust Reference Level to Full Scale Level"


INPut:DIQ:RANGe[:UPPer]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer] <Level>

Defines or queries the "Full Scale Level", i.e. the level that corresponds to an I/Q sample with the magnitude "1".

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
<numeric value>
Range: | 1 μV to 7.071 V
*RST: | 1 V
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe[:UPPer]:UNIT

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:RANGe[:UPPer]:UNIT <Unit>

Defines the unit of the full scale level (see "Full Scale Level"). The availability of units depends on the measurement application you are using.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
VOLT | DBM | DBPW | WATT | DBMV | DBUV | DBUA | AMPere
*RST: Volt
Manual operation: See "Full Scale Level"


INPut:DIQ:SRATe

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe
INPut:DIQ:SRATe <SampleRate>

This command specifies or queries the sample rate of the input signal from the Digital Baseband Interface (R&S FSW-B17, see "Input Sample Rate").

Parameters:
<SampleRate>
Range: | 1 Hz to 10 GHz
*RST: | 32 MHz
Example:

INP:DIQ:SRAT 200 MHz

Manual operation: See "Input Sample Rate"


INPut:DIQ:SRATe:AUTO

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe:AUTO
INPut:DIQ:SRATe:AUTO <State>

If enabled, the sample rate of the digital I/Q input signal is set automatically by the connected device.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Input Sample Rate"


OUTPut:DIQ

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > OUTPut:DIQ
OUTPut:DIQ <State>

This command turns continuous output of I/Q data to the optional Digital Baseband Interface (R&S FSW-B17) on and off.

Using the digital input and digital output simultaneously is not possible.

If digital baseband output is active, the sample rate is restricted to 100 MHz (200 MHz if enhanced mode is possible; max. 160 MHz bandwidth).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: OUTP:DIQ ON
Example:

See "Converting an RF Signal to a Digital I/Q Signal via the Digital Baseband Interface (-B17)" .

Example:

See "Output via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Digital Baseband Output"


OUTPut:DIQ:CDEVice

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > OUTPut:DIQ:CDEVice
OUTPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q data output to the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<NotUsed>

to be ignored

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<NotUsed>

to be ignored

<Placeholder>

for future use; currently "0"

Example: OUTP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Output via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Output Settings Information"
See "Connected Instrument"


Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

The following commands are required to control the Analog Baseband Interface (R&S FSW-B71) in a remote environment.They are only available if this option is installed.

For more information on the Analog Baseband Interface see "Processing Data From the Analog Baseband Interface" .

Useful commands for Analog Baseband data described elsewhere:
  • INP:SEL AIQ (see INPut:​SELect)
  • [SENSe:​]FREQuency:​CENTer
For calibration:
  • DIAGnostic:​SERVice:​INPut[:​SELect]
  • DIAGnostic:​SERVice:​INPut:​AIQ[:​TYPE]
Remote commands exclusive to Analog Baseband data input and output
List of Commands
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
[SENSe:]PROBe<ch>:SETup:CMOFfset
TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?


INPut:IQ:BALanced[:STATe]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:BALanced[:STATe]
INPut:IQ:BALanced[:STATe] <State>

This command defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Parameters:
<State>
ON

Differential

OFF

Simple-ended

*RST: ON
Example: INP:IQ:BAL OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Input configuration"


INPut:IQ:FULLscale:AUTO

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale:AUTO <State>

This command defines whether the full scale level (i.e. the maximum input power on the Baseband Input connector) is defined automatically according to the reference level, or manually.

Parameters:
<State>
ON

Automatic definition

OFF

Manual definition according to INPut:​IQ:​FULLscale[:​LEVel]

*RST: ON
Example: INP:IQ:FULL:AUTO OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Full Scale Level Mode / Value"


INPut:IQ:FULLscale[:LEVel]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale[:LEVel]
INPut:IQ:FULLscale[:LEVel] <PeakVoltage>

This command defines the peak voltage at the Baseband Input connector if the full scale level is set to manual mode (see INPut:​IQ:​FULLscale:​AUTO).

Parameters:
<PeakVoltage>
0.25 V | 0.5 V | 1 V | 2 V

Peak voltage level at the connector.

For probes, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

*RST: 1V
Example: INP:IQ:FULL 0.5V
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Full Scale Level Mode / Value"


INPut:IQ:TYPE

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:TYPE
INPut:IQ:TYPE <DataType>

This command defines the format of the input signal.

Parameters:
<DataType>
IQ | I | Q
IQ

The input signal is filtered and resampled to the sample rate of the application.

Two input channels are required for each input signal, one for the in-phase component, and one for the quadrature component.

I

The in-phase component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0 (see [SENSe:​]FREQuency:​CENTer), the in-phase component of the input signal is down-converted first (Low IF I).

Q

The quadrature component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0, the quadrature component of the input signal is down-converted first (Low IF Q).

*RST: IQ
Example:

INP:IQ:TYPE Q

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "I/Q Mode"


CALibration:AIQ:DCOFfset:I

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:I <Offset>

This command defines a DC offset of the I input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:I 0.001


CALibration:AIQ:DCOFfset:Q

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:Q
CALibration:AIQ:DCOFfset:Q <Offset>

This command defines a DC offset of the Q input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:Q 0.001


[SENSe:]PROBe<ch>:SETup:CMOFfset

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > [SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<ch>:SETup:CMOFfset <CMOffset>

Sets the common mode offset. The setting is only available if a differential probe is connected to the R&S FSW.

If the probe is disconnected, the common mode offset of the probe is reset to 0.0 V.

For details see "Common Mode Offset" .

Suffix:
<ch>
1..4

Selects the input channel.

Parameters:
<CMOffset>
Range: | -100E+24 to 100E+24
Increment: | 1E-3
*RST: | 0
Default unit: | V


TRACe:IQ:APCon[:STATe]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon[:STATe] <State>

If enabled, the average power consumption is calculated at the end of the I/Q data measurement. This command must be set before the measurement is performed!

The conversion factors A and B for the calculation are defined using TRACe:​IQ:​APCon:​A and TRACe:​IQ:​APCon:​B.

The results can be queried using TRACe:​IQ:​APCon:​RESult?.

For details see "Average Power Consumption" .

Parameters:
<State>
ON | OFF
*RST: OFF
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:A

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:A
TRACe:IQ:APCon:A <ConvFact>

Defines the conversion factor A for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 1.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:B

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:B
TRACe:IQ:APCon:B <ConvFact>

Defines the conversion factor B for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 0.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:RESult?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon:RESult?

Queries the average power consumption for an analog baseband input. This value is only calculated at the end of the I/Q data measurement if the TRACe:​IQ:​APCon[:​STATe] command is set to ON before the measurement is performed!

For details see "Average Power Consumption" .

Parameters:
<Average>
numeric value
Default unit: W
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?
Usage: Query only


Setting up Probes

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Setting up Probes
Setting up Probes

Probes can be connected to the optional BASEBAND INPUT connectors, if the Analog Baseband interface ( option R&S FSW-B71) is installed.

List of Commands
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?


[SENSe:]PROBe<p>:ID:PARTnumber?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:PARTnumber?

Queries the R&S part number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<PartNumber> | Part number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:ID:SRNumber?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:ID:SRNumber?

Queries the serial number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<SerialNo> | Serial number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:SETup:MODE

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:MODE <Mode>

Select the action that is started with the micro button on the probe head.

See also: "Microbutton Action".

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Parameters:
<Mode>
RSINgle

Run single: starts one data acquisition.

NOACtion

Nothing is started on pressing the micro button.

*RST: RSINgle
Manual operation: See "Microbutton Action"


[SENSe:]PROBe<p>:SETup:NAME?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:NAME?

Queries the name of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Name> | Name string
Usage: | Query only


[SENSe:]PROBe<p>:SETup:STATe?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:STATe?

Queries if the probe at the specified connector is active (detected) or not active (not detected). To switch the probe on, i.e. activate input from the connector, use INP:SEL:AIQ (see INPut:​SELect).

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Return values:
<State>
DETected | NDETected
*RST: NDETected
Usage: Query only


[SENSe:]PROBe<p>:SETup:TYPE?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]PROBe<p>:SETup:TYPE?

Queries the type of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Type> | String containing one of the following values: – None (no probe detected) – active differential – active single-ended
Usage: | Query only


Configuring the Outputs

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring the Outputs
Configuring the Outputs

Configuring trigger input/output is described in "Configuring the Trigger Output".

List of Commands
DIAGnostic:SERVice:NSOurce
OUTPut:IF:IFFRequency


DIAGnostic:SERVice:NSOurce

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring the Outputs > DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:NSOurce <State>

This command turns the 28 V supply of the BNC connector labeled NOISE SOURCE CONTROL on the front panel on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DIAG:SERV:NSO ON
Manual operation: See "Noise Source"


OUTPut:IF:IFFRequency

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring the Outputs > OUTPut:IF:IFFRequency
OUTPut:IF:IFFRequency <Frequency>

This command defines the frequency for the IF output. The IF frequency of the signal is converted accordingly.

This command is available in the time domain and if the IF/VIDEO/DEMOD output is configured for IF.

Parameters:
<Frequency>
*RST: 50.0 MHz


Frontend Configuration

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration
Frontend Configuration

The following commands configure frequency, amplitude and y-axis scaling settings, which represent the "frontend" of the measurement setup.

Contents
  • Frequency
  • Amplitude and Scaling Settings
  • Configuring the Attenuation


Frequency

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Frequency
Frequency
List of Commands
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet


[SENSe:]FREQuency:CENTer

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the center frequency.

Parameters:
<Frequency>

The allowed range and fmax is specified in the data sheet.

UP

Increases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

DOWN

Decreases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Center Frequency"
See "Center frequency"


[SENSe:]FREQuency:CENTer:STEP

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:AUTO

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:AUTO <State>

This command couples or decouples the center frequency step size to the span.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: FREQ:CENT:STEP:AUTO ON

Activates the coupling of the step size to the span.


[SENSe:]FREQuency:OFFSet

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Frequency > [SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:OFFSet <Offset>

This command defines a frequency offset.

If this value is not 0 Hz, the application assumes that the input signal was frequency shifted outside the application. All results of type "frequency" will be corrected for this shift numerically by the application.

Note: In MSRA mode, the setting command is only available for the MSRA Master. For MSRA applications, only the query command is available.

Parameters:
<Offset>
Range: | -100 GHz to 100 GHz
*RST: | 0 Hz
Example: FREQ:OFFS 1GHZ
Usage: SCPI confirmed
Manual operation: See "Frequency Offset"


Amplitude and Scaling Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings
Amplitude and Scaling Settings

The following commands are required to configure the amplitude and scaling settings in a remote environment.

Useful commands for amplitude settings described elsewhere:
  • INPut:​COUPling
  • INPut:​IMPedance
  • [SENSe:​]ADJust:​LEVel
Remote commands exclusive to amplitude settings:
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
INPut:GAIN:STATe
INPut:GAIN[:VALue]


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

Automatic scaling of the y-axis is performed once, then switched off again.

Usage: | SCPI confirmed
Manual operation: | See "Auto Scale Once"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum <Value>

This command defines the maximum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Y-Maximum, Y-Minimum"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum <Value>

This command defines the minimum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Y-Maximum, Y-Minimum"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision <Value>

This remote command determines the grid spacing on the Y-axis for all diagrams, where possible.

Parameters:
<Value>
numeric value WITHOUT UNIT (unit according to the result display)

Defines the range per division (total range = 10*<Value>)

*RST: depends on the result display
Example: DISP:TRAC:Y:PDIV 10

Sets the grid spacing to 10 units (e.g. dB) per division


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Shifting the Display (Offset)"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition <Position>

This command defines the vertical position of the reference level on the display grid.

The R&S FSW adjusts the scaling of the y-axis accordingly.

Parameters:
<Position>

0 PCT corresponds to the lower display border, 100% corresponds to the upper display border.

*RST: 100 PCT = frequency display; 50 PCT = time display
Example:

DISP:TRAC:Y:RPOS 50PCT

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue <Value>

The command defines the power value assigned to the reference position in the grid.

For external generator calibration measurements (requires External Generator Control option R&S FSW-B10), this command defines the power offset value assigned to the reference position.

Parameters:
<Value>
*RST: 0 dBm, coupled to reference level
Example: DISP:TRAC:Y:RVAL -20dBm

Sets the power value assigned to the reference position to -20 dBm


INPut:GAIN:STATe

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN[:VALue]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


Configuring the Attenuation

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Configuring the Attenuation
Configuring the Attenuation
List of Commands
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe


INPut:ATTenuation

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Configuring the Attenuation > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If an electronic attenuator is available and active, the command defines a mechanical attenuation (see INPut:​EATT:​STATe).

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:ATTenuation:AUTO

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Configuring the Attenuation > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:EATT

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Configuring the Attenuation > INPut:EATT
INPut:EATT <Attenuation>

This command defines an electronic attenuation manually. Automatic mode must be switched off (INP:EATT:AUTO OFF, see INPut:​EATT:​AUTO).

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<Attenuation>
attenuation in dB
Range: | see data sheet
Increment: | 1 dB
*RST: | 0 dB (OFF)
Example: INP:EATT:AUTO OFF
INP:EATT 10 dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:AUTO

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Configuring the Attenuation > INPut:EATT:AUTO
INPut:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:EATT:AUTO OFF
Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:STATe

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Frontend Configuration > Configuring the Attenuation > INPut:EATT:STATe
INPut:EATT:STATe <State>

This command turns the electronic attenuator on and off.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Switches the electronic attenuator into the signal path.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


Configuring Triggered Measurements

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements
Configuring Triggered Measurements

The following commands are required to configure a triggered measurement in a remote environment. The tasks for manual operation are described in "Trigger Settings".

The *OPC command should be used after commands that retrieve data so that subsequent commands to change the selected trigger source are held off until after the sweep is completed and the data has been returned.

Contents
  • Configuring the Triggering Conditions
  • Configuring the Trigger Output


Configuring the Triggering Conditions

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions
Configuring the Triggering Conditions
List of Commands
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce


TRIGger[:SEQuence]:BBPower:HOLDoff

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:BBPower:HOLDoff <Period>

This command defines the holding time before the baseband power trigger event.

The command requires the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

Note that this command is maintained for compatibility reasons only. Use the TRIGger[:​SEQuence]:​IFPower:​HOLDoff command for new remote control programs.

Parameters:
<Period>
Range: | 150 ns to 1000 s
*RST: | 150 ns
Example: TRIG:SOUR BBP

Sets the baseband power trigger source.

TRIG:BBP:HOLD 200 ns

Sets the holding time to 200 ns.


TRIGger[:SEQuence]:HOLDoff[:TIME]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:HOLDoff[:TIME] <Offset>

Defines the time offset between the trigger event and the start of the sweep (data capturing).

Parameters:
<Offset>
*RST: 0 s
Example: TRIG:HOLD 500us
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Offset"


TRIGger[:SEQuence]:IFPower:HOLDoff

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HOLDoff <Period>

This command defines the holding time before the next trigger event.

Note that this command can be used for any trigger source, not just IF Power (despite the legacy keyword).

Note: If you perform gated measurements in combination with the IF Power trigger, the R&S FSW ignores the holding time for frequency sweep, FFT sweep, zero span and I/Q data measurements.

Parameters:
<Period>
Range: | 0 s to 10 s
*RST: | 0 s
Example: TRIG:SOUR EXT

Sets an external trigger source.

TRIG:IFP:HOLD 200 ns

Sets the holding time to 200 ns.

Manual operation: See "Trigger Holdoff"


TRIGger[:SEQuence]:IFPower:HYSTeresis

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:IFPower:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis, which is only available for "IF Power" trigger sources.

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
*RST: | 3 dB
Example: TRIG:SOUR IFP

Sets the IF power trigger source.

TRIG:IFP:HYST 10DB

Sets the hysteresis limit value.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Hysteresis"


TRIGger[:SEQuence]:LEVel:BBPower

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:BBPower <Level>

This command sets the level of the baseband power trigger.

This command is available for the Digital Baseband Interface (R&S FSW-B17) and the Analog Baseband Interface (R&S FSW-B71).

Parameters:
<Level>
Range: | -50 dBm to +20 dBm
*RST: | -20 dBm
Example: TRIG:LEV:BB -30DBM
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


TRIGger[:SEQuence]:LEVel[:EXTernal<port>]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>] <TriggerLevel>

This command defines the level the external signal must exceed to cause a trigger event.

Suffix:
<port>

Selects the trigger port.

1 = trigger port 1 (TRIGGER INPUT connector on front panel)

2 = trigger port 2 (TRIGGER INPUT/OUTPUT connector on front panel)

3 = trigger port 3 (TRIGGER3 INPUT/OUTPUT connector on rear panel)

Parameters:
<TriggerLevel>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Example: TRIG:LEV 2V
Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:SLOPe

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Slope"


TRIGger[:SEQuence]:SOURce

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

RFPower

First intermediate frequency

(Frequency and time domain measurements only.)

Not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

IFPower

Second intermediate frequency

(For frequency and time domain measurements only.)

Not available for input from the Digital Baseband Interface (R&S FSW-B17). For input from the Analog Baseband Interface (R&S FSW-B71), this parameter is interpreted as BBPower for compatibility reasons.

BBPower

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17)

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)

(UE mode (K77) only)

PSEN

External power sensor

(For frequency and time domain measurements only.)

GP0 | GP1 | GP2 | GP3 | GP4 | GP5

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available.

Defines triggering of the measurement directly via the LVDS connector. The parameter specifies which general purpose bit (0 to 5) will provide the trigger data.

The assignment of the general purpose bits used by the Digital IQ trigger to the LVDS connector pins is provided in "Digital I/Q".

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Example:

See "Programming Example" .

Manual operation: See "Trigger Source"
See "Free Run"
See "External Trigger 1/2/3"
See "Baseband Power"
See "Digital I/Q"
See "IF Power"


Configuring the Trigger Output

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Trigger Output
Configuring the Trigger Output

The following commands are required to send the trigger signal to one of the variable TRIGGER INPUT/OUTPUT connectors. The tasks for manual operation are described in "Trigger 2/3".

List of Commands
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth


OUTPut:TRIGger<port>:DIRection

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:DIRection <Direction>

This command selects the trigger direction.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Direction>
INPut

Port works as an input.

OUTPut

Port works as an output.

*RST: INPut
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"


OUTPut:TRIGger<port>:LEVel

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:LEVel <Level>

This command defines the level of the signal generated at the trigger output.

This command works only if you have selected a user defined output with OUTPut:​TRIGger<port>:​OTYPe.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Level>
HIGH

TTL signal.

LOW

0 V

*RST: LOW
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"
See "Level"


OUTPut:TRIGger<port>:OTYPe

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:OTYPe <OutputType>

This command selects the type of signal generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<OutputType>
DEVice

Sends a trigger signal when the R&S FSW has triggered internally.

TARMed

Sends a trigger signal when the trigger is armed and ready for an external trigger event.

UDEFined

Sends a user defined trigger signal. For more information see OUTPut:​TRIGger<port>:​LEVel.

*RST: DEVice
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Output Type"


OUTPut:TRIGger<port>:PULSe:IMMediate

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:IMMediate

This command generates a pulse at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: Event
Manual operation: See "Send Trigger"


OUTPut:TRIGger<port>:PULSe:LENGth

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:LENGth
OUTPut:TRIGger<port>:PULSe:LENGth <Length>

This command defines the length of the pulse generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Length>

Pulse length in seconds.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Pulse Length"


Signal Capturing

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Signal Capturing
Signal Capturing

The following commands are required to configure how much and how data is captured from the input signal.

MSRA operating mode

In MSRA operating mode, only the MSRA Master channel actually captures data from the input signal. The data acquisition settings for the TD-SCDMA application in MSRA mode define the application data (see also "Configuring the Application Data Range (MSRA mode only)").

For details on the MSRA operating mode see "Applications and Operating Modes" .

Useful commands when defining signal capturing described elsewhere:
  • [SENSe:​]CDPower:​SET
Remote commands exclusive to defining signal capturing:
List of Commands
[SENSe:]CDPower:FILTer[:STATe]
[SENSe:]CDPower:IQLength
[SENSe:]CDPower:QINVert
[SENSe:]CDPower:SET:COUNt


[SENSe:]CDPower:FILTer[:STATe]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Signal Capturing > [SENSe:]CDPower:FILTer[:STATe]
[SENSe:]CDPower:FILTer[:STATe] <State>

This command selects if a root raised cosine (RRC) receiver filter is used or not. This feature is useful if the RRC filter is implemented in the device under test (DUT).

Parameters:
<State>
ON | 1

If an unfiltered signal is received (normal case), the RRC filter should be used to get a correct signal demodulation.

OFF | 0

If a filtered signal is received, the RRC filter should not be used to get a correct signal demodulation. This is the case if the DUT filters the signal.

*RST: 1
Example:

SENS:CDP:FILT:STAT OFF

Manual operation: See "RRC Filter State"


[SENSe:]CDPower:IQLength

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Signal Capturing > [SENSe:]CDPower:IQLength
[SENSe:]CDPower:IQLength <CaptureLength>

This command specifies the number of slots that are captured by one measurement. If more than one set is to be captured (see [SENSe:​]CDPower:​SET:​COUNt), the number of slots is automatically set to the maximum of 64.

Parameters:
<CaptureLength>
Range: | 2 to 64
*RST: | 7
Example:

SENS:CDP:IQLength 3

Example:

See "Measurement 5: Measuring the Composite EVM".

Manual operation: See "Number of Slots to Capture"


[SENSe:]CDPower:QINVert

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Signal Capturing > [SENSe:]CDPower:QINVert
[SENSe:]CDPower:QINVert <State>

This command inverts the Q-branch of the signal.

Parameters:
ON | OFF
*RST: OFF
Example: CDP:QINV ON

Activates inversion of Q-branch

Example:

See "Measurement 5: Measuring the Composite EVM".

Manual operation: See "Invert Q"


[SENSe:]CDPower:SET:COUNt

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Signal Capturing > [SENSe:]CDPower:SET:COUNt
[SENSe:]CDPower:SET:COUNt <NoOfSets>

This command sets the number of sets to be captured and stored in the instrument's memory.

Refer to "Set Count" for more information.

Parameters:
<NoOfSets>
Range: | 1 to TDS: 99; CDMA: 490
Increment: | 1
*RST: | 1
Example: CDP:SET:COUN 12

Sets the number of sets to 12.

Example:

See "Measurement 5: Measuring the Composite EVM"

Mode: TDS
Manual operation: See "Set Count"


Synchronization

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Synchronization
Synchronization

The individual channels in the input signal need to be synchronized to detect timing offsets in the slot spacings. These commands are described here.

Remote commands exclusive to synchronization:
List of Commands
[SENSe:]CDPower:MSHift
[SENSe:]CDPower:SCODe
[SENSe:]CDPower:STSLot
[SENSe:]CDPower:STSLot:MODE
[SENSe:]CDPower:STSLot:ROTate
[SENSe:]CDPower:SULC
[SENSe:]CDPower:TREF


[SENSe:]CDPower:MSHift

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Synchronization > [SENSe:]CDPower:MSHift
[SENSe:]CDPower:MSHift <MaxMAShift>

This command sets the maximum number of usable midamble shifts (= number of users) on the base station.

If you use a predefined channel table, this value is replaced by that of the channel table (see CONFigure:​CDPower:​CTABle:​MSHift).

Parameters:
<MaxMAShift>
Range: | 2 to 16
Increment: | 2
*RST: | 16
Example: CDP:MSH 10

Sets the maximum number of midamble shifts to 10.

Example:

See "Measurement 5: Measuring the Composite EVM".

Manual operation: See "MA Shift Cell / Number of Users"


[SENSe:]CDPower:SCODe

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Synchronization > [SENSe:]CDPower:SCODe
[SENSe:]CDPower:SCODe <numeric value>

This command sets the scrambling code of the base station.

Parameters:
<numeric value>
Range: | 0 to 127
Increment: | 1
*RST: | 0
Example: CDP:SCOD 28

Sets scrambling code 28.

Example:

See "Measurement 5: Measuring the Composite EVM".

Manual operation: See "Scrambling Code"


[SENSe:]CDPower:STSLot

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Synchronization > [SENSe:]CDPower:STSLot
[SENSe:]CDPower:STSLot <State>

This command selects the phase reference for synchronization (see "Sync To").

Parameters:
<State>
ON | OFF
ON

The instrument synchronizes to the midamble of the selected slot.

OFF

BTS application:

The instrument synchronizes to the P-CCPCH in slot 0.

UE application:

The instrument synchronizes to the channel of the selected slot.

*RST: OFF
Example: CDP:SLOT 7

Selects slot number 7.

CDP:STSL ON

Activates synchronizing to the midamble of slot 7.

Example:

See "Measurement 5: Measuring the Composite EVM".

Manual operation: See "Sync To"


[SENSe:]CDPower:STSLot:MODE

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Synchronization > [SENSe:]CDPower:STSLot:MODE
[SENSe:]CDPower:STSLot:MODE <Mode>

This command selects the phase reference for synchronization (see "Sync To").

Parameters:
<Mode>
CODE | MA
CODE

BTS application:

The instrument synchronizes to the P-CCPCH in slot 0.

UE application:

The instrument synchronizes to the channel of the selected slot.

MA

The instrument synchronizes to the midamble of the selected slot.

*RST: MA
Example: CDP:STSL:MODE CODE

Activates channel synchronizing

Mode: UE only
Manual operation: See "Sync To"


[SENSe:]CDPower:STSLot:ROTate

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Synchronization > [SENSe:]CDPower:STSLot:ROTate
[SENSe:]CDPower:STSLot:ROTate <Mode>

By default, the TD-SCDMA application determines one phase reference for all midambles and channels of a data slot. If this function is enabled, phase rotations between the channels are allowed. Each channel gets its own phase reference from the associated midamble according to section AA.2 of the standard document 3GPP TS 25.221. If the associated midamble is missing, the common phase reference is used for this channel.

Parameters:
<Mode>
ON | OFF
*RST: OFF
Example: CDP:STSL:ROT ON

Allows phase rotations between channels.

Example:

See "Measurement 5: Measuring the Composite EVM".

Manual operation: See "Rotate code channel to associated midamble"


[SENSe:]CDPower:SULC

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Synchronization > [SENSe:]CDPower:SULC
[SENSe:]CDPower:SULC <SyncUL>

Defines the code used for synchronization on the UpPTS (see "Time Reference (UE mode)").

This command is available for UE mode (K77) only.

Parameters:
<SyncUL>
integer

For details on available values depending on the scrambling code see table "Possible SYNC-UL codes depending on scrambling code".

Range: | 0 to 255
*RST: | 0
Example: CDP:SULC 28

Sets the code 28.

Manual operation: See "SYNC-UL Code (UE only)"


[SENSe:]CDPower:TREF

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Synchronization > [SENSe:]CDPower:TREF
[SENSe:]CDPower:TREF <numeric value>

Defines which slot is used as a time reference for synchronization.

Parameters:
<numeric value>
DPTS

Uses the Downlink Pilot Time Slot (DwPTS) as a time reference

UPTS

Uses the Uplink Pilot Time Slot (UpPTS) as a time reference

SLOT

Uses slot 0 (BTS mode) or slot 1 (UE mode) as a time reference

*RST: SLOT
Example: CDP:TREF DPTS
Manual operation: See "Time Reference (BTS mode)"
See "Time Reference (UE mode)"


Channel Detection

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection
Channel Detection

The channel detection settings determine which channels are found in the input signal. The commands required to work with channel tables are described here.

Contents
  • General Channel Detection
  • Managing Channel Tables
  • Configuring Channel Tables


General Channel Detection

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection > General Channel Detection
General Channel Detection

The following commands configure how channels are detected in general.

Useful commands for general channel detection described elsewhere:
  • CONFigure:​CDPower:​CTABle[:​STATe]
Remote commands exclusive to general channel detection:
List of Commands
[SENSe:]CDPower:ICTReshold
[SENSe:]CDPower:MMAX


[SENSe:]CDPower:ICTReshold

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection > General Channel Detection > [SENSe:]CDPower:ICTReshold
[SENSe:]CDPower:ICTReshold <ThresholdLevel>

This command defines the minimum power that a single channel must have compared to the total signal in order to be regarded as an active channel. Channels below the specified threshold are regarded as "inactive".

Parameters:
<ThresholdLevel>
Range: | -100 dB to 0 dB
*RST: | -40 dB
Example:

SENS:CDP:ICTR -100

Example:

See "Measurement 5: Measuring the Composite EVM".

Manual operation: See "Inactive Channel Threshold"


[SENSe:]CDPower:MMAX

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection > General Channel Detection > [SENSe:]CDPower:MMAX
[SENSe:]CDPower:MMAX <ModType>

This command defines the highest modulation to be considered in the automatic channel search. In low SNR environments it may be necessary to limit the channel search to lower modulations than 64QAM.

Parameters:
<ModType>
QPSK

Consider QPSK modulation only

PSK8

Consider QPSK and 8PSK modulation.

QAM16

Consider QPSK, 8PSK and 16QAM modulation

QAM64

Consider QPSK, 8PSK, 16QAM and 64QAM modulation

*RST: QAM64
Example: SENS:CDP:MMAX PSK8

Assume QPSK and 8PSK modulations only for the automatic channel search

Example:

See "Measurement 5: Measuring the Composite EVM".

Manual operation: See "Max Modulation"


Managing Channel Tables

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection > Managing Channel Tables
Managing Channel Tables
List of Commands
CONFigure:CDPower:CTABle:CATalog?
CONFigure:CDPower:CTABle:COPY
CONFigure:CDPower:CTABle:DELete
CONFigure:CDPower:CTABle:SELect
CONFigure:CDPower:CTABle[:STATe]


CONFigure:CDPower:CTABle:CATalog?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection > Managing Channel Tables > CONFigure:CDPower:CTABle:CATalog?
CONFigure:CDPower:CTABle:CATalog?

This command queries the names of all the channel tables stored on the instrument for the current application.

The first two result values are global values for all channel tables, the subsequent values are listed for each individual table.

The syntax for the return values is: <TotalSize>, <FreeMem>, <FileName>, <FileSize>, <FileName>, <FileSize>,...,<FileName>, <FileSize>

Parameters:
<TotalSize> | Sum of file sizes of all channel table files (in bytes)
<FreeMem> | Available memory left on hard disk (in bytes)
<FileName> | File name of individual channel table file
<FileSize> | File size of individual channel table file (in bytes)
Example: | CONF:CDP:CTAB:CAT? Returns all existing channel tables.
Usage: | Query only
Manual operation: | See "Predefined Tables"


CONFigure:CDPower:CTABle:COPY

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection > Managing Channel Tables > CONFigure:CDPower:CTABle:COPY
CONFigure:CDPower:CTABle:COPY <TargetFileName>

This command copies one channel table to another. Select the channel table you want to copy using the CONFigure:​CDPower:​CTABle:​NAME command. The name of the channel table may contain up to eight characters.

Parameters:
<TargetFileName> | <string> = name of the new channel table
Example: | CONF:CDP:CTAB:NAME 'CTAB_1' Selects channel table 'CTAB_1'. CONF:CDP:CTAB:COPY 'CTAB_2' Makes a copy of 'CTAB_1' with the name 'CTAB_2'.
Manual operation: | See "Copying a Table"


CONFigure:CDPower:CTABle:DELete

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection > Managing Channel Tables > CONFigure:CDPower:CTABle:DELete
CONFigure:CDPower:CTABle:DELete

This command deletes the selected channel table. Select the channel table you want to delete using the CONFigure:​CDPower:​CTABle:​NAME command.

Example: | CONF:CDP:CTAB:NAME 'CTAB_1' Selects channel table 'CTAB_1' CONF:CDP:CTAB:DEL Deletes channel table 'CTAB_1'.
Usage: | Event
Manual operation: | See "Deleting a Table"


CONFigure:CDPower:CTABle:SELect

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection > Managing Channel Tables > CONFigure:CDPower:CTABle:SELect
CONFigure:CDPower:CTABle:SELect <FileName>

This command selects a predefined channel table file for comparison during channel detection. Before using this command, the "RECENT" channel table must be switched on first with the command CONFigure:​CDPower:​CTABle[:​STATe].

Parameters:
<FileName>
*RST: RECENT
Example: CONF:WCDP:CTAB ON

Switches the channel table on.

CONF:CDP:CTAB:SEL 'CTAB_1'

Selects the predefined channel table 'CTAB_1'.

Manual operation: See "Selecting a Table"


CONFigure:CDPower:CTABle[:STATe]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection > Managing Channel Tables > CONFigure:CDPower:CTABle[:STATe]
CONFigure:CDPower:CTABle[:STATe] <State>

This command switches the use of a predefined channel table on or off. When switched on, the measured channel table is stored under the name "RECENT" and is selected for use. After the "RECENT" channel table is switched on, another channel table can be selected with the command CONFigure:​CDPower:​CTABle:​SELect.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

CONF:CDP:CTAB ON

Example:

See "Measurement 5: Measuring the Composite EVM".

Manual operation: See "Using Predefined Channel Tables"


Configuring Channel Tables

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection > Configuring Channel Tables
Configuring Channel Tables

Some general settings and functions are available when configuring a predefined channel table.

Remote commands exclusive to configuring channel tables:
List of Commands
CONFigure:CDPower:CTABle:COMMent
CONFigure:CDPower:CTABle:NAME
CONFigure:CDPower:CTABle:DATA
CONFigure:CDPower:CTABle:MSHift


CONFigure:CDPower:CTABle:COMMent

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection > Configuring Channel Tables > CONFigure:CDPower:CTABle:COMMent
CONFigure:CDPower:CTABle:COMMent <Comment>

This command defines a comment for the channel table selected with CONFigure:​CDPower:​CTABle:​NAME.

Parameters:
<Comment> | comment for the channel table
Example: | CONF:CDP:CTAB:NAME 'CTAB_1' Selects channel table 'CTAB_1'. CONF:CDP:CTAB:COMM 'Comment for CTAB_1' Writes a comment for 'CTAB_1'.
Manual operation: | See "Comment"


CONFigure:CDPower:CTABle:NAME

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection > Configuring Channel Tables > CONFigure:CDPower:CTABle:NAME
CONFigure:CDPower:CTABle:NAME <ChannelTable>

This command selects an existing channel table or creates a new one. Use this command to edit the channel table. To use a channel table for a measurement, use the CONFigure:​CDPower:​CTABle:​SELect command.

Parameters:
<ChannelTable>

<string> = name of the channel table

*RST: RECENT
Example: CONF:CDP:CTAB:NAME 'NEW_TAB'

Selects channel table for editing. If a channel table with this name does not exist, a new channel table by that name is created.

Manual operation: See "Name"


CONFigure:CDPower:CTABle:DATA

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection > Configuring Channel Tables > CONFigure:CDPower:CTABle:DATA
CONFigure:CDPower:CTABle:DATA <ChannelType>, <CodeClass>, <CodeNumber>, <ModType>, <MAShift>, <ActiveFlag>,<Reserved>, <Reserved>

This command defines or queries the parameters of the channel table selected or created with the CONFigure:​CDPower:​CTABle:​NAME command.

To define a channel (one row in the channel table), you have to enter eight values in the following order:

<ChannelType>, <CodeClass>, <CodeNumber>, <ModType>, <MAShift>, <ActiveFlag>,<Reserved>, <Reserved>

Return values:
<ChannelType> | 0 ... 7 Type of the channel 0= inactive 1= midamble 2= DPCH 3= P-CCPCH 4= S-CCPCH 5= FPACH 6= PDSCH 7= PICH Note that values 2 to 7 are not distinguished by the application; all these values are mapped to the value 2 (DPCH).
<CodeClass> | 0 … 4 Code class of the channel. The code class specifies the spreading factor of the channel. 0= spreading factor 1 1= spreading factor 2 2= spreading factor 4 3= spreading factor 8 4= spreading factor 16
<CodeNo> | 1 … 16 Code number of the channel. The number of codes depends on the spreading factor (see table "Relationship between code class, channels and spreading factor").
<ModType> | Modulation type of the channel 0= invalid (for midamble) 1= QPSK 2= 8PSK 3= 16QAM 4= 64QAM
<MAShift> | 0 … 38400 Midamble shift of the channel
<ActiveFlag> | 0 | 1 Flag to indicate whether a channel is active (1) or not (0)
<Reserved1>, <Reserved2> | Placeholder values; Currently not used.
Example: | CONF:CDP:CTAB:NAME 'CTAB_1' Selects or creates channel table 'CTAB_1' CONF:CDP:CTAB:DATA '2,4,1,1,1,1,0,0,2,4,2,1,1,1,0,0' Defines two data channels with QPSK modulation.
Manual operation: | See "Channel Type" See "Channel Number (Ch. SF)" See "State"


CONFigure:CDPower:CTABle:MSHift

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Channel Detection > Configuring Channel Tables > CONFigure:CDPower:CTABle:MSHift
CONFigure:CDPower:CTABle:MSHift <MAShift>

This command defines the number of midamble shifts in the channel table.

This value replaces the value defined by [SENSe:​]CDPower:​MSHift.

Parameters:
<numeric value>
2 | 4 | 6 | 8 | 10 | 12 | 14 | 16
*RST: 16
Example: CONF:CDP:CTAB:MSH 4

Sets the number of midamble shifts to 4.

Manual operation: See "MA Shifts Cell"
See "Midamble Shift"


Sweep Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Sweep Settings
Sweep Settings
List of Commands
[SENSe:]AVERage:COUNt
[SENSe:]SWEep:COUNt


[SENSe:]AVERage:COUNt

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Sweep Settings > [SENSe:]AVERage:COUNt
[SENSe:]AVERage:COUNt <AverageCount>
[SENSe:]SWEep:COUNt <SweepCount>

This command defines the number of sweeps that the application uses to average traces.

(For Pulse measurements, see also "Trace Statistics" ).

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweeps, the application stops the measurement and calculates the average after the average count has been reached.

Example: SWE:COUN 64

Sets the number of sweeps to 64.

INIT:CONT OFF

Switches to single sweep mode.

INIT;*WAI

Starts a sweep and waits for its end.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep/Average Count"


Automatic Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Automatic Settings
Automatic Settings
MSRA operating mode

In MSRA operating mode, the following commands are not available, as they require a new data acquisition. However, TD-SCDMA applications cannot perform data acquisition in MSRA operating mode.

Useful commands for adjusting settings automatically described elsewhere:
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO ONCE
Remote commands exclusive to adjusting settings automatically:
List of Commands
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:LEVel


[SENSe:]ADJust:ALL

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Automatic Settings > [SENSe:]ADJust:ALL
[SENSe:]ADJust:ALL

This command initiates a measurement to determine and set the ideal settings for the current task automatically (only once for the current measurement).

This includes:

  • Reference level
Example: | ADJ:ALL
Usage: | Event
Manual operation: | See "Adjusting all Determinable Settings Automatically (Auto All)"


[SENSe:]ADJust:CONFigure:DURation

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Automatic Settings > [SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation <Duration>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command defines the length of the measurement if [SENSe:​]ADJust:​CONFigure:​DURation:​MODE is set to MANual.

Parameters:
<Duration>
Numeric value in seconds
Range: | 0.001 to 16000.0
*RST: | 0.001
Default unit: | s
Example: ADJ:CONF:DUR:MODE MAN

Selects manual definition of the measurement length.

ADJ:CONF:LEV:DUR 5ms

Length of the measurement is 5 ms.

Manual operation: See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:DURation:MODE

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Automatic Settings > [SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:DURation:MODE <Mode>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command selects the way the R&S FSW determines the length of the measurement .

Parameters:
<Mode>
AUTO

The R&S FSW determines the measurement length automatically according to the current input data.

MANual

The R&S FSW uses the measurement length defined by [SENSe:​]ADJust:​CONFigure:​DURation.

*RST: AUTO
Manual operation: See "Resetting the Automatic Measurement Time (Meastime Auto)"
See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Automatic Settings > [SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:LOW 2

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level falls below 18 dBm.

Manual operation: See "Lower Level Hysteresis"


[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Automatic Settings > [SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:UPP 2
Example:

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level rises above 22 dBm.

Manual operation: See "Upper Level Hysteresis"


[SENSe:]ADJust:LEVel

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Automatic Settings > [SENSe:]ADJust:LEVel
[SENSe:]ADJust:LEVel

This command initiates a single (internal) measurement that evaluates and sets the ideal reference level for the current input data and measurement settings. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Example: | ADJ:LEV
Usage: | Event
Manual operation: | See "Setting the Reference Level Automatically (Auto Level)"


Evaluation Range

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Evaluation Range
Evaluation Range

The evaluation range defines which data is evaluated in the result display.

List of Commands
[SENSe:]CDPower:CODE
[SENSe:]CDPower:SET
[SENSe:]CDPower:SLOT


[SENSe:]CDPower:CODE

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Evaluation Range > [SENSe:]CDPower:CODE
[SENSe:]CDPower:CODE <CodeNumber>

This command sets the code number. The code number refers to spreading factor 16.

Parameters:
<CodeNumber>
<numeric value>
*RST: 0
Example:

SENS:CDP:CODE 3

Example:

See "Measurement 5: Measuring the Composite EVM".

Manual operation: See "Channel (Code) Number"


[SENSe:]CDPower:SET

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Evaluation Range > [SENSe:]CDPower:SET
[SENSe:]CDPower:SET <SetNo>

This command selects a specific set for further analysis. The number of sets to capture has to be defined with the [SENSe:​]CDPower:​SET command before using this command.

Parameters:
<SetNo>
Range: | 0 to SET COUNT -1
Increment: | 1
*RST: | 0
Example: CDP:SET:COUN 10

Selects the 10th set for further analysis.

Manual operation: See "Set to Analyze"


[SENSe:]CDPower:SLOT

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Evaluation Range > [SENSe:]CDPower:SLOT
[SENSe:]CDPower:SLOT <SlotNumber>

This command selects the slot number to be evaluated. The number of slots to capture has to be defined with the [SENSe:​]CDPower:​IQLength command before using this command.

Parameters:
<SlotNumber>
<numeric value>
Range: | 0 to <Number of slots to capture> -1
Increment: | 1
*RST: | 0
Example:

SENS:CDP:SLOT 3

Example:

See "Measurement 5: Measuring the Composite EVM".

Manual operation: See "Slot Number"


Code Domain Analysis Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Code Domain Analysis Settings
Code Domain Analysis Settings

Some evaluations provide further settings for the results.

List of Commands
CONFigure:CDPower:CTABle:ORDer
[SENSe:]CDPower:NORMalize
[SENSe:]CDPower:PDISplay
[SENSe:]CDPower:PTS


CONFigure:CDPower:CTABle:ORDer

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Code Domain Analysis Settings > CONFigure:CDPower:CTABle:ORDer
CONFigure:CDPower:CTABle:ORDer <CODE | MIDamble>

This command selects sorting of the channel table in code order or midamble order.

Parameters:
<CODE | MIDamble>
CODE

Channels are sorted in code order.

MIDamble

Channels are sorted in midamble order.

*RST: CODE
Example: CONF:CDP:CTAB:ORD

Sorts the channels in code order.

Manual operation: See "Channel Table Sort Order"


[SENSe:]CDPower:NORMalize

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Code Domain Analysis Settings > [SENSe:]CDPower:NORMalize
[SENSe:]CDPower:NORMalize <State>

If enabled, the I/Q offset is eliminated from the measured signal. This is useful to deduct a DC offset to the baseband caused by the DUT, thus improving the EVM. Note, however, that for EVM measurements according to standard, compensation must be disabled.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

SENS:CDP:NORM ON

Activates the elimination of the I/Q offset.

Manual operation: See "Compensate IQ Offset"


[SENSe:]CDPower:PDISplay

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Code Domain Analysis Settings > [SENSe:]CDPower:PDISplay
[SENSe:]CDPower:PDISplay <Mode>

This command switches between showing the absolute or relative power.

This parameter only affects the Code Domain Power evaluation.

Parameters:
<Mode>
ABS | REL
ABSolute

Absolute power levels

RELative

Power levels relative to total power of the data parts of the signal

*RST: ABS
Example:

SENS:CDP:PDIS ABS

Example:

See "Measurement 5: Measuring the Composite EVM".

Manual operation: See "Code Power Display"


[SENSe:]CDPower:PTS

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Code Domain Analysis > Code Domain Analysis Settings > [SENSe:]CDPower:PTS
[SENSe:]CDPower:PTS <State>

If activated, additional information on the DwPTS (BTS mode) or UpPTS (UE mode) is displayed in the Result Summary. (See also "Frames, Subframes and Slots".)

This parameter only affects the Code Domain Power evaluation.

Parameters:
<State>
ON | OFF
ON

PTS evaluation is activated.

OFF

PTS evaluation is disabled.

*RST: OFF
Example:

SENS:CDP:PTS ON

Manual operation: See "Show DwPTS Results (BTS mode)"
See "Show UpPTS Results (UE mode)"


Configuring Frequency and Time Domain Measurements

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Frequency and Time Domain Measurements
Configuring Frequency and Time Domain Measurements

Frequency and time domain measurements are performed in the Spectrum application, with some predefined settings as described in "Frequency and Time Domain Measurements".

For details on configuring these RF measurements in a remote environment, see "Configuring and Performing Measurements" .

The TD-SCDMA RF measurements must be activated for a TD-SCDMA application, see "Activating the TD-SCDMA Applications".

The individual measurements are activated using the CONFigure:​CDPower:​MEASurement command.

Some frequency and time domain measurements require further configuration.

Analysis for Frequency and Time Domain Measurements

General result analysis settings concerning the trace, markers, lines etc. for RF measurements are identical to the analysis functions in the Spectrum application except for some special marker functions and spectrograms, which are not available in TD-SCDMA applications.

See
  • "Zooming into the Display"
  • "Configuring the Trace Display and Retrieving Trace Data"
  • "Working with Markers"
  • "Configuring Display and Limit Lines"
Contents
  • Configuring Power vs Time Measurements
  • Configuring the Slot Range for Frequency Sweeps on Downlink Data


Configuring Power vs Time Measurements

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Frequency and Time Domain Measurements > Configuring Power vs Time Measurements
Configuring Power vs Time Measurements
List of Commands
CONFigure:CDPower[:BTS]:PVTime:SFRames
CONFigure:CDPower[:BTS]:PVTime:SPOint
[SENSe:]POWer:ACHannel:AUTO:LTIMe


CONFigure:CDPower[:BTS]:PVTime:SFRames

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Frequency and Time Domain Measurements > Configuring Power vs Time Measurements > CONFigure:CDPower[:BTS]:PVTime:SFRames
CONFigure:CDPower[:BTS]:PVTime:SFRames <numeric value>

This command defines the number of subframes to be used for averaging.

Parameters:
<numeric value>

Subframe value.

*RST: 100
Example: CONF:CDP:PVT:SFR 50

Sets the number of subframes to 50.

Example:

See "Measurement 7: Checking the Power vs Time"

Manual operation: See "No of Subframes"


CONFigure:CDPower[:BTS]:PVTime:SPOint

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Frequency and Time Domain Measurements > Configuring Power vs Time Measurements > CONFigure:CDPower[:BTS]:PVTime:SPOint
CONFigure:CDPower[:BTS]:PVTime:SPOint <numeric value>

This command defines the switching point between uplink and downlink slots.

Parameters:
<numeric value>

1 to 7

*RST: 3
Example: CONF:CDP:PVT:SPO 7

Sets the switching point to 7.

Example:

See "Measurement 7: Checking the Power vs Time"

Manual operation: See "Switching Point"


[SENSe:]POWer:ACHannel:AUTO:LTIMe

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Frequency and Time Domain Measurements > Configuring Power vs Time Measurements > [SENSe:]POWer:ACHannel:AUTO:LTIMe
[SENSe:]POWer:ACHannel:AUTO:LTIMe

This command automatically adjusts the reference level and the trigger to frame time to their optimum levels. This prevents overloading of the R&S FSW.

Current measurements are aborted when this command is executed and resumed after the automatic level detection is finished.

Example: | See "Measurement 1: Measuring the Signal Channel Power" or "Measurement 7: Checking the Power vs Time".
Usage: | Event
Manual operation: | See "Auto Level & Time"


Configuring the Slot Range for Frequency Sweeps on Downlink Data

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Frequency and Time Domain Measurements > Configuring the Slot Range for Frequency Sweeps on Downlink Data
Configuring the Slot Range for Frequency Sweeps on Downlink Data

In the BTS application, you can define which slots to analyze, i.e. which slots contain downlink data (depending on the switching point).

List of Commands
[SENSe:]POWer:ACHannel:SLOT:STARt
[SENSe:]POWer:ACHannel:SLOT:STOP


[SENSe:]POWer:ACHannel:SLOT:STARt

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Frequency and Time Domain Measurements > Configuring the Slot Range for Frequency Sweeps on Downlink Data > [SENSe:]POWer:ACHannel:SLOT:STARt
[SENSe:]POWer:ACHannel:SLOT:STARt <StartSlot>

Sets the first slot of the measurement.

Parameters:
<StartSlot>

The start slot may not be larger than the stop slot.

In the UE application, the default value is 1.

Range: | 1 to 7
*RST: | 4
Example: POW:ACH:SLOT:STAR 2
Example:

See "Measurement 1: Measuring the Signal Channel Power"

Manual operation: See "Start Slot / Stop Slot"


[SENSe:]POWer:ACHannel:SLOT:STOP

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring Frequency and Time Domain Measurements > Configuring the Slot Range for Frequency Sweeps on Downlink Data > [SENSe:]POWer:ACHannel:SLOT:STOP
[SENSe:]POWer:ACHannel:SLOT:STOP <StopSlot>

Sets the last slot of the measurement.

Parameters:
<StopSlot>

The stop slot may not be lower than the start slot.

In the UE application, stop slots other than 1 require an external trigger. The default value is 1.

Range: | 1 to 7
*RST: | 6
Example: POW:ACH:SLOT:STOP 5
Example:

See "Measurement 1: Measuring the Signal Channel Power"

Manual operation: See "Start Slot / Stop Slot"


Configuring the Result Display

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display
Configuring the Result Display

The following commands are required to configure the screen display in a remote environment. The tasks for manual operation are described in "Result Display Configuration".

Contents
  • General Window Commands
  • Working with Windows in the Display
  • Zooming into the Display


General Window Commands

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > General Window Commands
General Window Commands

The following commands are required to configure general window layout, independent of the application.

List of Commands
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE


DISPlay:FORMat

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > General Window Commands > DISPlay:FORMat
DISPlay:FORMat <Format>

This command determines which tab is displayed.

Parameters:
<Format>
SPLit

Displays the MultiView tab with an overview of all active channels

(See "R&S MultiView" ).

SINGle

Displays the measurement channel that was previously focused.

*RST: SING
Example: DISP:FORM SPL


DISPlay[:WINDow<n>]:SIZE

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > General Window Commands > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows" .


Working with Windows in the Display

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Working with Windows in the Display
Working with Windows in the Display

The following commands are required to change the evaluation type and rearrange the screen layout for a measurement channel as you do using the SmartGrid in manual operation. Since the available evaluation types depend on the selected application, some parameters for the following commands also depend on the selected measurement channel.

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace


LAYout:ADD[:WINDow]?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example" .

Usage: Query only
Manual operation: See "Bitstream"
See "Channel Table"
See "Code Domain Power"
See "Code Domain Error Power"
See "Composite Constellation"
See "Composite EVM"
See "Mag Error vs Chip"
See "Marker Table"
See "Peak Code Domain Error"
See "Phase Error vs Chip"
See "Power vs Slot"
See "Power vs Symbol"
See "Result Summary"
See "Symbol Constellation"
See "Symbol EVM"
See "Symbol Magnitude Error"
See "Symbol Phase Error"
See "Diagram"
See "List Evaluation"
See "Result Summary"
See "Marker Peak List"
<WindowType> parameter values for TD-SCDMA application
Parameter value | Window type
BITStream | Bitstream
CCONst | Composite Constellation
CDPower | Code Domain Power
CDEPower | Code Domain Error Power
CEVM | Composite EVM
CTABle | Channel Table
LEValuation | List evaluation (Power vs Time)
MECHip | Magnitude Error vs Chip
MTABle | Marker table
PCDerror | Peak Code Domain Error
PECHip | Phase Error vs Chip
PSLot | Channel Power vs Slot
PSYMbol | Power vs Symbol
RSUMmary | Result Summary
SCONst | Symbol Constellation
SEVM | Symbol EVM
SMERror | Symbol Magnitude Error
SPERror | Symbol Phase Error


LAYout:CATalog[:WINDow]?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:SPLitter

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


Zooming into the Display

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Zooming into the Display
Zooming into the Display
Contents
  • Using the Single Zoom
  • Using the Multiple Zoom


Using the Single Zoom

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Zooming into the Display > Using the Single Zoom
Using the Single Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:STATe


DISPlay[:WINDow<n>]:ZOOM:AREA

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Single Zoom"


DISPlay[:WINDow<n>]:ZOOM:STATe

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe <State>

This command turns the zoom on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:ZOOM ON

Activates the zoom mode.

Manual operation: See "Single Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Using the Multiple Zoom

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Zooming into the Display > Using the Multiple Zoom
Using the Multiple Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area for a multiple zoom.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Suffix:
<zoom>
1...4

Selects the zoom window.

Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Multiple Zoom"


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Result Display > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe <State>

This command turns the mutliple zoom on and off.

Suffix:
<zoom>
1...4

Selects the zoom window.

If you turn off one of the zoom windows, all subsequent zoom windows move up one position.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Multiple Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Starting a Measurement

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Starting a Measurement
Starting a Measurement

The measurement is started immediately when a TD-SCDMA application is activated, however, you can stop and start a new measurement any time.

List of Commands
ABORt
INITiate:CONMeas
INITiate:CONTinuous
INITiate[:IMMediate]
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
SYSTem:SEQuencer


ABORt

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Starting a Measurement > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONMeas

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Starting a Measurement > INITiate:CONMeas
INITiate:CONMeas

This command restarts a (single) measurement that has been stopped (using INIT:CONT OFF) or finished in single sweep mode.

The measurement is restarted at the beginning, not where the previous measurement was stopped.

As opposed to INITiate[:​IMMediate], this command does not reset traces in maxhold, minhold or average mode. Therefore it can be used to continue measurements using maxhold or averaging functions.

Manual operation: See "Continue Single Sweep"


INITiate:CONTinuous

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Starting a Measurement > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the sweep mode.

Note that in single sweep mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous sweep mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous sweep mode in remote control, as results like trace data or markers are only valid after a single sweep end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the sweep mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous sweep

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the sweep mode to single sweep.

INIT:CONT ON

Switches the sweep mode to continuous sweep.

Manual operation: See "Continuous Sweep/RUN CONT"
See "Start Meas"


INITiate[:IMMediate]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Starting a Measurement > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single Sweep/ RUN SINGLE"
See "Start Meas"


INITiate:SEQuencer:ABORt

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Starting a Measurement > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: Event


INITiate:SEQuencer:IMMediate

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Starting a Measurement > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event


INITiate:SEQuencer:MODE

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Starting a Measurement > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .


INITiate:SEQuencer:REFResh[:ALL]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Starting a Measurement > INITiate:SEQuencer:REFResh[:ALL]
INITiate:SEQuencer:REFResh[:ALL]

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only in MSRA or MSRT mode.

The data in the capture buffer is re-evaluated by all active MSRA/MSRT applications.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INIT:SEQ:REFR Refreshes the display for all channels.
Usage: | Event


SYSTem:SEQuencer

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Starting a Measurement > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .


Retrieving Results

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results
Retrieving Results

The following commands are required to retrieve the results from a TD-SCDMA measurement in a remote environment.

When the channel type is required as a parameter by a remote command or provided as a result for a remote query, abbreviations or assignments to a numeric value are used as described in "Channel Detection".

Useful commands described elsewhere:
  • "Storing Measurement Results"
Contents
  • Retrieving Calculated Measurement Results
  • Retrieving Trace Results
  • Measurement Results for TRACe<n>[:DATA]? TRACE<n>
  • Retrieving RF Results


Retrieving Calculated Measurement Results

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Retrieving Calculated Measurement Results
Retrieving Calculated Measurement Results

The following commands describe how to retrieve the calculated results from the CDA.

List of Commands
CALCulate:MARKer:FUNCtion:CDPower:RESult?
CONFigure:CDPower[:BTS]:PVTime:LIST:RESult?


CALCulate:MARKer:FUNCtion:CDPower:RESult?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Retrieving Calculated Measurement Results > CALCulate:MARKer:FUNCtion:CDPower:RESult?
CALCulate:MARKer:FUNCtion:CDPower:RESult? <ResultType>

This command queries the results of the code domain measurement. Refer to "Code Domain Parameters" for a detailed description of all results.

Suffix:
<n>
1...4

window

Query parameters:
<ResultType>
ACTive

Returns the number of active channels.

ARCD

Returns the Average Relative Code Domain Error.

CDPabsolute

Returns the absolute channel power in dBm.

CDPRelative

Returns the relative channel power in dB.

CHANnel

Returns the current channel number.

CERror

Returns the Chip Rate Error in ppm.

DACTive

Indicates whether DwPTS slot is active (BTS mode only)

DPOWer

Power in the DwPTS slot (BTS mode only)

DRHO

RHO for the DwPTS slot (BTS mode only)

DERM

EVM (RMS) for the DwPTS slot (BTS mode only)

DEPK

EVM (Peak) for the DwPTS slot (BTS mode only)

EVMPeak

Returns the maximum Error Vector Magnitude of the selected channel.

EVMRMS

Returns the average Error Vector Magnitude of the selected channel.

IQIMbalance

Returns the IQ Imbalance in %.

IQOFfset

Returns the IQ Offset in %.

MACCuracy

Returns the Composite EVM in %.

PCDerror

Returns the Peak Code Domain Error dB.

PD1

Returns the power of the slot's data part 1 in dBm.

PD2

Returns the power of the slot's data part 2 in dBm.

PDATa

Returns the average power of the data parts in dBm.

PMIDamble

Returns the power of the midamble in dBm.

RHO

Returns the parameter Rho.

SFACtor

Returns the spreading factor of the channel.

SLOT

Returns the currently analyzed slot number.

SRATe

Returns the symbol rate in ksps.

Note that TFRame returns a '9' if the trigger is at Free Run.

TFRame

Returns the Trigger to Frame time in seconds.

Example: CALC:MARK:FUNC:CDP:RES? CERR

Returns the Chip Rate Error

Example:

See "Measurement 5: Measuring the Composite EVM"

Usage: Query only
Manual operation: See "Code Domain Power"
See "Result Summary"


CONFigure:CDPower[:BTS]:PVTime:LIST:RESult?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Retrieving Calculated Measurement Results > CONFigure:CDPower[:BTS]:PVTime:LIST:RESult?
CONFigure:CDPower[:BTS]:PVTime:LIST:RESult?

Queries the list evaluation results for Power vs Time measurements. The results are a comma-separated list containing the following values for each list range:

Return values:
<RangeNo> | consecutive number of list range
<StartTime> | Start time of the individual list range
<StopTime> | Stop time of the individual list range
<AverageDBM> | Average power level in list range in dBm.
<AverageDB> | Average power level in list range in dB.
<MaxDBM> | Maximum power level in list range in dBm.
<MaxDB> | Maximum power level in list range in dB.
<MinDBM> | Minimum power level in list range in dBm.
<MinDB> | Minimum power level in list range in dB.
<LimitCheck> | Result of limit check for the list range. 0 Passed 1 Failed
<Reserved1> | 0; currently not used
<Reserved2> | 0; currently not used
Usage: | Query only
Manual operation: | See "Power vs Time"


Retrieving Trace Results

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Retrieving Trace Results
Retrieving Trace Results

The following commands describe how to retrieve the trace data from the CDA. Note that for these measurements, only 1 trace per window can be configured.

List of Commands
FORMat[:DATA]
TRACe<n>[:DATA]?
TRACe<n>[:DATA]:X?


FORMat[:DATA]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Retrieving Trace Results > FORMat[:DATA]
FORMat[:DATA] <Format>

This command selects the data format that is used for transmission of trace data from the R&S FSW to the controlling computer.

Note that the command has no effect for data that you send to the R&S FSW. The R&S FSW automatically recognizes the data it receives, regardless of the format.

Parameters:
<Format>
ASCii

ASCii format, separated by commas.

This format is almost always suitable, regardless of the actual data format. However, the data is not as compact as other formats may be.

REAL,32

32-bit IEEE 754 floating-point numbers in the "definite length block format".

In the Spectrum application, the format setting REAL is used for the binary transmission of trace data.

For I/Q data, 8 bytes per sample are returned for this format setting.

*RST: ASCII
Example: FORM REAL,32
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Usage: SCPI confirmed


TRACe<n>[:DATA]?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? <ResultType>

This command returns the trace data. Depending on the evaluation, the trace data format varies.

The data format depends on FORMat[:​DATA].

For details see "Measurement Results for TRACe<n>[:DATA]? TRACE<n>".

Query parameters:
<ResultType>

Selects the type of result to be returned.

TRACE1 | ... | TRACE4

Returns the trace data for the corresponding trace as a comma-separated list of values. This data consists of some or all of the result parameters described below, depending on the result type.

For details see "Measurement Results for TRACe<n>[:DATA]? TRACE<n>".

LIST

For CDA measurements:

Returns the results for the DwPTS/UpPTS slot. See table "Return values for LIST parameter (DwPTS / UpPTS Results)".

For RF measurements:

Returns the results of the peak list evaluation for Spurious Emission and Spectrum Emission Mask measurements.

For details see table "Return values for LIST parameter (Spurious / SEM measurements)".

Return values:
<AbsLevel> | <RelLevel>
dBm or %

Absolute level of the channel at the selected channel slot

or:

Relative level of the channel at the selected channel slot referenced to CPICH or total power

(Depending on [SENSe:​]CDPower:​PDISplay)

<ActiveFlag>
0 | 1

Flag to indicate whether a channel is active (1) or not (0)

<CError>

Chip Rate Error in ppm.

<CDPAbsolute>, <CDPRelative>

Code domain power absolute or relative to total signal power (data parts).

<ChannelType>
0 ... 2

Type of the channel

0= inactive

1= midamble

2= DPCH

<CodeClass>
0 … 4

Code class of the channel. The code class specifies the spreading factor of the channel.

0= spreading factor 1

1= spreading factor 2

2= spreading factor 4

3= spreading factor 8

4= spreading factor 16

<CodeNo>
1 … 16

Code number of the channel. The number of codes depends on the spreading factor (see table "Relationship between code class, channels and spreading factor").

<EVMPeak>

Maximum value of the EVM.

<EVMRMS>

Average value of the EVM.

<FError>

Frequency Error in Hz.

<CIQImbal>

I/Q Imbalance in %.

<IQOffset>

I/Q Offset in %.

<MAccuracy>

Composite EVM in %.

<MAShift>
0 … 38400

Midamble shift of the channel

<ΔMiD1>, <ΔMiD2>
dB

Power offset between:

sum power of channels belonging to midamble(k), only data field 1/2

and

power of midamble(k)

<ModType>

Modulation type of the channel

0= invalid (for midamble)

1= QPSK

2= 8PSK

3= 16QAM

4= 64QAM

<PCDError>

Peak Code Domain Error in dB.

<PD1>, <PD2>

Power of the data parts over all channels in dB.

<PData>

Mean power of both data parts (P1 and P2) over all channels in dBm.

<PMidamble>

Power of the midamble in dB.

<reserved1-4>

Placeholder value; Currently not used.

<RHO>
0 | 1

Rho.

<SF>
1 ... 16

Spreading Factor of the channel.

<Slot>

Slot number. The range depends on the capture length.

<SYMRate>

Symbol rate in kbps.

<TrigFrame>

Trigger to Frame in ms.

This value is valid only after successful synchronization to the TD-SCDMA signal. When using the Free Run trigger mode, the command returns a '9'.

<Validity>

0= inactive channel

1= active channel

2= alias channel. In this case the channel consists of more than one code.

Example: TRAC2:DATA? TRACE1

Returns the trace data from trace 1 in window 2.

Usage: Query only
Manual operation: See "Bitstream"
See "Channel Table"
See "Code Domain Power"
See "Code Domain Error Power"
See "Composite Constellation"
See "Composite EVM"
See "Mag Error vs Chip"
See "Peak Code Domain Error"
See "Phase Error vs Chip"
See "Power vs Slot"
See "Power vs Symbol"
See "Result Summary"
See "Symbol Constellation"
See "Symbol EVM"
See "Symbol Magnitude Error"
See "Symbol Phase Error"
See "Power vs Time"
Return values for LIST parameter (Spurious / SEM measurements)

For every measurement range you have defined (range 1...n), the command returns eight values in the following order.

<No>,<StartFreq>,<StopFreq>,<RBW>,<PeakFreq>,<PowerAbs>,<PowerRel>,<PowerDelta>,<LimitCheck>,<Unused1>,<Unused2>

  • <No>: range number
  • <StartFreq>,<StopFreq>: start and stop frequency of the range
  • <RBW>: resolution bandwidth
  • <PeakFreq>: frequency of the peak in a range
  • <PowerAbs>: absolute power of the peak in dBm
  • <PowerRel>: power of the peak in relation to the channel power in dBc
  • <PowerDelta>: distance from the peak to the limit line in dB, positive values indicate a failed limit check
  • <LimitCheck>: state of the limit check (0 = PASS, 1 = FAIL)
  • <Unused1>,<Unused2>: reserved (0.0)
Return values for LIST parameter (DwPTS / UpPTS Results)

For CDA measurements the LIST parameter returns the following results for the Downlink Pilot Time Slot (DwPTS) or Uplink Pilot Time Slot (UpPTS):

<State>,<Power>,<Rho>,<EVM RMS>,<EVM peak>

  • <State>: Indicates whether DwPTS/UpPTS slot is active
  • <Power>: Power in the DwPTS/UpPTS slot
  • <Rho>: RHO for the DwPTS/UpPTS slot
  • <EVM RMS>: EVM (RMS) for the DwPTS/UpPTS slot
  • <EVM peak>: EVM (Peak) for the DwPTS/UpPTS slot


TRACe<n>[:DATA]:X?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]:X? <TraceNumber>

This command queries the horizontal trace data for each sweep point in the specified window, for example the frequency in frequency domain or the time in time domain measurements.

This is especially useful for traces with non-equidistant x-values, e.g. for SEM or Spurious Emissions measurements.

Query parameters:
<TraceNumber> | Trace number. TRACE1 | ... | TRACE6
Example: | TRAC3:X? TRACE1 Returns the x-values for trace 1 in window 3.
Usage: | Query only


Measurement Results for TRACe<n>[:DATA]? TRACE<n>

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n>
Measurement Results for TRACe<n>[:DATA]? TRACE<n>

The evaluation method selected by the LAY:ADD:WIND command also affects the results of the trace data query (see TRACe<n>[:​DATA]?).

Details on the returned trace data depending on the evaluation method are provided here.

For details on the graphical results of these evaluation methods, see "Evaluation Methods for Code Domain Analysis".

Contents
  • Bitstream
  • Channel Table
  • Code Domain Power / Code Domain Error Power
  • Composite Constellation
  • Composite EVM (RMS)
  • Mag Error vs Chip
  • Peak Code Domain Error
  • Phase Error vs Chip
  • Power vs Slot
  • Power vs Symbol
  • Power vs Time
  • Result Summary
  • Symbol Constellation
  • Symbol EVM
  • Symbol Magnitude Error
  • Symbol Phase Error


Bitstream

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Bitstream
Bitstream

When the trace data for this evaluation is queried, the bit stream of one slot is transferred. One value is transferred per bit (range 0, 1).

The number of bits depends on the modulation (see table "Channel parameters and their dependencies").


Channel Table

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Channel Table
Channel Table

For the Channel Table result display, the command returns 11 values for each channel in the following order:

<ChannelType>, <CodeClass>, <CodeNo>, <ModType>, <AbsLevel>, <RelLevel>, <MAShift>, <ΔMiD1>, <ΔMiD2>, <reserved1>, <reserved2>

For details on these parameters see TRACe<n>[:​DATA]?.

The output depends on the channel sorting order (see CONFigure:​CDPower:​CTABle:​ORDer).

In code sorting order, all midambles are output first, then control channels and last the data channels.

In midamble sorting order, each midamble is output with its corresponding control and data channel.

Example:

The following example shows the results of a query for three active channels in common midamble allocation:

  • Midamble m(3), -3.0 dBm
  • DPCH, 1.16, QPSK, -7.78 dB
  • DPCH, 2.8, QPSK, -7.78 dB
  • DPCH, 3.4, 8PSK, -7.78 dB

In this example, the command would return the following string:

1, 0, 0, 0, –3.0, 0, 3, 0.005, 0.005, 0, 0 2 , 4, 1, 1, –7.78, –4.78, 3, 0, 0, 0, 0 2 , 3, 2, 1, –7.78, –4.78, 3, 0, 0, 0, 0 2 , 2, 3, 2, –7.78, –4.78, 3, 0, 0, 0, 0 0 , 4, 2, 1, –46.9, –43.9, 3, 0, 0, 0, 0 0 , 4, 5, 1, –46.9, –43.9, 3, 0, 0, 0, 0 0 , 4, 6, 1, –46.9, –43.9, 3, 0, 0, 0, 0 0 , 4, 7, 1, –46.9, –43.9, 3, 0, 0, 0, 0 0 , 4, 8, 1, –46.9, –43.9, 3, 0, 0, 0, 0 0 , 4, 13, 1, –46.9, –43.9, 3, 0, 0, 0, 0 0 , 4, 14, 1, –46.9, –43.9, 3, 0, 0, 0, 0 0 , 4, 15, 1, –46.9, –43.9, 3, 0, 0, 0, 0 0 , 4, 16, 1, –46.9, –43.9, 3, 0, 0, 0, 0


Code Domain Power / Code Domain Error Power

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Code Domain Power / Code Domain Error Power
Code Domain Power / Code Domain Error Power

When the trace data for this evaluation is queried, 4 values are transmitted for each channel:

<CodeClass>, <CodeNo>, <Level>, <ActiveFlag>

  • the code class (<CodeClass>)
  • the channel number (<CodeNo>)
  • the absolute or relative level (<Level>), depending on [SENSe:​]CDPower:​PDISplay
  • the state of the channel (<ActiveFlag>)

For details on these parameters see TRACe<n>[:​DATA]?.

The query returns a maximum of 16 channels. Channels that consist of more than one code are returned as one channel.

Example:

Consider the following configuration (three active channels out of a total of 12):

  • DPCH, 1.16, (CC4), -7.0 dB
  • DPCH, 2.8, (CC3), -7.3 dB
  • DPCH, 3.4, (CC2), -8.0 dB

In this example, the command would return the following string (active channels in bold):

4, 1, -7.0, 1, 4, 2, -55.1, 0,3, 2, -7.3, 1, 4, 5, -56.3, 0, 4, 6, -55.8, 0, 4, 7, -57.0, 0,2, 3, -8.0, 1, 4, 13, -55.8, 0, 4, 14, -56.3, 0, 4, 15, -55.9, 0, 4, 16, -57.3, 0


Composite Constellation

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Composite Constellation
Composite Constellation

When the trace data for this evaluation is queried, the real and the imaginary branches of the chip constellation at the selected slot are transferred:

<Re1>, <Im1>, <Re2>, <Im2>, ...., <Re864>, <Im864>

The values are normalized to the square root of the average power at the selected slot.


Composite EVM (RMS)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Composite EVM (RMS)
Composite EVM (RMS)

For the Composite EVM result display, the command returns two values for each slot in the following order:

<Slot_0>, <MAccuracy_0>, ..., <Slot_n>, <MAccuracy_n>

The number of slots depends on the capture length.


Mag Error vs Chip

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Mag Error vs Chip
Mag Error vs Chip

When the trace data for this evaluation is queried, a list of magnitude error values of all chips at the selected slot is returned (=2560 values). The values are calculated as the magnitude difference between the received signal and the reference signal for each chip in %, and are normalized to the square root of the average power at the selected slot.


Peak Code Domain Error

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Peak Code Domain Error
Peak Code Domain Error

For the Peak Code Domain Error result display, the command returns two values for each slot in the following order:

<Slot_0>, <AbsLevel_0>, ..., <Slot_n>, <AbsLevel_n>

The number of slots depends on the capture length.


Phase Error vs Chip

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Phase Error vs Chip
Phase Error vs Chip

When the trace data for this evaluation is queried, a list of phase error values of all chips in the selected slot is returned (=2560 values). The values are calculated as the phase difference between the received signal and the reference signal for each chip in degrees, and are normalized to the square root of the average power at the selected slot.


Power vs Slot

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Power vs Slot
Power vs Slot

For the Power vs Slot result display, the command returns three values for each slot in the following order:

<Slot_0>, <Level_0>, <Validity_0>..., <Slot_n>, <Level_n>, <Validity_n>

In addition to the power level, the source of the power (active, inactive or alias channel) is provided.

Whether the level is provided as an absolute or relative value depends on [SENSe:​]CDPower:​PDISplay).


Power vs Symbol

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Power vs Symbol
Power vs Symbol

When the trace data for this evaluation is queried, the absolute power of each symbol at the selected slot is transferred.

The number of symbols depends on the spreading factor (see table "Channel parameters and their dependencies").


Power vs Time

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Power vs Time
Power vs Time

When the trace data for this evaluation is queried, the peak power in the defined slot range for each measured subframe is transferred.

The number of values depends on the number of subframes (see "No of Subframes").


Result Summary

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Result Summary
Result Summary

For the Result Summary, the command returns 25 values for the selected set, slot and channel in the following order:

<Slot>, <PData>, <PD1>, <PD2>, <PMidamble>, <RHO>, <MAccuracy>, <PCDError>, <FError>, <CError>, <TrigFrame>, <IQImbalance>, <IQOffset>, <ActiveFlag>, <SymRate>, <CodeNo>, <SF>, <CDPRelative>, <CDPAbsolute>, <EVMRMS>, <EVMPeak>, <reserved1>, <reserved2>, <reserved3>, <reserved4>

For details on these parameters see TRACe<n>[:​DATA]?.


Symbol Constellation

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Symbol Constellation
Symbol Constellation

For the Symbol Constellation result display, the command returns one value each for the real and imaginary parts of each symbol:

<Re0>, <Im0>, <Re1>, <Im1>, ...., <Ren>, <Imn>

The number of symbols depends on the spreading factor (see table "Channel parameters and their dependencies").


Symbol EVM

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Symbol EVM
Symbol EVM

For the Symbol EVM result display, the command returns one value for each symbol: <EVMRMS>

The number of symbols depends on the spreading factor (see table "Channel parameters and their dependencies").


Symbol Magnitude Error

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Symbol Magnitude Error
Symbol Magnitude Error

When the trace data for this evaluation is queried, the magnitude error in % of each symbol at the selected slot is transferred. The number of the symbols depends on the spreading factor of the selected channel:

NOFSymbols=10*2(8-CodeClass)


Symbol Phase Error

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Symbol Phase Error
Symbol Phase Error

When the trace data for this evaluation is queried, the phase error in degrees of each symbol at the selected slot is transferred. The number of the symbols depends on the spreading factor of the selected channel:

NOFSymbols=10*2(8-CodeClass)


Retrieving RF Results

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Retrieving RF Results
Retrieving RF Results

The following commands are required to retrieve the results of the TD-SCDMA RF measurements.

See also "Measurement Results for TRACe<n>[:DATA]? TRACE<n>".

List of Commands
CALCulate:LIMit<k>:FAIL?
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate<n>:MARKer<m>:Y?
CALCulate:STATistics:RESult<t>?


CALCulate:LIMit<k>:FAIL?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Retrieving RF Results > CALCulate:LIMit<k>:FAIL?
CALCulate:LIMit<k>:FAIL?

This command queries the result of a limit check.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result>
0

PASS

1

FAIL

Example: INIT;*WAI

Starts a new sweep and waits for its end.

CALC:LIM3:FAIL?

Queries the result of the check for limit line 3.

Example:

See "Example: SEM Measurement" .

Usage: Query only
SCPI confirmed
Manual operation: See "Power vs Time"
See "Spectrum Emission Mask"


CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Retrieving RF Results > CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult? <Measurement>

This command queries the results of power measurements.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement; for all other measurements: irrelevant

Query parameters:
<Measurement>
ACPower | MCACpower

ACLR measurements (also known as adjacent channel power or multicarrier adjacent channel measurements).

Returns the power for every active transmission and adjacent channel. The order is:

• power of the transmission channels

• power of adjacent channel (lower,upper)

• power of alternate channels (lower,upper)

MSR ACLR results:

For MSR ACLR measurements, the order of the returned results is slightly different:

• power of the transmission channels

• total power of the transmission channels for each sub block

• power of adjacent channels (lower, upper)

• power of alternate channels (lower, upper)

• power of gap channels (lower1, upper1, lower2, upper2)

The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

CN

Carrier-to-noise measurements.

Returns the C/N ratio in dB.

CN0

Carrier-to-noise measurements.

Returns the C/N ratio referenced to a 1 Hz bandwidth in dBm/Hz.

CPOWer

Channel power measurements.

Returns the channel power. The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

For SEM measurements, the return value is the channel power of the reference range (in the specified sub block).

PPOWer

Peak power measurements.

Returns the peak power. The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

For SEM measurements, the return value is the peak power of the reference range (in the specified sub block).

OBANdwidth | OBWidth

Occupied bandwidth.

Returns the occupied bandwidth in Hz.

Example:

See "Example: Configuring and Performing an ACLR Measurement" .

Example:

See "Example: Configuring and Performing an MSR ACLR Measurement" .

Example:

See "Programming example" .

Example:

See "Programming Example: OBW Measurement" .

Example:

See "Programming Examples (-K73)" .

Example:

See "Programming Examples (TD-SCDMA BTS)"

Usage: Query only
Manual operation: See "Power"
See "Ch Power ACLR"
See "Spectrum Emission Mask"
See "Occupied Bandwidth"


CALCulate<n>:MARKer<m>:Y?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Retrieving RF Results > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | Result at the marker position.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2.
Usage: | Query only
Manual operation: | See "Marker Table" See "Marker Peak List" See "Marker 1 / Marker 2 / Marker 3 / Marker 4"


CALCulate:STATistics:RESult<t>?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Retrieving Results > Retrieving RF Results > CALCulate:STATistics:RESult<t>?
CALCulate:STATistics:RESult<t>? <ResultType>

This command queries the results of a CCDF or ADP measurement for a specific trace.

Parameters:
<ResultType>
MEAN

Average (=RMS) power in dBm measured during the measurement time.

PEAK

Peak power in dBm measured during the measurement time.

CFACtor

Determined crest factor (= ratio of peak power to average power) in dB.

ALL

Results of all three measurements mentioned before, separated by commas: <mean power>,<peak power>,<crest factor>

Example: CALC:STAT:RES2? ALL

Reads out the three measurement results of trace 2. Example of answer string: 5.56,19.25,13.69 i.e. mean power: 5.56 dBm, peak power 19.25 dBm, crest factor 13.69 dB

Example:

See "Programming Example: Measuring Statistics" .

Usage: Query only
Manual operation: See "CCDF"


Analysis

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis
Analysis

The following commands define general result analysis settings concerning the traces and markers.

Contents
  • Traces
  • Markers


Traces

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Traces
Traces

The trace settings determine how the measured data is analyzed and displayed on the screen. In TD-SCDMA applications, only one trace per window can be configured for Code Domain Analysis.

List of Commands
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]


DISPlay[:WINDow<n>]:TRACe<t>:MODE

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE <Mode>

This command selects the trace mode.

In case of max hold, min hold or average trace mode, you can set the number of single measurements with [SENSe:​]SWEep:​COUNt. Note that synchronization to the end of the measurement is possible only in single sweep mode.

For more information see "Analyzing Several Traces - Trace Mode" .

Example: INIT:CONT OFF

Switching to single sweep mode.

SWE:COUN 16

Sets the number of measurements to 16.

DISP:TRAC3:MODE WRIT

Selects clear/write mode for trace 3.

INIT;*WAI

Starts the measurement and waits for the end of the measurement.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trace Mode"


DISPlay[:WINDow<n>]:TRACe<t>[:STATe]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Traces > DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe] <State>

This command turns a trace on and off.

The measurement continues in the background.

Example: DISP:TRAC3 ON
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


Markers

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers
Markers

Markers help you analyze your measurement results by determining particular values in the diagram. In TD-SCDMA applications, only 4 markers per window can be configured for Code Domain Analysis.

Contents
  • Individual Marker Settings
  • General Marker Settings
  • Marker Search and Positioning Settings


Individual Marker Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Individual Marker Settings
Individual Marker Settings
List of Commands
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?


CALCulate<n>:MARKer<m>[:STATe]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "Marker State"
See "Marker Type"


CALCulate<n>:MARKer<m>:X

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.

Manual operation: See "Marker Table"
See "Marker Peak List"
See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "X-value"


CALCulate<n>:MARKer<m>:AOFF

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:AOFF

This command turns all markers off.

Example: | CALC:MARK:AOFF Switches off all markers.
Usage: | Event
Manual operation: | See "All Markers Off"


CALCulate<n>:DELTamarker<m>[:STATe]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>[:STATe] <State>

This command turns delta markers on and off.

If necessary, the command activates the delta marker first.

No suffix at DELTamarker turns on delta marker 1.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2 ON

Turns on delta marker 2.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "Marker State"
See "Marker Type"


CALCulate<n>:DELTamarker:AOFF

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:AOFF

This command turns all delta markers off.

Example: | CALC:DELT:AOFF Turns all delta markers off.
Usage: | Event


CALCulate<n>:DELTamarker<m>:X

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Example: | CALC:DELT:X? Outputs the absolute x-value of delta marker 1.
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / Marker 4" See "X-value"


CALCulate<n>:DELTamarker<m>:X:RELative?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:X:RELative?

This command queries the relative position of a delta marker on the x-axis.

If necessary, the command activates the delta marker first.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | CALC:DELT3:X:REL? Outputs the frequency of delta marker 3 relative to marker 1 or relative to the reference position.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / Marker 4"


CALCulate<n>:DELTamarker<m>:Y?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>:Y?

This command queries the relative position of a delta marker on the y-axis.

If necessary, the command activates the delta marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

The unit depends on the application of the command.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a sweep and waits for its end. CALC:DELT2 ON Switches on delta marker 2. CALC:DELT2:Y? Outputs measurement value of delta marker 2.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / Marker 4"


General Marker Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > General Marker Settings
General Marker Settings
List of Commands
DISPlay:MTABle


DISPlay:MTABle

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > General Marker Settings > DISPlay:MTABle
DISPlay:MTABle <DisplayMode>

This command turns the marker table on and off.

Parameters:
<DisplayMode>
ON

Turns the marker table on.

OFF

Turns the marker table off.

AUTO

Turns the marker table on if 3 or more markers are active.

*RST: AUTO
Example: DISP:MTAB ON

Activates the marker table.

Manual operation: See "Marker Table Display"


Marker Search and Positioning Settings

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings
Marker Search and Positioning Settings
List of Commands
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt


CALCulate<n>:MARKer<m>:MAXimum:LEFT

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:LEFT

This command moves a marker to the next lower peak.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MAXimum:NEXT

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:NEXT

This command moves a marker to the next lower peak.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:MARKer<m>:MAXimum:RIGHt

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum:RIGHt

This command moves a marker to the next lower peak.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

This command moves a marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:MARKer<m>:MINimum:LEFT

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:LEFT

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum:NEXT

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:NEXT

This command moves a marker to the next minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:MARKer<m>:MINimum:RIGHt

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:RIGHt

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum[:PEAK]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]

This command moves a marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

This command moves a delta marker to the next higher value.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

This command moves a marker to the next higher value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

This command moves a delta marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

This command moves a delta marker to the next higher value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:LEFT

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:LEFT

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:NEXT

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT

This command moves a marker to the next higher minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

This command moves a delta marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


Configuring the Application Data Range (MSRA mode only)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Application Data Range (MSRA mode only)
Configuring the Application Data Range (MSRA mode only)

In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications define an extract of the captured data for analysis, referred to as the application data.

For the TD-SCDMA BTS application, the application data range is defined by the same commands used to define the signal capture in Signal and Spectrum Analyzer mode (see "Signal Capturing"). Be sure to select the correct measurement channel before executing this command.

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the application data for the TD-SCDMA BTS measurement.

The analysis interval used by the individual result displays cannot be edited, but is determined automatically. However, you can query the currently used analysis interval for a specific window.

The analysis line is displayed by default but can be hidden or re-positioned.

Remote commands exclusive to MSRA applications

The following commands are only available for MSRA application channels:

List of Commands
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
INITiate:REFResh
[SENSe:]MSRA:CAPTure:OFFSet


CALCulate:MSRA:ALINe:SHOW

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Application Data Range (MSRA mode only) > CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRA applications and the MSRA Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON


CALCulate:MSRA:ALINe[:VALue]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Application Data Range (MSRA mode only) > CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRA applications and the MSRA Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time of the MSRA measurement.

Default unit: s


CALCulate:MSRA:WINDow<n>:IVAL?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Application Data Range (MSRA mode only) > CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:MSRA:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRA View or MSRA Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


INITiate:REFResh

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Application Data Range (MSRA mode only) > INITiate:REFResh
INITiate:REFResh

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only for applications in MSRA mode, not the MSRA Master.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INST:SEL 'IQ ANALYZER' Selects the IQ Analyzer channel. INIT:REFR Refreshes the display for the I/Q Analyzer channel.
Usage: | Event
Manual operation: | See "Refresh"


[SENSe:]MSRA:CAPTure:OFFSet

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Configuring the Application Data Range (MSRA mode only) > [SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]MSRA:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRA mode, not for the MSRA Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | 0 to <Record length>
*RST: | 0
Manual operation: See "Capture Offset"


Status Registers

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Status Registers
Status Registers

The following commands are required for the status reporting system specific to the TD-SCDMA applications. In addition, the TD-SCDMA applications also use the standard status registers of the R&S FSW (depending on the measurement type).

For details and a description of the common R&S FSW status registers see "Status Reporting System" and "STATus:QUEStionable:DIQ Register" .

*RST does not influence the status registers.

Contents
  • STATus:QUEStionable:SYNC Register


STATus:QUEStionable:SYNC Register

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Status Registers > STATus:QUEStionable:SYNC Register
STATus:QUEStionable:SYNC Register

The STATus:QUEStionable:SYNC register contains application-specific information about synchronization errors or errors during pilot symbol detection.

Status error bits in STATus:QUEStionable:SYNC register for TD-SCDMA applications

Bit

Definition

0

Not used.

1

Frame Sync failed

This bit is set when synchronization is not possible within the application.

Possible reasons:

  • Invalid frequency
  • Invalid level
  • Invalid scrambling code
  • Invalid max. number of MA shift cell
  • Invalid values for INVERT Q
  • Invalid signal at input

2 to 14

Not used.

15

This bit is always 0.

List of Commands
STATus:QUEStionable:SYNC[:EVENt]?
STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:PTRansition


STATus:QUEStionable:SYNC[:EVENt]?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Status Registers > STATus:QUEStionable:SYNC Register > STATus:QUEStionable:SYNC[:EVENt]?
STATus:QUEStionable:SYNC[:EVENt]? <ChannelName>

This command reads out the EVENt section of the status register.

The command also deletes the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:QUEStionable:SYNC:CONDition?

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Status Registers > STATus:QUEStionable:SYNC Register > STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:CONDition? <ChannelName>

This command reads out the CONDition section of the status register.

The command does not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:QUEStionable:SYNC:ENABle

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Status Registers > STATus:QUEStionable:SYNC Register > STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:ENABle <BitDefinition>, <ChannelName>

This command controls the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to be reported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:QUEStionable:SYNC:NTRansition

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Status Registers > STATus:QUEStionable:SYNC Register > STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:NTRansition <BitDefinition>,<ChannelName>

This command controls the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:QUEStionable:SYNC:PTRansition

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Status Registers > STATus:QUEStionable:SYNC Register > STATus:QUEStionable:SYNC:PTRansition
STATus:QUEStionable:SYNC:PTRansition <BitDefinition>,<ChannelName>

These commands control the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Commands for Compatibility

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Commands for Compatibility
Commands for Compatibility

The following commands are provided for compatibility to other signal analyzers only. For new remote control programs use the specified alternative commands.

List of Commands
CALCulate<n>:FEED
CONFigure:CDPower[:BTS]:PVTime:LIST[:STATe]
[SENSe:]CDPower:LEVel:ADJust


CALCulate<n>:FEED

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Commands for Compatibility > CALCulate<n>:FEED
CALCulate<n>:FEED <Evaluation>

This command selects the evaluation method of the measured data that is to be displayed in the specified window.

Note that this command is maintained for compatibility reasons only. Use the LAYout commands for new remote control programs (see "Working with Windows in the Display").

Parameters:
<Evaluation> | Type of evaluation you want to display. See the table below for available parameter values.
Example: | INST:SEL BTDS Activates TD-SCDMA mode. CALC:FEED CDP Selects the display of the code domain power.
<Evaluation> parameter values for TD-SCDMA applications
String Parameter | Enum Parameter | Evaluation
'XTIM:CDP:BSTReam' | BITStream | Bitstream
'XTIM:CDP:COMP:CONStellation' | CCONst | Composite Constellation
'XPOW:CDEPower' | CDEPower | Code Domain Error Power
'XPOW:CDP' 'XPOW:CDP:ABSolute' | CDPower | Code Domain Power (absolute scaling)
'XPOW:CDP:RATio' | CDPower | Code Domain Power (relative scaling) *)
'XTIM:CDP:MACCuracy' | CEVM | Composite EVM
'XTIM:CDP:ERR:CTABle' | CTABle | Channel Table
'XTIM:CDP:ERR:PCDomain' | PCDerror | Peak Code Domain Error
'XTIM:CDP:PVSLot' 'XTIM:CDP:PVSLot:ABSolute' | PSLot | Power vs Slot (absolute scaling)
'XTIM:CDP:PVSLot:RATio' | PSLot | Power vs Slot (relative scaling)*)
'XTIM:CDP:PVSYmbol' | PSYMbol | Power vs Symbol
'XTIM:CDP:ERR:SUMMary' | RSUMmary | Result Summary
‘XPOW:CDP:RATio' | SCONst | Symbol Constellation
'XTIM:CDP:SYMB:EVM' | SEVM | Symbol EVM
*) Use [SENS:]CDP:PDIS ABS | REL subsequently to change the scaling


CONFigure:CDPower[:BTS]:PVTime:LIST[:STATe]

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Commands for Compatibility > CONFigure:CDPower[:BTS]:PVTime:LIST[:STATe]
CONFigure:CDPower[:BTS]:PVTime:LIST[:STATe] <State>

This command hides or shows the list evaluation result display.

Note that this command is maintained for compatibility reasons only. Use the LAYout commands for new remote control programs (see "Working with Windows in the Display").

Parameters:
<State>
ON | OFF
*RST: OFF


[SENSe:]CDPower:LEVel:ADJust

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Commands for Compatibility > [SENSe:]CDPower:LEVel:ADJust
[SENSe:]CDPower:LEVel:ADJust

This command adjusts the reference level to the measured channel power. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Note that this command is retained for compatibility reasons only. For new R&S FSW programs use [SENSe:​]ADJust:​LEVel.


Programming Examples (TD-SCDMA BTS)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Programming Examples (TD-SCDMA BTS)
Programming Examples (TD-SCDMA BTS)

The following programming examples are meant to demonstrate the operation of the R&S FSWTD-SCDMA application in a remote environment. They are performed with an R&S FSW equipped with option R&S FSW-K76. Only the commands required to control the R&S FSW-K76 application are provided, not the signal generator.

The measurements are performed using the following devices and accessories:

  • The R&S FSW with Application Firmware R&S FSW-K76: TD-SCDMA BTS
  • The Vector Signal Generator R&S SMU with option R&S SMU-B45: digital standard 3GPP (options R&S SMU-B20 and R&S SMU-B11 required)
  • 1 coaxial cable, 50Ω, approx. 1 m, N connector
  • 1 coaxial cable, 50Ω, approx. 1 m, BNC connector
Test setup

  1. Connect the RF output of the R&S SMU to the input of the R&S FSW.

  2. Connect the reference input (REF INPUT) on the rear panel of the R&S FSW to the reference input (REF) on the rear panel of the R&S SMU (coaxial cable with BNC connectors).

  3. Connect the external trigger input on the front panel of the R&S FSW (TRIGGER INPUT) to the external trigger output on the front panel of the R&S SMU (TRIGOUT1 of PAR DATA).

Settings on the R&S SMU
Setting | Value
Preset |
Frequency | 2.1175 GHz
Level | 0 dBm
Digital standard | TDSCDMA/3GPP
Link direction | DOWN/FORWARD
Test model | DPCCH_DPDCH960ksps
User equipment | UE 1
Digital standard - State | ON
Scrambling code | 0000

The following measurements are described:

Contents
  • Measurement 1: Measuring the Signal Channel Power
  • Measurement 2: Determining the Spectrum Emission Mask
  • Measurement 3: Measuring the Relative Code Domain Power
  • Measurement 4: Triggered Measurement of Relative Code Domain Power
  • Measurement 5: Measuring the Composite EVM
  • Measurement 6: Determining the Peak Code Domain Error
  • Measurement 7: Checking the Power vs Time


Measurement 1: Measuring the Signal Channel Power

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Programming Examples (TD-SCDMA BTS) > Measurement 1: Measuring the Signal Channel Power
Measurement 1: Measuring the Signal Channel Power
//------- Preparing the instrument ------------
//Reset the instrument
*RST
//Activate a TD-SCDMA BTS measurement channel named "BTSMeasurement"
INST:CRE:NEW BTDS,'BTSMeasurement'
//Set the reference level to 0 dBm
DISP:TRAC:Y:SCAL:RLEV 0
//Set the center frequency to 2.1175 GHz
FREQ:CENT 2.1175 GHz
//Select the power measurement
CONF:CDP:MEAS POW

//--------Configuring the measurement ----------------
//Set the slot range to analyze downlink data from slots 3 to 7 (switching point = 2)
SENS:POW:ACH:SLOT:STAR 3
SENS:POW:ACH:SLOT:STOP 7
//Automatically set the reference level and trigger to frame values according
//to measured levels and time.
SENS:POW:ACH:AUTO:LTIM

//----------Performing the measurement -----------------
//Stops continuous sweep
INIT:CONT OFF
//Sets the number of sweeps to be performed to 10
SWE:COUN 10
//Start a new measurement with 10 sweeps and wait for the end
INIT;*WAI

//-------------Retrieving results --------------------------
//Retrieves the calculated total power value of the signal channel
CALC:MARK:FUNC:POW:RES? CPOW
//Result: -1.02 [dB]
//Retrieve the trace data of the power measurement
TRAC:DATA? TRACE1
//Result: -1.482287750E+002,-6.440737915E+001,-1.482287750E+002,-1.482287750E+002,
-1.482287750E+002,-6.440737915E+001,-1.482287750E+002,-1.482287750E+002, [...]
Trace results for power measurement
Frequency | Power level
-1.482287750E+002 | -6.440737915E+001
-1.482287750E+002 | -1.482287750E+002
-1.482287750E+002 | -6.440737915E+001
... | ...


Measurement 2: Determining the Spectrum Emission Mask

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Programming Examples (TD-SCDMA BTS) > Measurement 2: Determining the Spectrum Emission Mask
Measurement 2: Determining the Spectrum Emission Mask
//------- Preparing the instrument ------------
//Reset the instrument
*RST
//Activate a TD-SCDMA BTS measurement channel named "BTSMeasurement"
INST:CRE:NEW BTDS,'BTSMeasurement'
//Set the reference level to 0 dBm
DISP:TRAC:Y:SCAL:RLEV 0
//Set the center frequency to 2.1175 GHz
FREQ:CENT 2.1175 GHz
//Select the spectrum emission mask measurement
CONF:CDP:MEAS ESP

//--------Configuring the measurement ----------------
//Set the slot range to analyze downlink data from slots 3 to 7 (switching point = 2)
SENS:POW:ACH:SLOT:STAR 3
SENS:POW:ACH:SLOT:STOP 7
//Automatically set the reference level and trigger to frame values according
//to measured levels and time.
SENS:POW:ACH:AUTO:LTIM

//----------Performing the measurement -----------------
//Stops continuous sweep
INIT:CONT OFF
//Sets the number of sweeps to be performed to 10
SWE:COUN 10
//Start a new measurement with 10 sweeps and wait for the end
INIT;*WAI

//-------------Retrieving results --------------------------
//Retrieves the calculated channel power value of the reference channel
CALC:MARK:FUNC:POW:RES? CPOW
//Result: -36.013 [dBm]
//Queries the result of the limit check
CALC:LIM:FAIL?
//Result: 0 [passed]
//Retrieves the peak list of the spectrum emission mask measurement
TRAC:DATA? LIST
//Result:
//+1.000000000,-1.275000000E+007,-8.500000000E+006,+1.000000000E+006,+2.108782336E+009,
//-8.057177734E+001,-7.882799530E+001,-2.982799530E+001,+0.000000000,+0.000000000,+0.000000000,

//+2.000000000,-8.500000000E+006,-7.500000000E+006,+1.000000000E+006,+2.109000064E+009,
//-8.158547211E+001,-7.984169006E+001,-3.084169006E+001,+0.000000000,+0.000000000,+0.000000000,

//+3.000000000,-7.500000000E+006,-3.500000000E+006,+1.000000000E+006,+2.113987200E+009,
//-4.202708435E+001,-4.028330231E+001,-5.270565033,+0.000000000,+0.000000000,+0.000000000,

 [...]
Trace results for Relative Code Domain Power measurement
Range No. | Start freq. [Hz] | Stop freq. [Hz] | RBW [Hz] | Freq. peak power [Hz] | Abs. peak power [dBm] | Rel. peak power [%] | Delta to margin [dB] | Limit check result | - | - | -
1 | +1.000000000 | -1.275000000E+007 | -8.500000000E+006 | +1.000000000E+006 | +2.108782336E+009 | -8.057177734E+001 | -7.882799530E+001 | -2.982799530E+001 | +0.000000000 | +0.000000000 | +0.000000000
2 | +2.000000000 | -8.500000000E+006 | -7.500000000E+006 | +1.000000000E+006 | +2.109000064E+009 | -8.158547211E+001 | -7.984169006E+001 | -3.084169006E+001 | +0.000000000 | +0.000000000 | +0.000000000
3 | +3.000000000 | -7.500000000E+006 | -3.500000000E+006 | +1.000000000E+006 | +2.113987200E+009 | -4.202708435E+001 | -4.028330231E+001 | -5.270565033 | +0.000000000 | +0.000000000 | +0.000000000
... | ... |  |  |  |  |  |  |  |  |  |


Measurement 3: Measuring the Relative Code Domain Power

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Programming Examples (TD-SCDMA BTS) > Measurement 3: Measuring the Relative Code Domain Power
Measurement 3: Measuring the Relative Code Domain Power
//------- Preparing the instrument ------------
//Reset the instrument
*RST
//Activate a TD-SCDMA BTS measurement channel named "BTSMeasurement"
INST:CRE:NEW BTDS,'BTSMeasurement'
//Set the reference level to 10 dBm
DISP:TRAC:Y:SCAL:RLEV 10
//Set the center frequency to 2.1175 GHz
FREQ:CENT 2.1175 GHz
//Optimize the scaling of the y-axis for the current measurementDISP:TRAC:Y:SCAL:AUTO ONCE

//-------Configuring CDA -----------------

//Capture 32 slots in 1 set
SENS:CDP:SET:COUN 1
SENS:CDP:IQL 32
//Invert Q-branch of signal
SENS:CDP:QINV ON
//Base station uses scrambling code 16
SENS:CDP:SCOD 16
//Maximum number of users on base station is 8
SENS:CDP:MSH 8
//Synchronize to phase reference of midamble in slot
SENS:CDP:STSL ON
//Allow for phase rotations between channels.
SENS:CDP:STSL:ROT ON
//Power threshold for active channel is -10 dB compared to total signal
SENS:CDP:ICTR -10
//Automatic channel search for modulation up to 8PSK.
SENS:CDP:MMAX PSK8
CONF:CDP:CTAB OFF

//--------Defining the evaluation range and result displays ----------
//Analyze slot 3 in set 0.SENS:CDP:SET 0
SENS:CDP:SLOT 3
//Set code 3 (for SF 16) as current code.
SENS:CDP:CODE 3
//Define relative power values
SENS:CDP:PDIS REL

//----------Performing the measurement -----------------
//Stops continuous sweep
INIT:CONT OFF
//Sets the number of sweeps to be performed to 10
SWE:COUN 10
//Start a new measurement with 10 sweeps and wait for the end
INIT;*WAI

//-------- Retrieving results----------
//Retrieve the relative code domain power
CALC:MARK:FUNC:CDP:BTS:RES? CDPR
//Result: 0 [dB]
//Retrieve the trace data of the code domain power measurement
TRAC:DATA? TRACE1
//Result: +8.000000000,+0.000000000,-4.319848537,-3.011176586,+0.000000000,
//+2.000000000,+1.000000000,-4.318360806,-3.009688854,+1.000000000,
//+8.000000000,+0.000000000,-7.348078156E+001,-7.217211151E+001,+1.000000000,
// [...]

//----------Synchronizing the Reference Frequencies-------------------------
//Select the external frequency from the REF INPUT 1..20 MHZ connector as a reference
//ROSC:SOUR EXT10

//Query the carrier frequency error
CALC:MARK:FUNC:CDP:BTS:RES? FERR
//Result: 0.1 [Hz]
Trace results for Relative Code Domain Power measurement
Code class | Channel no. | Abs. power level [dBm] | Rel. power level [%] | Timing offset [chips]
+8.000000000 | +0.000000000 | -4.319848537 | -3.011176586 | +0.000000000
+2.000000000 | +1.000000000 | -4.318360806 | -3.009688854 | +1.000000000
+8.000000000 | +0.000000000 | -7.348078156E+001 | -7.217211151E+001 | +1.000000000
... | ... |  |  |


Measurement 4: Triggered Measurement of Relative Code Domain Power

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Programming Examples (TD-SCDMA BTS) > Measurement 4: Triggered Measurement of Relative Code Domain Power
Measurement 4: Triggered Measurement of Relative Code Domain Power
//------- Preparing the instrument ------------
//Reset the instrument
*RST
//Activate a TD-SCDMA BTS measurement channel named "BTSMeasurement"
INST:CRE:NEW BTDS,'BTSMeasurement'
//Set the reference level to 10 dBm
DISP:TRAC:Y:SCAL:RLEV 10
//Set the center frequency to 2.1175 GHz
FREQ:CENT 2.1175 GHz

//--------Configuring the measurement ----------------
//Set the trigger source to the external trigger
//(TRIGGER INPUT connector on the front panel)
TRIG:SOUR EXT
//Optimize the scaling of the y-axis for the current measurement
DISP:TRAC:Y:SCAL:AUTO ONCE

//----------Performing the measurement -----------------
//Stops continuous sweep
INIT:CONT OFF
//Sets the number of sweeps to be performed to 10
SWE:COUN 10
//Start a new measurement with 10 sweeps and wait for the end
INIT;*WAI

//-------------Retrieving results --------------------------
//Retrieve the trigger to frame (the offset between trigger event and
// start of first captured frame)
CALC:MARK:FUNC:CDP:BTS:RES? TFR
//Result: 0.00599987013 [ms]

//------- Compensating a delay of the trigger event to the first captured frame -------

//Change the trigger offset to 100 us (=trigger to frame value)
TRIG:HOLD 100 us
//Retrieve the trigger to frame value
CALC:MARK:FUNC:CDP:BTS:RES? TFR
//Result: 0.00599987013 [ms]


Measurement 5: Measuring the Composite EVM

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Programming Examples (TD-SCDMA BTS) > Measurement 5: Measuring the Composite EVM
Measurement 5: Measuring the Composite EVM
//------- Preparing the instrument ------------
//Reset the instrument
*RST
//Activate a TD-SCDMA BTS measurement channel named "BTSMeasurement"
INST:CRE:NEW BTDS,'BTSMeasurement'
//Set the reference level to 10 dBm
DISP:TRAC:Y:SCAL:RLEV 10
//Set the center frequency to 2.1175 GHz
FREQ:CENT 2.1175 GHz

//--------Configuring the measurement ----------------
//Set the trigger source to the external trigger
//(TRIGGER INPUT connector on the front panel)
TRIG:SOUR EXT
//Replace the second measurement window (Result Summary) by Composite EVM evaluation
LAY:REPL '2',CEVM
//Optimize the scaling of the y-axis for the Composite EVM measurement
DISP:WIND2:TRAC:Y:SCAL:AUTO ONCE

//----------Performing the measurement -----------------
//Stops continuous sweep
INIT:CONT OFF
//Sets the number of sweeps to be performed to 10
SWE:COUN 10
//Start a new measurement with 10 sweeps and wait for the end
INIT;*WAI

//-------------Retrieving results --------------------------
//Retrieve the trace data of the composite EVM measurementTRAC2:DATA? TRACE1

//Result: +0.000000000,+5.876136422E-001,
//+1.000000000,+5.916179419E-001,
//+2.000000000,+5.949081182E-001,
//[...]
Trace results for Composite EVM measurement
(CPICH) Slot number | EVM
0 | +5.876136422E-001
1 | +5.916179419E-001
2 | +5.949081182E-001
... | ...


Measurement 6: Determining the Peak Code Domain Error

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Programming Examples (TD-SCDMA BTS) > Measurement 6: Determining the Peak Code Domain Error
Measurement 6: Determining the Peak Code Domain Error
//------- Preparing the instrument ------------
//Reset the instrument
*RST
//Activate a TD-SCDMA BTS measurement channel named "BTSMeasurement"
INST:CRE:NEW BTDS,'BTSMeasurement'
//Set the reference level to 10 dBm
DISP:TRAC:Y:SCAL:RLEV 10
//Set the center frequency to 2.1175 GHz
FREQ:CENT 2.1175 GHz

//--------Configuring the measurement ----------------
//Set the trigger source to the external trigger
//(TRIGGER INPUT connector on the front panel)
TRIG:SOUR EXT
//Replace the second measurement window (Result Summary) by the
//Peak Code Domain Error evaluation
LAY:REPL '2',PCD
//Optimize the scaling of the y-axis for the Composite EVM measurement
DISP:WIND2:TRAC:Y:SCAL:AUTO ONCE

//----------Performing the measurement -----------------
//Stops continuous sweep
INIT:CONT OFF
//Sets the number of sweeps to be performed to 10
SWE:COUN 10
//Start a new measurement with 10 sweeps and wait for the end
INIT;*WAI

//-------------Retrieving results --------------------------
//Retrieve the trace data of the Peak Code Domain Error measurement
TRAC2:DATA? TRACE1
//Result: +0.000000000,-6.730751038E+001,
//+1.000000000,-6.687619019E+001,
//+2.000000000,-6.728615570E+001,
// [...]
Trace results for Peak Code Domain Error measurement
Slot number | Peak Error
0 | -6.730751038E+001
1 | -6.687619019E+001
2 | -6.728615570E+001
... | ...


Measurement 7: Checking the Power vs Time

TD-SCDMA Measurements (R&S FSW-K76/-K77) > Remote Commands for TD-SCDMA Measurements > Programming Examples (TD-SCDMA BTS) > Measurement 7: Checking the Power vs Time
Measurement 7: Checking the Power vs Time

This example demonstrates how to check the signal power in the time domain against a transmission power mask defined by the TD-SCDMA specification in a remote environment (for details see "Power vs Time").

//------- Preparing the instrument ------------
//Reset the instrument
*RST
//Activate a TD-SCDMA BTS measurement channel named "BTSMeasurement"
INST:CRE:NEW BTDS,'BTSMeasurement'
//Set the center frequency to 2.1175 GHz
FREQ:CENT 2.1175 GHz
//Select the power vs time measurement
CONF:CDP:MEAS PVT

//--------Configuring the measurement ----------------
//Set the switching point to 2 to analyze downlink data in slots 3 to 7
CONF:CDP:PVT:SPO 2
//Set the number of subframes to average to 50.
CONF:CDP:PVT:SFR 50
//Automatically set the reference level and trigger to frame values according
//to measured levels and time.
SENS:POW:ACH:AUTO:LTIM
//Add a second measurement window for the list evaluation
LAY:ADD '1',BEL,LEV

//----------Performing the measurement -----------------
//Stops continuous sweep
INIT:CONT OFF
//Start a new measurement with 10 sweeps and wait for the end
INIT;*WAI

//-------------Retrieving results --------------------------
//Query the result of the limit check for the 50 subframes against the
//transmission power mask
CALC:LIM:FAIL?
//Retrieve the calculated peak power value of the 50 subframes
//CALC:MARK:FUNC:POW:RES? PPOW
//Result: -1.02 [dB]
//Retrieve the trace data of the power vs time measurement
TRAC:DATA? TRACE1
//Result: -1.201362252,-1.173495054,-1.187217355,-1.186594367,-1.171583891,
//-1.188250422,-1.204138160,-1.181404829,-1.186317205,-1.197872400, [...]
Trace results for power vs time measurement
Subframe | Power level
-1.201362252 | -1.173495054
-1.187217355 | -1.186594367
-1.171583891 | -1.188250422
... | ...


List of Remote Commands (TD-SCDMA)

TD-SCDMA Measurements (R&S FSW-K76/-K77) > List of Remote Commands (TD-SCDMA)
List of Remote Commands (TD-SCDMA)
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:LEVel
[SENSe:]AVERage:COUNt
[SENSe:]CDPower:CODE
[SENSe:]CDPower:FILTer[:STATe]
[SENSe:]CDPower:ICTReshold
[SENSe:]CDPower:IQLength
[SENSe:]CDPower:LEVel:ADJust
[SENSe:]CDPower:MMAX
[SENSe:]CDPower:MSHift
[SENSe:]CDPower:NORMalize
[SENSe:]CDPower:PDISplay
[SENSe:]CDPower:PTS
[SENSe:]CDPower:QINVert
[SENSe:]CDPower:SCODe
[SENSe:]CDPower:SET
[SENSe:]CDPower:SET:COUNt
[SENSe:]CDPower:SLOT
[SENSe:]CDPower:STSLot
[SENSe:]CDPower:STSLot:MODE
[SENSe:]CDPower:STSLot:ROTate
[SENSe:]CDPower:SULC
[SENSe:]CDPower:TREF
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet
[SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]POWer:ACHannel:AUTO:LTIMe
[SENSe:]POWer:ACHannel:SLOT:STARt
[SENSe:]POWer:ACHannel:SLOT:STOP
[SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]SWEep:COUNt
ABORt
CALCulate:LIMit<k>:FAIL?
CALCulate:MARKer:FUNCtion:CDPower:RESult?
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:STATistics:RESult<t>?
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:FEED
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>[:STATe]
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
CONFigure:CDPower:CTABle:CATalog?
CONFigure:CDPower:CTABle:COMMent
CONFigure:CDPower:CTABle:COPY
CONFigure:CDPower:CTABle:DATA
CONFigure:CDPower:CTABle:DELete
CONFigure:CDPower:CTABle:MSHift
CONFigure:CDPower:CTABle:NAME
CONFigure:CDPower:CTABle:ORDer
CONFigure:CDPower:CTABle:SELect
CONFigure:CDPower:CTABle[:STATe]
CONFigure:CDPower:MEASurement
CONFigure:CDPower[:BTS]:PVTime:LIST:RESult?
CONFigure:CDPower[:BTS]:PVTime:LIST[:STATe]
CONFigure:CDPower[:BTS]:PVTime:SFRames
CONFigure:CDPower[:BTS]:PVTime:SPOint
DIAGnostic:SERVice:NSOurce
DISPlay:FORMat
DISPlay:MTABle
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe
FORMat[:DATA]
INITiate:CONMeas
INITiate:CONTinuous
INITiate:REFResh
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:DIQ:CDEVice
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
INPut:SELect
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
OUTPut:DIQ
OUTPut:DIQ:CDEVice
OUTPut:IF:IFFRequency
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth
STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:PTRansition
STATus:QUEStionable:SYNC[:EVENt]?
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon[:STATe]
TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]?
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce


Legal Notice

R&S®FSW-K76/K77
TD-SCDMA Measurements Options

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.